Backups fail on certain folder names (p2p, .bin, etc.)

Trying to use Bvckup2 to back up to my EX4. It’s an rsync like backup. Some of my folders being backuped up have interior names like .bin and p2p, and the EX4 fails with a “file not found” when a folder with one of those names is created. Using Windows Explorer, I get the same error if, for example, I go into one of the shares on my EX4 and try to create a folder called p2p anywhere in the folder hierarchy.

I understand these are reserved names as far as the share name goes (e.g the root folder), but I would think it’s a bug if an interior folder is also not allowed to have certain names… how could you ever use an EX4 for a file based backup?

Am I missing something obvious here?

Seems perhaps related to this old problem:

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

This is the best method to confirm if the reservations are still in effect.

Firmware update (from 1.0.2. something I believe…) to 2.10.302 solved the problem. The unit was in some sort of odd state - it appeared it had tried to update itself, but was unable to reboot. Even pressing and holding the power button, or the reset (paper clip) wouldn’t reboot the unit. Had to pull the power for 20 seconds and then replug in the thing… then was able to download/install new firmware as would be expected from within the device web interface. After new firmware and a reboot of the EX4, I had to reboot my PC to get access to it again. Just for fun (or as if to mock me), when I rebooted my PC, windows decided that would be a good time to apply a bunch of updates. So not sure if the bug was in the old firmware (probably) or some sort of byproduct of the odd state the device was in… but problem is solved.

I might also add for a benefit to others… the firmware on my newly purchased EX4 (purchased from WD via Amazon) seemed to be at least two years out of date (and the unit’s auto firmware update process aparently didn’t work), so required some manual efforts to get it current.

I have an EX4100 with firmware version 2.11.140 and you still cannot make a folder named uploaded anywhere in the file system. I understand not allowing special characters * ? / \ as these serve a purpose as wildcards and directory and filename separators, but I don’t see any reason to reserve a folder name. Do you have any idea how stupid it sounds to go to a user and say “I’m sorry, but you can’t name the folder that has all the docs that have already been uploaded, “uploaded”, it’s a reserved directory name.”

Is there any resolution to allowing “uploaded” as a filename or directory? A workaround? I have ensured my firmware is updated. I’m not in the position to change the original name nor do I want to skip the folder.