Backup failed - "Please check system settings"

I am trying to copying my existing data to the device. The existing data is on an external drive and I have it plugged into one of the USB ports on the back. I created a USB Backup job, but it failed. What is a little strange is it has reproduced a portion of the original source path inside the destination folder. The destination path is supposed to be…


it has added on an additional ‘Expansion_Desk-1\VZ-Cloud’ from the source path. Can anyone help me with this?

Now I cannot access the EX4 and of coarse the drive lights are flashing. 


Have you tried resetting the unit and trying to run the backup again?

Um… Yea… Is that the best advise you have? That’s hardly a solution. Other people are working on files located on the drive. If I cant even do a simple USB backup, this is completely useless. 

1 Like

There is a fault in the device firmware which, according to my investigation, is due to the use ot the “timeout” parameter in the rsync command.  This timeout value is sepcified as 30 seconds which is not sufficient for large or complex backups.  I have logged this fault with WD but have not had any followup from them.

In my case I have proved that the same rsync command with a larger timeout value works.

Below is my SSH script to further illustrate the fault.

rsync --timeout=30 --job-name=FooBar --delete /mnt/HD/HD_FooBar/ /mnt/USB/USB1_FooBar

du: write error


rsync: writefd_unbuffered failed to write 788 bytes to socket [sender]: Broken pipe (32)

rsync error: timeout in data send/receive (code 30) at io.c(1530) [sender=3.0.7]

rsync --timeout=60 --job-name=FooBar --delete /mnt/HD/HD_FooBar/ /mnt/USB/USB1_FooBar



So how do I change that timeout to 60?

1 Like