Backup does not resume after PC switched off

Even with both the PC and MtCloud device connected to the router by a cable, the backup was very slow. I estimate it would take about 40 hours to complete my 119Gb of files. I switched off the PC after about 10 hours obviously stalling the backup, but it does not resume when I switch back on. I have over 274,000 files to be backed up and it is stuck on about 138,000.  If I leave everything switched on for several hours, the counter of backed up files hardly moves at all.  In fact it sometimes seems to count backwards! I have tried altering from timed to constant backup and back to constant, but nothing seems to work. It seems to me the Smartware could do with a button to pause/resume backup.

Hello and welcome to the WD community.

Try to disable and re enable the backup and see if this fixes the issue. Also try to re install the software from scratch. If you try this and get the same results, i recommend to contact support:

I identified the problem myself. Norton backup was creating a backup set on my C drive, which was extremely large. I have cancelled the Norton backup set and deleted the old files, which now reside on MyCloud.  Not only has MyCloud successfully backed up all files, but I now have considerably more room on my C drive.  Hopefully the PC will run much quicker too, which will be a bonus. I also deleted all the old bloat-ware, so there is much less junk to back up.