Backdrops Locally – How to display with Internet OFF & Media Library off

I have been struggling to get this going. Have created moviesheet and edited the .xml file

Taking out all the and lines, then replacing with one line avatar_sheet.jpg

avatar_sheet.jpg is in the same folder as movie and .xml file.

It still would not display, then later when I had the internet on ( Hub switched on ) it appeared.

Therefore I must of edited the .xml file correctly.

This I do not understand, if the reference to the file in .xml is local, why do I need the internet on. It is silly to have the internet on just to view a local file

I found this thread, in “Live Streaming Ideas” with the a reference to same problem. :-

Your WDTV Live SMP’s NIC interface must have a valid IP address for the local backdrops to display even though you are not actually using the Wired or WiFi connection to display the locally stored Backdrops! - This beats me

This is a clue, so is there any new knowledge tips to achieve this with Internet off and media library off.

Is it possible to manually set any ip address in the SMP NIC Interface ? and will that be a problem when I turn the network on.

Even so a better solution if possible would be better

Any help and guidance – much appreciated.

Hello Tony0204,

I am the author of that statement that you found in the ideas section and your observations are correct, The WDTV Live SMP needs to have a active NIC interface to display the locally avaliable backdrops. - Yep! it still beats me :angry:

You must have already got the clue that as long as the NIC interface has a valid IP address (It must also have a physical link) you are good to go.

My suggestion for you would be to use the WIRED Ethernet, Just plug it to your Switch or router and use “Manual Settings”  to setup a “STATIC IP” address and put some IP address that necessarily does not go anywhere on the Internet. So you can enjoy the locally available Backdrops.

When you really need to access Online Services, you can always use network setup and select automatic to make the WIRED or WIFI use the DHCP method to populate the IP address and DNS entries.

In my tests I found that it works just okay even when the Media Library is turned OFF


Thanks Vistawall for help / confirmation. I guess WD would say storing Backdrops locally is not the way it was designed, but it does seem silly and a pity that the router needs to be on, my parents do not have there router on most of the time ( don’t need it). So would like the SMP to be totally self contained – independent. Of course you can still play your movies, but showing the backdrops makes it look a great deal better.

If any other knowledge come to light – would be really interested. Thanks again


I can understand your situation, But with some creative thinking you can get around that problem :smileyvery-happy:

Just Google for “RJ-45 Ethernet Loopback Plug” and buy one and plug it into the ETHERNET port, When your parents have turned off  the router in the house, You can switch to the ETHERNET wired port and setup a dummy Static IP address! :wink: so that you can view the locally available Backdrops!

If you are electrically inclined, you can build one yourself, just make sure that you cross pins in this fashion

RJ45 cable

PIN 1 Tx[+]   —  to PIN 3 RX [+]

PIN 2 Tx [-]   —  to PIN 6 Rx  [-]


1 Like

Brilliant, will give it a try over the weekend. Thanks

tony0204 wrote:

Brilliant, will give it a try over the weekend. Thanks

Please, keep us updated on yoyr progress.


Made the loop back Ethernet plug and plugged into SMP.

With my router off i.e. no wireless network. Switched on SMP

The SMP assigned it own ip address and subnet.

The movie that I had put a moviesheet.jpg in the same folder as the movie and edited the .xml file appropriately showed up as the backdrop, along with the metadata – Great.

Then in Gallery view scrolling along to some other movies which previously I used the “Get Info” for Background and Metadata – to my delight that worked as well.

The .xml files are original created by SMP and still referenced to the net.

I did find it odd that they are all kept in a .background folder ( cached I guess) and previously assumed that they were not used, because when my wireless network was off, they did not display. Since the references are to the net I assumed that it got the images each time ( which did seem silly ).

I think the reality is that the pics from .background are used once they are cached, it is just that background pictures are not displaced unless a valid ip address is available. Whether the SMP actually needs it or not.

Then turned everything off ( left the loopback connector in ) and turned on the wireless network, - switched on the SMP. It detected my wireless network, all operated as normal. Powered off – turned off Wireless network – switched on SMP – backdrops ( locally saved and web based ) still all showing.

So thanks, Vistawall - really worthwhile doing. So once setup with all your backdrops , metadata it is not necessary to have the web on, to enjoy the view

Thanks for your feedback!  - I am happy it all worked out well for you. :smiley:

The WDTV LIVE HUB with FW Release 3.01.19 (12/20/11) has this issue fixed, You do not need to have your Ethernet Adapter active now to view locally stored Backdrops. I will test the latest release of  FW **Release 1.05.18 (12/20/2011) **on WDTV Live SMP and give feedback soon. I am sure this would have been implemented on the WDTV Live SMP too.