Avi-file and sound by mp3


#1

I cannot play most of my avi files.

They are xvid with embedded mp3 audio:

WD TV Live says:

Unsupported …

Is thats true, I cannot believe ist


#2

Something is likely wrong with the encoding. How many reference frames did you use when you encoded them? Can you provide a media info?


#3

i have this same issues i got a few dvd rips that have XVID MPEG-4 video codec and MPEG 1 Audio, Layer 3 (MP3) audio codec and it doesnt play, but i have another dvd with with MPEG-4 but AC-3 audio and its working fine.

the specs doesnt say anything about certain codec combinations not working, it just simply lists all video and audio codecs that are supported and AVI container with MP4 and audio MP3 are both supported.

so what gives?

i just purchased this and it immediatly prompted me for a firmware update, how ever after looking around this forum it seems that this newer firmware is causing issues, could it simply be that i need to downgrade teh firmware?


#4

actually i just checked another file and it has mp3 audio codec, so im really stumped, heres a side by side of 3 different files, zombieland doesnt work, the other 2 do

http://i48.tinypic.com/11h5mpk.png


#5

Found playing same avi-file from USB stick will be fine.

So there must be a filesharing issue.


#6

yeah, i actually just tried that out, an that file does work when i play it from a USB connected to the WD TV Live device.

but i dont understand why the twilight zone episodes i have which use the same video/audio codecs in AVI container play thru my network but not movies, cause i actually tried one other movie i have that uses MP3 an it doesnt work either.

hopefully they figure this out an fix it in the next firmware update, or if someone knows that this newer update is whats causing this, id downgrade but searching the firmware section of the site i cant find older versions, only the latest one. unless i reset the device i guess…