Avatar BluRay - M2TS - Playback stutters


#1

Hi! I’ve bought an WD Live TV. Works so far w/o any problems for me :slight_smile: I wanted also try playing directly m2ts from my bluray iso, but it seems not to work well. The first 15-30 seconds of playback are fine. Afters this, the sound ist complete gone, the video is stuttering. Using official lastest firmware. (also tried the lastest beta firmware) Its the WD Live TV to slow to decode it?


#2

Welcome to the forums.

Could very well be too much.  How are you serving the data?  (Directly wired or wireless?)

My Handbrake encoded Avatar blu-ray works perfectly, but that’s quite a bit less data (even though the image is indistinguisable from the original even on my HD 9’ screen).  But I’m not even sure that I could serve *that* wirelessly (I’m hard wired into my NAS).


#3

Hi, it is directly connected to my switch via lan. I am not using wlan. My bluray iso is an 1:1 copy made with anydvd. So I’ve changed nothing in the iso. Its about ~ 46GB.


#4

ConiKost wrote:
Hi, it is directly connected to my switch via lan. I am not using wlan. My bluray iso is an 1:1 copy made with anydvd. So I’ve changed nothing in the iso. Its about ~ 46GB.

The good news is: it is your setup. The WDTV live can perfectly play the highest bitrates out there without stutter. The ‘bad’ news is that you might have to switch to homebrew, for the real high bitrates, since the WDTV Live’s stock FW uses the ‘samba’ protocol for sharing over the network and that protocol isn’t fast enough for mediaplayers to handle the 40 Mbit theoretical maximum of bluray. You’ll need to use homebrew FW for that and then enable NFS sharing.

Anyway, first make sure if it’s your network: try playing from USB. Then go from there. Copy a movie over the network to test (to an USB drive attached to your WDTV), if it doesn’t even get to 25 Mbit (so 3 MB/s), then you have network problems. If you do get 25 Mbit AND you’ve made sure that it plays fine from USB, then you’ll need to install homebrew and use NFS sharing.


#5

BTW, I just tested it myself: I copied a 715 MB file to my hdd attached to the WDTV live (via the regular network sharing, as supported by WD (samba))., It took 110 seconds, so an average of 6.5MB = 52 Mbit/s, which IN THEORY should be enough to play *any* bluray file, since bluray has a theoretical maximum of 40 Mbit. However I have at least 1 high bitrate file that stutters over the regular SAMBA protocol and plays fine over NFS. So even if you  get, like me, an average that’s theoretically enough, that doesn’t mean the file will play perfect. Maybe the throughput is not stable enough to sustain 40 mbit over a longer period (or maybe playing a video itself will strain the chipset so much that the throughput lowers)


#6

LOL, I just found the reason why I got stuttering :slight_smile: The theoretical max I was referring to is for *data*. Video has a theortical max of 54 Mbps. Since I’m getting 52 Mbps in the test I just did, that explains the stuttering

http://www.pcworld.com/article/128205/bluray_frequently_asked_questions.html

“The 1X data-transfer rate for Blu-ray Disc is 36 megabits per second for data and 54 mbps for movies”

So, to solve it: use the homebrew FW and share via NFS. That will get you around 75-80 Mbit and that’s enough to play ANY bitrate stutter free over the network.


#7

Or just re-encode the movie using Handbrake (and the High Profile preset) and be done with it.

Perfect image, and audio, and will play perfectly.  The one and only drawback is time (depending on your machine could take anywhere from 2 1/2 hours to all day – it took me a touch under 4 hours to encode.  But what’s your machine doing when you sleep/work anyway?).


#8

mkelley wrote:

Or just re-encode the movie using Handbrake (and the High Profile preset) and be done with it.

 

 

Hehe. Not everybody likes re-encoding so much as you do, Mike :wink:


#9

LOL.  Yep, you’re right there.  (But I sure do like having all my stuff play perfectly without any effort)


#10

mkelley wrote:

LOL.  Yep, you’re right there.  (But I sure do like having all my stuff play perfectly without any effort)

Yes-In-friggin’deedy.

A few hours (days?) spent doing batch encodings while you sleep is WORTH the No-hassle, plays 100% perfectly every time result.  (Except for the occasional Transparent Subtitles, before Cocovana jumps in… :slight_smile:  )


#11

Well, on a serious note, it’s not only the time it takes that I don’t like about re-encoding (one could that at night indeed) but more importantly, the quality loss that’s inherent of re-encoding to for example lower bitrates. And besides, using homebrew FW there’s really no need to re-encode (except for some MP4’s and of course trueHD audio)


#12

Well, there you are wrong.

Blu-ray content in particular is not encoded very efficiently – the H264 codec has improved so much over the last few years that it truly is the equal of MPEG2 at a much smaller factor.

I’ve done A/B tests and my friends can not tell the difference on my reference quality monitors between the blu-ray original and my encoded source – so that’s a straw man argument.

So – the time is the one and only reason someone should not re-encode.  And with fast machines I don’t see that as much of a problem (I do three or four movies a night at times – that’s more than I can possibly watch in a day :slight_smile:


#13

mkelley wrote:

Well, there you are wrong.

 

Blu-ray content in particular is not encoded very efficiently – the H264 codec has improved so much over the last few years that it truly is the equal of MPEG2 at a much smaller factor.

 

I’ve done A/B tests and my friends can not tell the difference on my reference quality monitors between the blu-ray original and my encoded source – so that’s a straw man argument.

 

So – the time is the one and only reason someone should not re-encode.  And with fast machines I don’t see that as much of a problem (I do three or four movies a night at times – that’s more than I can possibly watch in a day :slight_smile:

Well, merely switching lossy codecs alone equals quality loss, since it’s another encoding pass and every lossy encoding pass loses quality (try converting an MP3 back to wav and encode it to MP3 again, same thing).

I’m not sure if it would be easy to spot though, in fact, maybe you’re right and maybe it IS very difficult to spot differences, I don’t know, but I’d like to be safe and don’t lose any info at all.


#14

Information is lost, but it’s information that can’t be seen anyway.  A good analogy you’ve already made – an MP3 encoded at high quality from a .WAV “original”.  The “original” ain’t original – it’s just the best we can get with recording equipment but it’s also a loss from Real Life.  The point is that you can toss a lot of that information away (with a high quality re-encode to MP3) and it’s impossible to hear the difference.

The same is true of blu-ray – the codec is so inefficient that it’s easily re-encoded and the information that was there just isn’t missed.  I was skeptical at first myself, but after doing extensive tests with side by side comparisons of the blu-ray original and the re-encode on my 9’ HD screen, I became a believer.

Now – beyond a certain point you will lose information.  This is why I recommend the High Preset.  Most folks say that using an RF factor of 22 (the “quality” slider in Handbrake – higher number being a lower quality, kind of like a golf score) is more than enough for blu-ray, but on my reference monitors I do notice a difference, so I leave it at 20 (the default on that preset).  But I can promise you there is *some* point at which no one could tell – you just have to find the sweet spot for yourself.

I don’t argue that it involves an extra step not all people want to do.  But it also promises complete compatibility with not only the Live but nearly every other device out there (since the MKV container is much more compatible than an M2TS one).  And the storage savings is nothing to sneeze at even in these days of huge drives (with my 3TB of NAS I have hundreds of movies but I’d have to vastly reduce that amount if they weren’t encoded by Handbrake).

The nice thing is it’s basically a no-brainer – Handbrake is that easy to use.  So, if people (like the original poster, to bring this back on point) have any issues at all, it’s something to try that doesn’t involve anything other than a little time.  If you don’t have any issues (and don’t mind the size of the file) then by all means do not re-encode.


#15

mkelley wrote:

Information is lost, but it’s information that can’t be seen anyway.  A good analogy you’ve already made – an MP3 encoded at high quality from a .WAV “original”.  The “original” ain’t original – it’s just the best we can get with recording equipment but it’s also a loss from Real Life.  The point is that you can toss a lot of that information away (with a high quality re-encode to MP3) and it’s impossible to hear the difference.

 

Sure, there’s a certain bitrate where it becomes hard to tell the difference. I can tell the difference between an 164 kbps MP3 and the original WAV but higher than that, I really don’t hear differences anymore (192 kbps equals lossless to my ears). However, if you re-encode 192 kbps to 192 kpbs (so that it ‘decompresses’ to WAV and then encodes AGAIN) loses extra info and THEN it becomes noticeable again. I’m afraid same thing goes with re-encoding video, even at the highest bitrates, but I must admit I haven’t really been experimenting with re-encoding video myself (because it’s not needed).

If it works for you and you don’t notice any difference, then that’s of course perfectly fine.


#16

You know what, actually I’m going to try it :slight_smile: What settings should I use in handbrake ?


#17

There ya go!  That’s the spirit!  Take the Pepsi Challenge for yourself!

Use the HIGH PROFILE Preset, change the RF to 20 to 22 (20 is better, but bigger, 22 will create noticable artifacts but will yield a smaller file.)  Change the output to h.264 in an MKV container.   Go to the audio tab and select whichever tracks you want and mark them to PASSTHRU under the Codec section.  

If you want subtitles, you’ll have to manually strip them out using something like BDSup2Sub, then re-mux them back in using MKVMerge.   DONT FORGET:  Avatar has FORCED SUBTITLES when the Smurfs talk.

Click start, go to bed.  :)


#18

TonyPh12345 wrote:

There ya go!  That’s the spirit!  Take the Pepsi Challenge for yourself!

 

Use the HIGH PROFILE Preset, change the RF to 20 to 22 (20 is better, but bigger, 22 will create noticable artifacts but will yield a smaller file.)  Change the output to h.264 in an MKV container.   Go to the audio tab and select whichever tracks you want and mark them to PASSTHRU under the Codec section.  

 

If you want subtitles, you’ll have to manually strip them out using something like BDSup2Sub, then re-mux them back in using MKVMerge.   DONT FORGET:  Avatar has FORCED SUBTITLES when the Smurfs talk.

 

Click start, go to bed.  :)

Hehe, cool, I’m going to try it on the ultimate bench marking scene: the famous ‘pole to pole - birds scene’. Will encode tonight and see if I can spot any differences later on. I love pepsi challenges ! :slight_smile:


#19

I’d definitely use RF 20 (the default on the High Preset).  That’s my gold standard.

Note that using smaller numbers can actually increase the file size (something you obviously don’t want).  Anything smaller than 20 is insane for blu-ray material.

And then, for testing, get someone to play back the original and the encoded file but not let you know which is which – you then have to guess at least 10 times (they should play back each 5 times randomly).  In my tests NO ONE could pick correctly more than 50% of the time (about half the time my guests picked the encoded file as the “better” one).


#20

Thank You for your answers! I will try the Homebrew FW (I guess you mean the WDLXTV-Live Firmware?) But I don’t get it, why is samba so slow on the WDLiveTV? I’ve at home here Gigabit an get over Samba about ~ 35MB/s… much faster than the WDLiveTV can get…