Automatic Network not connecting


Just got a WDTVLiveHub yesterday and it won’t connect to my network.  I have a network running through a LinkSys WRT160N wireless router.  My WDTV is connected to my router by wire and the connection is good, tested by connecting Laptop to it.

When I run Network Setup\automatic I get the following error “Unable to obtain an IP address. The WD TV has limited or no network connectivity”.

My router is DHCP server enabled.



Were you able to access the WIRELESS CONFIGURATION MENU in Network Setup?

What model USB WiFi adapter did you choose?

Not useing Wi-Fi…trying to connect to network through ether net cable. 

Can you confirm that BOTH ends of the cable have LINK LIGHTs? 

Yep, the cable is good.  I can hook my laptop up to it and get the network just fine.

You sure your laptop isn’t using wireless whe. You do that test?

yep…i disable wireless adapter on laptop just to make sure.  Also reads as Lan connection in Network and sharing center.

Have you tried setting the IP information manually?

yep…I would assign it an IP address, subnet mask.  But then I get wrong DNS error…so I assigned a DNS (many differnt ones at many differnt times).  No luck…still DNS error.

My router is enabled for DHCP server, so I should not have to set up manualy.

Not sure if I set it up manualy the right way though, still learning.  Maybe you could tell me how to set up manualy?  See if I’m doing it right :slight_smile:

try using the same IP address for DNS as you used for Default Gateway.

no luck…still get Incorrect DNS server address error :frowning:

I’m having this same problem with mine. I’ve tried manually entering the IP and DNS and the DNS always fails. Yet, when I plug it in to my Airport router via a hardline, there isn’t a problem.

Don’t know if you stopped posting because you found a solution but if you did. Love to hear it.

I am going through exactly the same problem, but I am connecting via ethernet cable…so frustrating.

Just bought the WDTVLiveHub and having the same issue. “Unable to obtain an IP address”. Tried updating the firmware, same issue. Tried resetting to factory default, same issue. Tried setting up a static IP, it looks like it’s accepting it but you click OK and no network access.

So I tired un-connecting the WDTVLIVEHUB and connecting my WDTVLive to the same cable, it picks up an IP and connects to the network fine. Laptop same thing. So the cable and network work fine.

Decided to bring back the device and exchange it for a new one. Brought it home, set it up and same thing, this is becoming very frustrating…

so a post back or so I thought I read that you tried a static ip. After that was done you said you started getting DNS errors. Where did the primary DNS IP from? did you actually have the information. I know one person suggested pointing to the default gateway, however I suggest opening a command prompt and typing the command NSLOOKUP. That will give you the correct IP of your DNS server. THAT is the IP you want to use if you are going to use static settings.

I would also check your router to make sure that you have enough IP’s to issue via DHCP. Typically you will have 254 in a class “C” range, but as the admin of the router you can limit the amount of addresses that your router can give out as a sort of security feature.

As another test; try bridging the connections (wired and wireless) and connect the hub though your laptop just for giggles and see what you get.

Strange, I take the same cable and connect from the WDTVLIVEHUB to my Laptop that has a bridged network with the wireless and the WDTVLIVEHUB gets an IP. I connect the same cable back to my gigabit switch and it won’t pick up an IP. I turn off the wireless on the laptop and connect the same cable to the gigabit switch and it picks up an IP no problem.

Why won’t the WDTVLIVEHUB to get an IP from the switch. If I set the IP manually, it doesn’t work either. Very frustrating!!!

If a cable between your laptop and the hub works, then you must have a crossover cable. That’s not the right cable to hook up the hub to a switch. Look closely at the ends of the cable. Are the colors of the individual wires in the exact same order on both ends?

Hi TonyPh12345, I thought that with the newer switches, it did not mater any more if the cable was a patch or straight through? I thought they were auto-sensing, sorry if I am wrong, it will check when I get home tonight.

So last night I tried by-passing the switch altogether, just to see, and it connect no problem. Not an ideal situation since I need the switch for my other devices. I’ll check out the cables to see if that makes a difference.

That is true, some newer switches are “Auto-MDIX.”