Automatic Get Content Info No Longer Works

I have a 2TB USB drive connected to the WD Tv Live SMP. I have Get Content Info set to automatic.

In the past, whenever I uploaded files to the player via Windows File Sharing, the player would get the content info for the new files shortly after all by itself.

But now this no longer works. I have to manually get the content info for each file.

Any ideas how to fix this?


Hello,  change Get content info to Manual and then back to automatic. Also check if you have the latest firmware version. For more information check the following links. 

Page 193 of the manual

Firmware update

Firmware is current. I set Get Content Info to manual and then back to automatic. Made no difference.

Also check that you have media library turned on in settings.

Media Libray is enabled. I changed no settings in the player. The Get Content Info automatic updating just stopped working all by iteself.

Try resetting the player to factory defaults.

Is there a difference between using the reset function via the remote control and the reset button on the bottom of the unit? I don’t want to go thru resetting the unit up from scratch again twice.


I would try “Clearing the Media Library” before doing a “Factory Reset”

Setup > System > Media Library > Clear Media Library


This basically “Cleans” but does not delete your Media Library xml’s & posters and hopefully kick-in the Automatic Scan once completed.

You may however, lose any Favourited & Rated settings (which you would lose anyway doing a Factory Reset plus a lot of other settings)

I’m pretty sure I clered the Media Libray at least once trying to solve this before.

I have reset to factory defaults and reconfigured from scratch.

I’ll see what happens next time I upload files to the player’s attached USB hard drive.

another thing you could try…

if you have your movies sorted in into genre folders  eg. Action, Thriller, Comedy etc

try changing the folders name eg. Action Movies, Thrillers, Comedies etc

and see if the Automatic Scraper recognises these as New Content and starts to Auto scan

Each movie is in its own folder and all the folders are in a folder called movies which is in the root of the drive.

As I said, it used to get the content automatically in the past.

I uploaded a few more movies in their own folders, but so far it has not gotten the content info.

For what it’s worth I’m running into the same problem. Getting content info has always worked in the past but not today: instead I get a "network not available "error (which is wrong).  I read on another forum that this issue may be system-wide, related to the imdb api used by wd.  I’ll bear with them for now to see if they can resolve it. 


Have you tried to manually get info? Its working in the UK on my player.

Manually getting content has always worked here. No errors are thrown.

Exact same issue here in Switzerland :frowning:

TMDB shut down their old 2.1 API on September 15, 2013.  WD must update their firmware to use the v3 API.  Despite the advanced warnings from TMDB, WD didn’t do it and now fetching movie metadata from WDTV Live SMP is broken.

I have no doubt the WD engineers know about this but they have been silent on this issue.  I own 3 WDTV Live SMP devices and use the Media Library with movie metadata.  Since the old API was shut down, I just get “Network not available” when attempting to get content for movie titles.

It has been almost 3 months since the last firmware update.  I certainly hope WD’s next update will include the updated API.  If not, well…bye.

I don’t understand your situation. Are you saying even manual getting of content info was broken by the change inthe API? It certainly is not here. I can get the content manually just fine. I do net get “Network not available” at any time.

Gderf is correct. The SMP firmware has already been updated for the new TMDB API.

Hi all, I have set my settings to get content manually, and since a few days It’s alsow not longer working. I only get the “Network Not Available” message. I have the latest firmeware, any ideas? 


Im also having this issuse. But not on all movies?

The “no netwotk connection” is on “manual get content info”, but some movies are scanned automatic. And on some of the movies is is impossible to to get content (blockbusters both old and new).