Audio Sync issues with MKV files, Firmware: 2.08.13

Hi guys,

I’ve got a problem with my new “WD TV Live Hub Media Center” which has the latest firmware 2.08.13 installed on it.

The problem seems to be the same one as people are experiencing with their “WD TV Live” devices, and search as I may in the Media Center forums, I can’t find anyone here who is having the same problem.

Basically it is a syncing problem on the Media Center while playing a MKV file.

After 10 minutes the audio is out of delay by about 100ms (or more) and it soon becomes quite noticeable, and after a while extremely irritating!

I’m using a HDMI 1.4a cable from the device directly to the TV. (I don’t have an AMP)

It does appear to be all just MKV files. I have played AVI files flawlessly. I have played a number of different MKV files (from the same source though…) and the all experience the same problem.

My first port of call is to attempt a download of the firmware to 2.04.13, but if that does not work, I’m looking for advice???


Video File:

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Muxing mode : Header stripping
Duration : 1h 7mn
Bit rate : 2 771 Kbps
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.120
Stream size : 1.30 GiB (90%)
Writing library : x264 core 116 r2037 f8ebd4a
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=18 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=18.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Language : English

Sound File:

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Muxing mode : Header stripping
Codec ID : A_AC3
Duration : 1h 7mn
Bit rate mode : Constant
Bit rate : 256 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 123 MiB (8%)

First thing to do is to roll back to confirm if you still have the same problem, as it could be your Hub itself instead of the firmware.

There are also random cases where a “perfect” file would still not play as it should, and just for testing try to remux the file using MKVmerge…

Hi there,

Thanks for the advice.

I have just rolled back the firmware to 2.04.13, and it seems to have worked, although I’ve only tested it with one 30 minute series and the audio did not move out of sync with the video.

If anyone else is experiencing a similar problem I would suggest that they also rollback their firmware.

I’ll test it again over the next couple of evenings and will report back!

Thanks for your help!

P.S. I’ll mark this answer as accepted once I can confirm that this is the problem - then others can learn from it as well.