Audio Sync Issues w/MP4 Files From Handbrake [2013]

 I’ve been using the WD-TV Live Hub for a couple of months now, and never had a problem with audio sync before. I have recently changed the way I encode my files on handbrake though, and was wondering if this problem could be addressed.

Now before I go any further I want to inform you guys that the file plays fine on my PC with VLC, and no audio sync problems.

One thing I noticed is that the first couple of seconds of the audio doesn’t play on the WD-TV Live Hub, while on my PC with VLC it plays it fine… audio doesn’t get cut off.

Here are my settings for handbrake, maybe you guys can see what’s causing the problem with the WD-TV Live Hub player.

Video is in the MP4 container.

Picture: Keep Aspect Ratio - On

            Cropping - Auto

Filters: Detlecine - Default

            Decomb - Default

Video: Codec - H.264 (x264)

            Framerate (FPS) - Same as source, variable framerate

            Quality: Avg Bitrate (kbps) 2980, 2-Pass Encoding - On, Turbon first pass - On

Audio: AC3 Passthru

Since I’m on the nightly version of handbrake, there’s this new option that dumbs down the advanced tab, and breaks certain features down, here’s a screenshot of that and my settings for it:

Here’s video/codec info on the video file that’s giving me trouble (converted by handbrake)

File Size: 555,264,013 Bytes
Video Codec: avc1
Video Bitrate: 2981 kb/s
Audio Codec: AC3
Audio Bitrate: 384 kb/s
Audio Bitrate Type: CBR
Duration: 21:59.751
Frame Count: 31930
Frames Per Second: 17.123
Display Aspect Ratio: 1.784
Frame Width: 1920
Frame Height: 1076

It seem to be a compatibility issue, don’t know how you can fix that, aside from encoding the files in the same way that you did before.