Audio sync issues continue

I don’t know why I keep having this problem with some of my MKV ripped movies. The only way to fix it is to stop and resume the movie or rewing a few seconds, but it will go off sync again in 5-10 minutes. I’ve been trying to find some commonality to see what the cause might be, but there doesn’t appear to be any outside of the Live Hub. I use the same program to convert with the same settings. It has happened on movies with Dolby Digital soundtracks as well as ones with DTS. It is driving me crazy as it only happens on maybe 1 in 5 movies that I convert. Usually it is only a minor delay, but I watched a movie called The Ledge the other night and it was so bad that it got as much as 3 seconds out of sync and would get unsynced again within a couple of minutes after resuming. This is so **bleep** annoying!

If it only happens on 1 of every 5 movies then the problem might be with the program that you are using. Have you tried playing the movies from your computer?

They all play without issue on my PCs, that’s why I know it is the Live Hub. There seems to be no rhyme or reason as to why it does this as I’ve had it happen on DTS as well as DD soundtracks. It has never been as bad as it was on that movie the other night. It got a full 2-3 seconds out of sync.


Im not an ‘expert’ but ive never encounted an mkv ‘audio sync’ problems .

Ive encounted Mkv files with “DTS Header Stripping” which honestly… dunno what it means

but i always use MKVToolNix and Extract and Remux the Mkv file (i dont touch any Audio Settings ie. Compression)

Maybe the Software you use to create the Mkv is Compressing Audio and doing something ‘Funny’ with it ?

Anyways, just offering a suggestion …dont shoot me :slight_smile:

P.S. Been Demuxing and Remuxing Mkv’s since my WDTV Gen1 days (Live and Hub days as well) … no Audio Snyc Probs

JoeySmyth wrote:



Maybe the Software you use to create the Mkv is Compressing Audio and doing something ‘Funny’ with it ?

Any suggestions appreciated. The software I use (PavTube’s Byte Copy) does nothing to the video or audio. It makes 1-to-1 lossless conversions. That’s why my rips are 20+ gb in size (depending on movie length). These rips play absolutely fine on my PCs using both WMP or VLC, which is why I’m pretty sure it is a Live Hub issue and not my rips. Previously, it was just a minor annoyans as the audio never got more than about a 1/2 second behind, but this latest movie got as much as 3 seconds behind and made watching unbearable. Have watched several movies since and did not have any problems.

See last post ?

And just going back to the playing on a PC comment, I think you have said it a couple of times, as you know PCs are very forgiving, back in the day when I tried to play 1080p rips with excessive ref frames they used to play fine on my PC, but any WD box would have heart attacks, I genuinely believe its the software as with all the years I have used Mkvs and WD boxes, the only time I had issues was with software related issues, and crappy firmware of course. :slight_smile:

But last few firmwares have given me 0 issues with Mkvs/.m2ts/.ts files.

Oh and just thinking out loud, just use Tsmuxer to rip put the files you want from a Bluray.

Interesting thread, but it refers only to problems when FF/REW vids. My problems happen even when not doing that. It also specifically references DTS soundtracks. I’ve had the issue with DD soundtracks, as well. As for the PC vs Hub playback comparison, yes, I have made that statement in here and am well aware of the differences. I bring it up only to show that the files can be played back without issue on some platform. The problem could still be the conversions, but I would think it would be more prevalent thereby happening on more movies, not just the rare odd one. I will look into the ideas expressed in that thread and the possibility of a different software for converting my files. I have been using Byte Copy for over a year and only encountered this issue on maybe 4-5 movies out of the 150 I have converted during that time.

I don’t understand why you are converting though.

If you use Tsmuxer you just select what you want and click, it basically rips out the .m2ts file with the sound you want, there is no other container involved and since you want the full quality, there is no need for other software. It takes away any issues with the software.

Just give it a try on the last Bluray you have had problems with, if you have issues it points to the source rather than the Box I think. maybe a copy protection issue ?