Audio issues with surround sound

Hi Guys,

I’m a newbie here although I’ve had my WD TV Live HD for close to a year now. I found this forum while searching the net for a solution to my problems with it.

My setup is: 

  • The WDTVLive connects via HDMI to a Samsung UE40C6530 TV, the samsung has an optical out to a set of Logitech Z-5500. (I also tried with a samsung monitor that handles HDMI and the issue is the same)

  • Content comes from a QNAP TS-639 that is connected to a gigabit switch, then that switch connects to a 10/100 switch in the living room, where the WDTVLive is connected.

Now for the history:

About a year ago, I bought the WDTV Live and I saw that it was good…  then came a couple of updates, which I barely noticed (I think after the updates it was left at 1.01.XX, can’t remember).

At this time I could play 97% of the .mkv files that came my way. Some I’d have trouble with, namely those encoded with compressed audio track (no audio) or some with global tags (no more playback until I cold booted the player). MkvMerge to the rescue and bye-bye compression and global tags. No problem.

Then late last year came a couple of patches (I think it was 1.02 and 1.03), also I had my father with me for a couple months and he took over the living room so no WDTV for me . He just went away and I noticed there was a new update, 1.04. Update installed and… 90% of my mkvs don’t play audio anymore. Even those that played before are now mute (like Avatar 1080p file I have).

More: Avatar and a few others now start to stutter heavily after playing for a couple minutes… I saw in some forum (might have been this one) that this is apparently a problem with the network on the new firmwares, but the audio problem seems unrelated to network since I get the same issue with an USB drive connected directly. I think I noticed some stuttering in some movies when I installed 1.02 or 1.03, but didn’t pay attention to it at the time.

I tried downgrading to 1.02 and 1.03 and no luck (can’t get my hands on a 1.01 firmware…)

Some trial and error with different files (sorry for lack of detail, I am basing the info on VLC’s codec info, I’ll get mediainfo installed tonight when I get home for some more investigation):  

  • Avi with mpga audio (stereo) - ok 

  • Avi with AC3 sound (5.1) - no sound 

  • MKV with stereo sound - ok

  • MKV with AC3 sound (5.1) - no sound

Please note that last year I could play all these files just fine! these are all files that I’d already watched on the wdtv live in the past with no problems.

A couple of notes: - if I switch my audio output to stereo instead of digital I get sound (stereo ofc).- problem happens in both SMB and Media Server (DLNP server).

Anyone have any inkling of what the issue might be? I think all my issues started with 1.02 but I’m not sure as I didn’t pay much attention (or test much) to the new versions I installed…

Also, if anyone can get me a 1.01.XX firmware to try out I’d appreciate it.

Thanks for reading my wall of text!  

You’re going to need to use STEREO.  

In order to get SURROUND tracks, your TV must support DIgital Audio Passthrough.   Most TVs don’t.   

Stereo *does* work, but I had surround sound with this same configuration (and using the same video files) before the firmware upgrades.

I did notice that starting in 1.02 or 1.03 there were three options in audio/video menu: stereo, digital, digital pass-through (I think that’s the name) while I think before there was only Stereo and Digital. I have it on Digital at the moment, but I can try the digital pass-through later today.

I also haven’t yet tried direct optical output from the WD (going through the HDMI at the moment) but I’ll test that tonight when I get home.

Just tested and surround sound on the optical out works just fine… so it’s just surround through HDMI that’s not working.

Is it just me with this issue? I searched a couple forums and I don’t think I see anyone else with similar problems.

Other users have reported similar issues with surround codecs when trying to pass-through from their TV.

Surround codecs (e.g. DTS and DD5.1) stream without issue over HDMI when the receiving device is capable of decoding them.  E.g. I have no issues with my Pioneer amp.

Newer firmwares seem to query the receiving device on its capabilities, which works fine when connected directly via HDMI to AV receivers and home cinema amps.  Most TVs only report what they can themselves play (e.g. PCM), not what they can pass-through.

If the receiving device is not capable, the Live won’t pass through the audio.  It doesn’t factor in the possibility of that device passing the audio through to a device that IS capable of decoding.  I’d call that a bug.

Older firmwares seem to just blindly stream the audio without querying the receiving device, which may explain why users claim that it used to work.

The solution may be coming soon though.  

The latest Hub firmware got some nice new audio code that takes automatic device interrogation further BUT also allows you to manually specify what the receiving device is capable of.  I believe the Live and Plus are due to get that same audio code in a future update.  

When that may be, I don’t know…

Thanks PixelPower, that fits. :smiley:

I’ll have to check which firmware introduced that “feature” and see if I can rollback to before that. more recent firmwares have been nothing but thorns… choppy video due to network lag on SMB, audio issues… 

For now I’ll just have to keep the optical cabled connected directly to the Z-5500 and suffer playing the PS3 on the TV only :cry: