Audio Issues WD TV Live & WD TV Live Hub Network Share

I am new to this forum so my apologies up front if the issues I am having have already been covered. I have 3 devices connected to a home network system sharing files, photos and videos between various TV’s, laptops, tablets etc. The first unit I have is a WD TV Live with a wired etherent connection with the latest firmware 1.06.43_V.

This unit is around 2 years old. The next unit I have is a WD TV Live Hub with a wired connection with the latest firmware 3.12.13. This unit is around 1 year old. The last unit I have is a brand new WD TV with a wiredless connection with the latest firmware 1.02.17. The majority of the time we am viewing movies at different locations thoughout the house from various hard drives in a central location in a desktop computer with the exception of those files on the WD TV Live Hub. All units are connected HDMI to separate TV’s or amplifiers with the audio output settings in each unit set to digital pass thru via HDMI (auto).

I am also running TVERSITY version 2.7 for a PS3 to view movies in another location of the house. All the video formats have been converted to WMV so that I can also view them on a windows based tablet. They were all originally MKV but the tablet couldn’t play them. We can stream multiple movies at once and all is fine. The issue I have is recently I was trying to stream a movie and the audio was breaking down or missing in some parts of the movie. This only occured on the WD TV and the WD TV Live Hub. They played fine on the WD TV Live (the older unit). I put the files onto a flash drive and I plugged it directly into the WD TV  and the WD TV Live Hub but the result was the same so I know it is not a network or computer issue.

The faults in the audio playback are in the exact location every time on each movie so I believe there is an issue with the file I am trying to play. I can play the file through TVERSITY with no issues at all to the playback. The issue I have using TVERSITY though is if I want to try and fast forward or skip forward or back 20 or 30 minutes through the file TVERSITY will not allow playback after I have done so which means I have to watch the whole movie again (It freezes up through the fast forwarding or at the end I get a still picture).

I am not sure if this is an issue with TVERSITY or how I have set it up, an issue with my computer (windows 8.1 pro, Intel ® Core ™ i7 -3770K CPU @ 3.5GHz 3.9GHz - 16G RAM), TVERSITY cant keep up with the rapid transcoding needed to project forward so fast or an issue between the WD products and TVERSITY. Obviously this is another issue I would like to sort out also but I am at a loss why the older unit can play the movie over network share without audio issues yet the newer units (WD TV and WD TV Live Hub) have audio faults.

I have tried to change the audio settings to manual and select different output formats with no change to the issue.  As I am new to all of this and not sure how it all works could there be an issue with the newer firmwares on the 2 units or is something just not setup right?

Hi bossdave, welcome to the WD Community. Have you verified if the problem happens with previous firmware versions?

How to roll back the firmware on a WD TV Live Hub Media Center, WD TV Live Streaming Media Player, or WD TV Media Player

Thanks for the reply jubei04. I clicked on your link and noticed something different about the firmawares listed. Firstly when I scan my units they all indicate that the firmware is up to date. The firmware on my WD TV Live Hub is 3.12.13 however the latest one on the link is only 3.11.10. The other 2 units have different firmware to those listed on the link. Does it make a difference to what country I am in for the firmware version I have. I am in Australia. I dont want to risk putting the wrong firmware on if they are the wrong ones.

Thanks

Dave

bossdave wrote:

The firmware on my WD TV Live Hub is 3.12.13 however the latest one on the link is only 3.11.10.

 

3.11.10 is “Rollback Firmware” … you know, the “Previous Version” to 3.12.13

 

which is what jubei04 suggested … try a “Previous Firmware” and see if the issue persists.

 

All WDTV Firmware is Global … doesent make any difference where you live

 

Regards, Joey

Greetings from Brisbane, Queensland :wink:

Joey,

Thanks for the reply. I understand about rolling back the firmaware but not sure about a few things. I have the current version of firmware and I wish to roll it back shouldn’t I see both versions of the firmware listed or do they not list the current version of firmware as a download as this is purely a roll back page? The WD TV Live has currently got firmware 1.02.17 installed on it and the newest one listed as a roll back is 1.01.30. I have checked the model number on the unit and it is WDPUF0000NBK-00 and this matches the model number listed on the download page when you hover the mouse over the description of the unit so I know this is the right firmware to download. I downloaded the firmware and extracted it to a USB flash drive and then I followed the instructions on the web page and inserted the flash drive after the unit booted up and the update page popped up but the firmware version I downloaded ‘1.01.30’ is descriped on the WD TV as version ‘4.01.30’. I didn’t go any further as I want to see if this is a mistake in the description of the firmware or is it in fact the wrong firmware or it is actually ok to proceed? The unit is asking to upgrade so I am assuming it will accept it if I select ok but I didn’t want to risk it seeing that the old firmware starts with a number 1 and the old firmware I want to roll back to starts with a 4 so I assuming it isn’t the right one. Help!

if you have a  WDPUF0000NBK-00 … then tthat’s the 2014 WDTV Media Player  (forum is here: http://community.wd.com/t5/WD-TV-Media-Player/bd-p/wdtv_media_player))

Let me explain how rollback works…

For the WDTV to detect “Rollback Firmware” the version number must be “Higher” than what you’re currently running.

i.e. if you are on 1.02.17  then  4.01.30 (Rollback Firmware) is a higher number.

(all wd do is edit the *.ver file to a higher number)

Ignore " 4.01.30" and just press OK to proceed and when finished rolling back the Firmware the WDTV will display 1.01.30

p.s. the WDTV Live Streaming rollback is the same  See Step: 8

To rollback from 2.02.32 … download 2.01.86 rollback and the wdtv will detect 4.01.86  (aka. a higher number … ignore it and press OK to proceed)

http://community.wd.com/t5/WD-TV-Live-Streaming/2-02-32-Firmware-no-longer-allows-content/m-p/781937#M32423

Joey,

That makes sense about making the older firmware look newer by changing the first number for the unit to detect it. I followed the instructions and did the firmware update. It rebooted and I tried to play the same file again and it still played up in the exact same location. It is definitely not the firmware now or the network. There is an issue with the file but I am back to my other question and why does it only occur on network shares yet through the media server it is fine? I wish I could just fast forward thorugh the media server it would solve the issue.

did you do a factory reset ?

 

Setup > System > Device Reset > Reset All Settings Back to Factory Default

sorry, i don’t know what the audio issue is :neutral_face:

No I just got the unit to download the latest firmware again. The issue is on 2 of the newer units so there must be something in the firmware generally for it to play up.