Audio dropouts/glitches on x264/AAC 720p video (WD TV HD Live, firmware 1.01.24)


#1

I am getting random audio dropouts about every 15 seconds or so, less than a second in duration. 

The file is streamed from a Popcorn Hour over a network, but I don’t think that is the problem. Video is perfect.

The files play perfectly on a Popcorn Hour or a PC.

I tried changing the video to 720p 60Hz or 720p 50 Hz, as someone suggested, does not help at all.

At the moment I’m probably going to take my WDTV live back and get a refund as I see that others have had the issue and there is apparently no statement from WD about it.


#2

We will soon have a firmware update out to fix some issues, but that’s up to you if you want wait and see.


#3

I tried switching to component video instead of HDMI, but the audio dropouts remain exactly the same.


#4

The coming firmware update 1.02.14 does not address this issue.

Can you confirm that this issue is registered in your bug tracking system?


#5

Does the file play smoothly from a local USB disk / flash drive?


#6

No. I have played the same video from a USB disk connected locally to the WD TV Live HD, and I hear exactly the same audio glitches.

The audio glitches happen on ALL my files that have AAC audio.

I haven’t noticed any audio glitches on videos that don’t have AAC audio.


#7

Same problem - using a WD World Edition 2 T network drive and get random audio drop outs on MKV /AAC audio files. I hear a lot of talk about this issue and would like to get an idea from WD when a fix will be in place. The Asus O! Play is looking pretty good right now. (it also plays menus from VOB files) that’s another beef.


#8

I did a factory reset yesterday and it fixed the audio dropouts.


#9

I did a factory reset today and it did not help. The audio glitches persist.


#10

there is definitely still an issue with aac audio in video files @ v1.01.24.

there is an audio “glitch” / “stutter” / “dropout” every “x” seconds for video files that suffer from this problem.

  • i have tried various hdmi resolutions in video settings, problem persists.

  • i have tried using a “better” hdmi cable, problem persists.

  • hdd connected directly to wdtv usb 1/2, problem persists.

  • and yes i have tried resetting the device, problem persists.

  • tried changing to PAL/NTSC (10 sec poke in its side), problem persists.

btw, how do you figure out which system WDTVL is set at, PAL or NTSC?

anyway i did this twice to return to the system i was originally at…


#11

Same problem here, MKV x264 codec with AAC audio, the player has some problem with AAC audio, it drops every 30 secs less the 1 sec, using firmware 1.01.24 connected to TV using HDMI

The file plays perfect on PC


#12

The file above, works good on Wd tv HD Gen1


#13

Just a heads-up that this issue also exists in the 1.02.14 prerelease.

I can just about tolerate it but it makes my wife twitch.

Mostly I’m using AC3 passthrough now instead of AAC, partly because of this issue (and partly because I like proper surround sound from my old receiver).  :)


#14

Yes, AC3 is the best, I am with you, but AAC problem should be fixed as soon as possible, isn’t nice, and AAC is the main standard now.


#15

I also have the exact same problem. Hope they fix it soon.