Attn Mac Users: Invalid Username/Password Network Share Max OSX

I hate to even resort to asking because I’m typically usually good at this stuff.  Ever since I purchased my WD TV Live, I for the life of me can’t get it to connect to my Mac (OSX 10.8.3).  I followed all the WD insturctions (settings, file sharing, SMB, add folders etc.)  

On the GUI of the WD I choose source, then network share and it sees my Mac’s computer name.  I select it and then it brings me to a username and password screen.  I’ve tried every possible combination of usernames and passowrds that my Mac would havewith no luck.  I’ve left it blank, left it at anonymous, and still nothing.  

I’ve spent hours googling and searching for solutions with no luck.  Is it just not possible on a Mac to do this?  Thanks in advance for any positve feedback or suggestions.

Now I belive i’ve found the correct username and password combo.  But now after the username and password screen, I get “Unable to connect to the selected source.  Please make sure the selected source is active and available for sharing.”

Which I belive I’ve done everything correct on the system file sharing settings.  

Should I be seeing the deive name WDTVLive someone in Finder?  I know I’ve seen it before and was able to browse the thumbdrive that was plugged in.  Wonder if since I’m not seeing this, if that’s part of my problem?

As a work around, try using Plex Media Server. I used to use Network shares to WDTV Live from OS X but Plex turned out to be a much more reliable (and free) solution. Sorry, not a solution - but it’s something. Other people haveing 10.8 problems overe here

have the same problem here … no way to connect to my iMac :cry:

Check out this link I wrote up about accessing Network Shares.  it’s based upon a Win OS, but I’m sure Mac users can figure out what they need to do.

Hi Have the same issue and gone through all several of these issues.

My WDTV Live is connected to Wifi and visible on my Mac but when I try to connect to it from the Mac it wont password comes up and regardless of what I enter, it fails.

When I try access my Mac  (Networked shared / windows share and my device) from the WDTV Live it wont it comes up with Invalid Username/Password as described in several post.

I also enable password logon for windows shared and use this username and password it makes no difference

I have gone through the folling steps;

Step 1: Click File Sharing

Step 2: Click SMB

Step 3: Reset your WD TV LIVE

Step 4: Don’t touch anything for username and password

Step 5: You should see shared folders.

It still gives me invalid username and password

I have also power cycled the WD TV live

Gone back to preferences and check that sharing and double checked SMB also toggled AFP on /off it makes no difference.

Everytime I retried I reset my WDTV Live

Running firmware: 1.15.10

And Mac OS X 10. 8. 3

I’m loosing may patience 

I don’t use a mac, so kind of helpless there.  I do suggest you follow the directions I gave, but don’t use the password option.  Go with no passwords and see how it goes.  Passwords just add another layer of complication at this point.  Try to get it working; then fool around with passwords if you like.  I don’t even mess with any passwords – heck ,it is in my house!

Thanks for reply but tried withpassword as last resort I.e tried with and without password and still same issue.

Sent support ticket lets see what happens

You realize you’re in the wrong forum for your device?  This forum is for the older generation Live and Live+