ATTENTION THEMERS - OSD for 1.09.10


#1

Hey guys, well I’m happy to report that we can now get the OSD (Mochi theme) for the most recent FW (1.09.10) and it can found in the GPL.

However, to save you some time I have took the liberty to download the GPL, rezip just the OSD and upload it so that you can download just it, since it is about 34MB as opposed ot 871MB of the GPL.

You can download it from here: http://www.mediafire.com/?wnicnol5la13vtx

If you download this though, please make sure to click the KUDOS button to say thanks for saving you about 30 to 40 min. of downloading & extracting from the GPL.

TW


Theme info / questions
#2

Awesome…thank you for providing the base them for us all of so we don’t have download the whole GPL.  Curious to see what things might be available to use in a theme with this update.


#3

Thanks.

At the moment I have the old (modified) theme. Are there more changes to this theme or isit only the live tv link in the menu?


#4

Great news, WD released the updated version of the default theme.

I was looking for this, thanks for the information.


Where can we find the source for default Mochi theme for the last firmware version?
#5

Dikkiedikdik2 wrote:

Thanks.

 

At the moment I have the old (modified) theme. Are there more changes to this theme or isit only the live tv link in the menu?

If you have a “(modified) theme” then you never had the entire theme (this is the entire theme), so yes there will be a lot of changes.

Actually, there appear to be a lot of changes from the last available OSD that I posted (that was from the 2.08 HUB FW).


#6

thank you tinwarble, as always you are a big help.

d@ve


#7

@ Tinwarble

I used the orginal theme which I found from 3 updates ago, I believe it’s 6 months old (but perhaps it’s the same one you uploaded, I saw somewerhe the hub images). I will rebuild my own creation with this theme, but first I have to adjust some things like the live tv icon in the main menu which I don’t use.

Most of the time I only use a couple of xml files and almost no images to build the theme, the missing images / files are used from the original theme. I will update my theme with the new xml files, that’s not much work and worth the time to do it.


#8

This theme seems to be made for the hub version because the updater says the file is too big to upload to the wd tv streaming player.

Is there a new Mochi version for the streaming version too?


#9

@Ryu87

You miss understand, this is not a theme made to be uploaded.  This is the same theme that comes with the firmware and is the default (Mochi) theme.

You only need to download this if you are creating a theme because it contains all the data which is need for the 1.09.10 firmware.

This is why it has “ATTENTION THEMERS” in the subject line.


#10

Dikkiedikdik2 wrote:

@ Tinwarble

 

I used the orginal theme which I found from 3 updates ago, I believe it’s 6 months old (but perhaps it’s the same one you uploaded, I saw somewerhe the hub images). I will rebuild my own creation with this theme, but first I have to adjust some things like the live tv icon in the main menu which I don’t use.

 

No, this is completely new.  It contains all the new data that has been added with the newer firmware.  The last one I posted before this was for the HUB’s 2.8 FW and there have been a lot of changes since then.


#11

Thx for posting! I was wondering if anyone knew which file is the top white image on the Youtube Video and the Weather service? I have tried all the obvious looking ones but have had no luck in identifying it.


#12

Youtubes is “mediafly_encoding_bg.png” in the youtube folder and weather is “accu_bg.png” in accu_weather folder.


#13

They look it don’t they? But no success! :crying_cat_face:


#14

Sorry, I forgot it’s been awhile since I did anything with these.

The actual images are for Youtube, in the youtube folder “youtube_encoding_bg.png”

For the weather, I believe it is in the accu_weather folder: “accu_weather_bg.png”.

Try these, they are missing from the OSD, but these should be the right image names and they are pretty much the same images as the ones that I mentioned.

Just modify those 2 images and then rename them what I have here.


#15

Hm thanks for help but still no success. Perhaps it would be easier for me to just changed the time/temperature font colour? I have looked int he xml file but the I do not recognise the colour format used.


#16

Sorry again, problem is that I’m looking through multiple theme files.  Here’s the issue, I was looking at my Mojo theme that I had modified, but I forgot that I had modified the xml also.

I had to go back and actually look at the original xml’s to see which images to address.  Most of the services use the same …bg.png file which is “image/mediafly_encoding_bg.png”, so it uses that image from the main image folder and not the subfolders.

To modify though for youtube, open the xml “inc_yt_widgets.xml” and modify that image to the one you want.  I would suggest placing the image in the youtube folder then change the line:

   

to

    

and change the name of the image to match.

For the weather, this one I’m not to sure of because there seems to have been some changes to it since the last time I did any mods to it, but you can try “image/accuweather/accuweather_encoding_bg.png”, I will try to confirm that this is the correct image when I get a chance.  If it’s not then I will attempt to find the correct one and post it.

For all other services though (if you decided to change them as well) they should almost all be the “image/mediafly_encoding_bg.png”, but to change each individual one to something different you will have to find the corrosponding xml and change it.


#17

OK, the accuweather is correct the image is “image/accuweather/accuweather_encoding_bg.png”, so that parts sorted.

However, what I said about the youtube overlay is wrong.  There must have been changes to the youtube xmls and so I will have to find the correct one.  This is probably do to adding the Youtube app along with Youtub Videos, so all the xmls are different now.

I’m searching for it now and I will update as soon as I find the correct one.

UPDATE:  Yep, they changed it.  The new xml for the logo and overlay is “inc_youtube_logo.xml” and the image is:

   

So there you go, that should be all sorted.


#18

perfect, thanks! :manvery-happy: