Attached USB spin-up time also delays main HDD file access on latest firmware - any solution?

Hello everyone. I’ve a 4 Tb My Cloud with a 6 Tb USB3 drive attached as well since I have a lot of files. I store the mostly-used files directly on the My Cloud drive and the less used ones on the USB drive. The USB drive spins down when not in use whereas I’ve set the My Cloud itself not to, because I don’t want a delay every time I access these “regularly used” files, but I don’t mind a delay when I occasionally access something on the USB drive.

I updated the firmware recently to 4.05.00-320 and unfortunately now the behaviour is broken. When I try to access anything, even files stored on the My Cloud’s internal drive, it insists on spinning up the USB drive and won’t give me the file until that drive is ready. Can anybody shed light on why it does this, and how to get round it, please?

I did check the USB drive to see if I could prevent it spinning down - I’d rather have it constantly running than stopping and starting too often - but it doesn’t seem to have a power option for that.

Stupidly, I forgot to note the previous (working) firmware version before I updated - is that information anywhere in a log file I could access? The older FW was working fine for me so I could “downdate” if necessary.

Thanks in advance!

Hi TonyC1,

Please know that the firmware updates are released timely to improve performance of the My Cloud drive and unfortunately downgrading the firmware is not recommended. There could be multiple reasons for the external drive not responding as expected. Please contact out support team so that they can help assisting for the same.


You can ssh into the My Cloud. CD to /var/log. Then grep for devfw it will display firmware numbers.
Most likely it will just show the current number. But it might also show the previous number. Don’t over look the zipped files as they are the oldest.

I suggest you read the OP more carefully.

The problem is not with trying to read files from the external drive, it is that accesses to the internal drive are delayed until the external drive has spun up.

There are two obvious problems with this:

  1. why is the external drive being spun up, since the files required are not on the external drive?
  2. why is the MyCloud waiting for the external HDD to spin up, when the files required are not on the external drive?

I’d suggest you pass this to your developers to investigate, so they can ‘release a timely firmware update to improve performance’, should they be able to recreate the problem.

Thank you cpt, that is exactly my point!

Chances are the internal HDD is now sleeping when before, it may not have been sleeping.

Firmware Version 04.05.00-320 (11/28/2017)
Resolved Issues:

Resolved issue of MyCloud device waking up from standby despite no activity.

TEST:

  • Safe eject the external USB drive
  • Allow your normal wait time before accessing the device
  • Now try to access the files on the internal HDD

My guess is, the internal drive is sleeping and takes time to spin up.
The question, Is the internal HDD file access Faster or Slower with the 6 TB USB drive not attached?

I have checked, and am 99.9% sure that this is not the problem. The internal HDD is not sleeping at all - I have Drive Sleep turned off - and with the external USB drive unplugged, access to the internal HDD files is as fast as it should be. When I plug the external drive back in, file access is again very slow even though the internal drive (where the file I am accessing is stored) is not sleeping.

Obviously it’s very frustrating that I’m getting the disadvantage of sleep mode (slow access) without the advantage (energy saving)!