At my wit's end- My Passport Essential won't appear, and I've tried everything

I have a My Passport Essential 3.0. On Thursday, while I was using it, our building had an unexpected power outage from the city doing work on our street. I was transferring files onto my passport at the time, and lo and behold, when I booted my computer, it was borked. It appears empty and unformatted. When I mount it in Puppy Linux, I can see the files on it, but it mounts with errors and I have zero access to them. The drive does not click. It does light up.

I have spent every moment I’ve not been at work since Thursday trying to fix it. I would, of course, prefer to recover my files, but at this point, if I can just get the thing working again, I’d be happy.

I am operating on Windows XP Pro. I use Malwarebytes and Avast. My boyfriend has a computer with Windows 7 I have access to, and I have a Puppy Linux live CD. My drive does not always show in Disk Management, but when it does, it’s raw.

Here is what I’ve tried that I can think of off top of my head.

* Replacing the cord.

* Chkdsk, with /r /f /x modifiers. Errors with “Cannot open volume for direct access.”

* Formatting. Errors with “Specified drive does not exist.” If I try to format by right-clicking it and selecting to format, the window simply disappears without anything happening. When I try to format it through Disk Management, it fails with an error that I can’t recall the exact wording of ATM and it’s not appearing in my Disk Management window once again so I can’t find it, ahah.

* Recuva doesn’t see the drive at all, neither does Seatools.

* Find & Mount doesn’t recover anything.

* I can’t assign any partition to it in Disk Management.

* I can’t recall the specific error, but trying to use the GParted live cd fails.

* I’ve tried to run gparted through Puppy Linux as well, with no avail. ntfsprogs fails with “Volume is corrupt. You should run chkdsk.”

* I tried convert.exe. “Cannot determine filesystem of drive G:.”
* I ran fsutil with a repair option on the Win7 machine and got the error of “FSUTIL requires a local NTFS volume.”

* I have File Scavanger 3.0 and it turns up nothing.

* In desperation I tried fixmbr in the recovery console and it simply hangs for eternity. (I left it alone for two hours to no progress)

* I tried the WD Firmware Updater and it errors out with “Firmware application failed on specified drive.”

* Finally I uncased the drive to attempt to internally mount it, only to find that it’s not SATA as I hoped it’d be be. It’s some sort of proprietary thing I can do nothing with.

I just have no idea what to do. I don’t have the money to replace this drive and while I accept that my files are probably unrecoverable I would like them back if possible. I just want my drive to operate again and I know due to the circumstances that it’s not an HD failure.


This is most unfortunate, however, all hope is not lost. If the device is still under warranty then Western Digital will kindly replace your disk drive for free. Please visit the following link for additional information and warranty check:

I unfortunately can’t check the status of my warrenty as the checker’s capcha is broken.