Are WD breaking consumer law?

Checked the U.K. website and it states

"Access from anywhere

Enjoy your digital life from anywhere on your PC, Mac, tablet or smartphone. With WD’s free apps, your personal cloud is always with you.

Expand your tablet and smartphone storage

Upload photos and videos directly to your personal cloud from anywhere and free up space on your mobile devices."

But the app simply doesn’t work.

If I click on ‘Try Me’ then go into shared pics it shows a thumbnail.

When I go into mycloud it shows no thumbnail but an icon, click on icon and it says cannot access file.

I have spent hours searching this forum and cannot find an answer but it seems to Me it should ’ work out of the box’

but doesn’t a misrepresentation me thinks,  unless of course someone knows better ?

It works for me, on the rare occasions I’ve enabled it. Since the majority of people manage to get it to work, I think the answer is ‘no, WD are not breaking UK consumer law’. That’s not to say the apps couldn’t be improved…

What device are you using to try to access it remotely? Have you registered that device with your MyCloud?

I assume you’ve read the user manual?

Using Samsung Galaxy S3 mini, the device is registered in MyCloud and I’ve read the user manual.

Having read many posts on here there are quite a lot of people can’t get it to work

I’d suggest looking at your router, and ensuring it’s allowing the required traffic to your mycloud. What router is it?

johnw1943 wrote:


But the app simply doesn’t work.

I have spent hours searching this forum and cannot find an answer but it seems to Me it should ’ work out of the box’

but doesn’t a misrepresentation me thinks,  unless of course someone knows better ? 

Lets be clear here. The app doesn’t work… for you. There are plenty of others for whom the apps work just fine, both locally and remotely. As such that is not misrepresentation on WD’s part.

You have not posted any details on what steps you’ve taken. For example:

  • Is the WD My Cloud directly connected to the broadband router/gateway?
  • Have you properly configured the WD My Cloud, and the user(s) for remote access?
  • Have you properly configured your broadband router/gateway to allow access through the router/gateway to the WD My Cloud?
  • Have you tested app while the device was connected to your local network before trying it remotely?
  • Have you uninstalled and reinstalled the app?
  • If you manually configured a user’s app for access did you input the WD My Cloud generated code into the app?
  • Have you tried to access the WD My Cloud through the website?
  • Have you installed the app to another device?

What I said was I cannot access IMAGES using the mobile app.

I can access ALL other files.

Yes they are accessable through / internet explorer and Windows Explorer

They are even accessable  through Thunar file manager in LUBUNTU ! (a linux OS)

Have you tried uninstalling and then reinstalling the app?

Which specific app are you using, the WD My Cloud app for Android or the WD Photos app for Android?

What format is the picture?

Have you tried to clear the “Cache” in the app (see app settings)?

Both apps should open pictures/images the apps support within the app viewer. The WD My Cloud app may, if it cannot open the file, it should ask you to select another program install on your device to open the file. If there isn’t a compatible app then one should get a message indicating such.

Using both the WD My Cloud Android app and the WD Photos Android app on my Motorola Android phone and Nexus tablet I have no problems opening up pictures I’ve loaded to the WD My Cloud.

This is what happens, for me, with the WD My Cloud app when opening up image files from each format type:

JPG - Opens in the WD viewer

GIF - “Open with” dialog box appears

BMP - Opens in the WD viewer

RAW - “There is no player app installed on your device. to play this file please download an app from Google Play.”

TIF - “Open with” dialog box appears

I continued to search for a solution to this problem but found none.

I did find that the operating system is based on Debian Wheezy, now having used a Linux operating system on My computer for more than ten years it occured to Me that maybe the the system required a complete restart .

I shut it down and then rebooted it, at present it is still indexing BUT it would appear that the mobile app is now working correctly.

I apologise to WD BUT still think their install/running instructions are punk presumably because they don’t want to admit

they are using a Linuxoperating system.

still think their install/running instructions are punk presumably because they don’t want to admit

they are using a Linux operating system.

I agree that their install/setup instructions are poor, and strongly encourage a user to run their install/setup program, and a whole raft of apps that are only necessary if you want to do remote access. I’ve had a moan about this on a number of threads here, and even contemplated writing an ‘alternative setup guide’ that is incremental, rather than the ‘just push these buttons to install stuff without understanding why’ approach the UM suggests. When that goes wrong, the poor user has no understanding of the process, or what has gone wrong, or how to fix it.

WD’s argument for this ‘push button’ process will be that, for most naive users, it will work, and be the easiest way to get all the services installed and running in one fell swoop.

If you skip past a lot of the initial setup stuff in the user manual, and start reading about using the ‘Dashboard’, the instructions are a lot clearer.

I don’t think WD are worried about admitting they’re using Linux; they make their source available, following the GPL. I just think they’re sensibly concerned about naive users tinkering with Linux and breaking stuff they don’t understand, because they typed a command incorrectly or in the wrong place, or thought that, since “it’s just Debian Wheezy”, they could use apt-get to install any old package they liked, and expect it not to break the MyCloud…(hint: you can’t, because the MyCloud uses a non-standard, 64K page size build). Hence the dire warnings about warranty and SSH access.

Command line Linux isn’t for the faint-hearted, or for the average, non-technical consumer user that the MyCloud is aimed at. The fact that you had to restart your device to get it to work shows that it isn’t foolproof; you really shouldn’t have to reboot a consumer device to make it work properly (because it shouldn’t be able to get confused). Even if IT support question #1 is ‘have you tried turning it off and on again?’…