Apt-get update bricked drive


#1

so i ran apt-get update which managed to fix part of the FTP problems this thing has.
so a day went past and everything was ok, i went on continuing to fix the FTP by following some guides on FTP over SSL (the problem it was having) and for some reason, after i edited the vsftpd.conf files and ran another apt-get update then ■■■■ thing tanked.

Now i got a few hours before a sleep and a few when i wake it up but but before then id like to know if there is anyway of accessing it without using SSH, Telnet or the stupid web GUI.

The device IS bricked, not even forcing a flash firmware update using TFTP is working.

Any help appreciated.


#2

Apt-get is not safe for firmware v4 onwards. Chances some of your 64k libs were already replaced with 4k ones. Been there done that.

If TFTP doesn’t work for you, then you have no other choice but to open up the drive to dump new rootfs image into the two 2GB raid partitions.

Search the forum on this.


#3

Use chroot in the future for your experiments.
Search there


#4

Managed to get a new cloud. Just wondering if there is progress on a firmware update that will stop this issue with apt, also if this is a problem shouldn’t WD mention it somewhere, the offer SSH as an option by default so beginner users can access it so they should warn people that upgrading apt will break the system.


#5

WD ought, perhaps. But they also say that SSH may void your warranty.

It might be safer if they didn’t include apt-get on the device…

On the other hand, if you start doing Linux system stuff without understanding the platform you’re using, you’re asking for trouble.

“With great power comes great responsibility”…


#6

The SSH as an option by default is great! Without it I won’t be getting this MyCloud :stuck_out_tongue:

Also IIRC there is a warning about SSH when you decided to turn it on, can’t remember what exactly it says but any modifications may still void warranty.

And don’t expect apt-get to work anytime soon. This is not an issue, there was a well-known changes in v4 firmware onwards with the kernel page size memory 4K->64K.


#7

Then is suppose i should RTFM :slight_smile: i though it was just a stripped down Debian distro ? and do any of the apt services work. i tried to install pip (sudo apt-get install python-pip) and it cant find the packages. i cant really get any packages without manually installing them.
Also do python modules work, does python work ?


#8

I guess you’re still new with the MyCloud, lots of things to catch up in this forum :stuck_out_tongue:

Python is pre-installed but minimal. Python-pip nope.

How to get some of the apps? Search this MyCloud section for below.

  1. Get from one of the 64K repos here, one of the user Fox_exe.

  2. Get pre-build 64K apps from users here, some by myself.

  3. Build your own 64K page size memory patched apps from the source.


#9

If you absolutely insist on installing standard Debian distribution packages, built with a 4k page size, then revert your device’s firmware to the last v3 firmware, since it was at v4 that the 64k page size was introduced. Search the forum for guides on how to revert to v3 firmware.

DO NOT try to use apt-get to install from Debian 4k page size depositories unless you want to brick your device again. You say you got a new MyCloud - how? Did you take the last one back as ‘not working’? Well, you broke it…


#10

And if you go back to v3 firmwares, you’ll lose WD remote logins which is perfectly fine if you don’t use them.


#11

Yea i did technically break it. However the store replacement policy covers any accidental damage for 8 days on a one time service. So i cant break it again or they wont replace it.

yea im pretty new to my cloud (only just getting one) and the 2 features i needed were FTP access behind i very strict firewall (stupid uni being paranoid) and also having a small(basic) web server i can access and modify.

I managed to get TSL/SSL for FTP and it looks to be working (wont fully know until Tuesday) and i was hoping to use some basic python modules for the web server.

Im unsure on the 64k packages, is this for the apt side of things or does this include every and all python modules i want to include .(if it includes python modules does this mean I need to edit the way oi make my python codes ?)


#12

Here’s another option:


#13

I had a look through the 64k repos and it didnt include python-Flask
I was thinking about trying to make my own but having issues with debian and the source provided by WD. i installed both packages in mentioned in the readme but getting a problem with chroot when i try update binutils (chroot no command found /bin/bash) im pretty lost on this and cant seem to get chroot working.
any solutions ? (clean debian amd64 on virtualbox)


#14

The error you got seems like the bootstrap is corrupted or not debootstrap correctly. See if you can execute bash in qemu environment after extracting it from the tar bootstrap.

Not that even if you got pip installed, it’s not as easy as it seems running it on MyCloud. Because some python modules needs to compile libs which also requires 64k page size patch. You can setup chroot build environment on the MyCloud but it’s very slow and your NAS might lockup. Best to do it on qemu.

I suggest you open a new thread for this as the topic is no longer relevant.