Apt-get issues

I have often added Linux utils to my MyCloud using apt-get. After this year’s firmware update 04.05.00-342, it has become a lot more difficult. The debian is jessie, but on kernel 3.2.26 (all my other systems are on 5) and libc6-4.7 - obsolete and deprecated. I unwisely upgraded that to 4.8 and thus fell foul of wd-lib and wd-nas which are dependent on 4.7.

Does anyone have copies of libc6-4.7 and other ancient pkgs so that I can fix the local dependencies and use apt-get again?

What about wd-lib and wd-nas installable debs so that I can work around and replace them?

Is WD bothered that they chain us to versions which become dangerous with vulnerabilities?

Has anyone else added programs to the existing firmware by apt-get?
Are you still able to do it?

Nobody here used apt-get?

Still no one?

Issues are resolved now by using apt-get individually only - WD’s own packages prevent a full upgrade with broken dependancies.
Still amazed no one else seems interested in getting vulnerabilities fixed - do we really want all MyClouds to become bot-farm members?
At least get the SSL up to date!

Hi Mike,
i made a similar mistake as you did. Could you please develop a bit on how you solved the issue of the missing wd-lib and wd-nas?

Bothered is an understatement. I own a DS918+ instead of a EX4/ Ex2 Ultra…

But is anyone bothered enough to build update images?
They ought to be, especially WD themselves.