Apt-get always fails


No metter what I’m trying to load using apt-get fails with an error. One example would be MiniDLNA

This is the result of running apt-get install minidlna:

WDMyCloud:~# apt-get install minidlna
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
libc-bin : Depends: libc6 (< 2.18) but 2.19-18+deb8u1 is to be installed
libtirpc1 : Breaks: nfs-common (< 1:1.2.8-7) but 1:1.2.6-4 is to be installed
Breaks: nfs-kernel-server (< 1:1.2.8-7) but 1:1.2.6-4 is to be inst alled
minidlna : Depends: libavformat56 (>= 6:11~beta1) but it is not going to be ins talled
Depends: libavutil54 (>= 6:11~beta1) but it is not going to be insta lled
Depends: libflac8 (>= 1.3.0) but 1.2.1-6 is to be installed
Depends: libid3tag0 (>= 0.15.1b) but it is not going to be installed
Depends: libjpeg62-turbo (>= 1:1.3.1) but it is not going to be inst alled
Depends: libvorbis0a (>= 1.1.2) but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a s olution).

I’ve already tried several things.
apt-get clean
apt-get autoclean
apt-get -f install
apt-get -u dist-upgrade

and more I’ve found when searching for help. But nothing helps :frowning:

My source.list looks like this (opened with nano)

(sorry I have to use pastebin, because I’m not allowed to post more than 2 links…)

I’m really frustrated right now, because nothing works :frowning:

I wanted to install sabnzbd - what actually did work, except for SSL, unrar and par2.
After I gave up on sabnzbd I’ve tried minidlna - also without success.

Even if I backed up my sources.list, I’m not sure if it’s really still the original one.

Do you have any idea? It would be highly appreciate!

Thanks and regards,

Use Chroot and this repo: Repository with software worked on v4 firmware
Or search packages provided by Nazaar.

1 Like

As fox_exe says, don’t try using apt-get from standard Debian repositories; the MyCloud is Debian, but is built with a non-standard 64k page size. Installing from standard (4k page size) Debian repositories is likely to brick your device. Count yourself lucky if you haven’t already done this…

Thank you. I guess I need to search for some information regarding chroot :o

Is there any way to revert everything I did? Basically a full reset?

I’m searching since 1,5 hours for some kind of guidance regarding chroot (how to install, use, etc.) but can’t find anything :frowning:
Is there any guidance how to use this install.sh? I’m quite new too debian etc.

Also maybe you’ve got an answer regarding a full reset - is this possible? Maybe by installing the firmware again? (if possible without data loss on the HDD)

for the love of god use this [APP] MiniDLNA original/patched for firmware V4+ (08/2017) please … it will install miniDLNA automatically without any problems :slightly_smiling:

PS: you should be glad that apt-get didnt work as the guide would brick your device :slight_smile:

If you have actually managed to remove any packages from your MyCloud, it is probably a good idea to re-install the firmware.

To do this, you will need to fool the firmware updater into thinking it has an older version of firmware than it actually has. See the instructions for this at this thread:

Since you’re not trying to downgrade, but just trying to get it to re-install the existing firmware, just edit /etc/version to fool it into thinking it needs to upgrade, and then use the dashboard to make it do the ‘upgrade’.

For all info and useful things, look here: https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE

Thanks so much guys!
I’ve done the downgrade and was quiet terrified, because everything seemed to be buggy. My shares were gone, etc :slightly_smiling:
Once I’ve got the webinterface working again (well kind of…) I tried to install the most recent firmware, which I had downloaded to my harddrive. This however didn’t work, because WD MyCloud was telling me, that there would not be enough space. So I’ve tried the automatic upgrade, which did work.

Now I’m back on the most recent firmware and everything seems to be working fine. I’ve already installed NZBGet with the installer by Nazar - really impressive work btw!

I’m kind of scared installing the chroot firmware, because I don’t really know what this is. Does this actually change something on my interface? And can I get back to standard once installed?

Thank you so much for your help! Really impressive community over here!

dont install anything else… just miniDLNA if you want it… chroot is just other way to install the package… manual way… nazars apps are automatic :slight_smile:

Actually I’d prefer to use sabnzbd over nzbget :frowning:
But to use it I need to install python cheetah and more. Therefore I’m still kind of interested in knowing how to use chroot and what it does :slight_smile:

I’ve tried to understand what the script (chroot_fw_v4_install.sh) does. If I understand that right it basically creates a debian directory under /DataVolume/ and creates kind of subsystem in it?
When I’d like to install something from the Repo now, I would have to use chroot apt-get install python-cheetah (as an example) - is that correct?
Same goes for update: chroot apt-get update

And when I’ve installed something I’d need to add an entry to DataVolume/debian/chroot-services.list

And to install the script I’d copy it to my NAS, open up putty and run it by “sh chroot_fw_v4_install.sh”

Is that correct?

And will the /etc/apt/sources.list still be relevant for installations? So if I’d like to add your repo (you mentioned above) would I have to add it there, or at DataVolume/debian/etc/apt/sources.list?

Sorry for that questions. If I have everything together and got it running I might create a beginner guide for the basic installation and the troubles I faced :slightly_smiling:

On top of the SSH warnings, think WD needs to include “missing” warnings about using apt-get/aptitude on the v4 firmwares lol (no not funny when bricks happens).

Generally running apps compiled by C are faster and more resource (memory) efficient compared to JIT (Just-in-Time) compilers such as Python. So technically, NZBGet is faster than SABnzbd. Also chroot are mostly used for testing purposes i.e. I use chroot to test if the apps I compiled works on a clean v4 firmware before sharing so my debootstrap is always virgin.

It should be the later, once in jail mode (chroot) you are not able to access certain parent resources. Also note that not all dependencies are available on the 64K repo, think you also need to compile some dependencies like par2 for SABnzbd.

It should be chroot path apt-get update or just chroot into the path and run your commands.