Apple formatted MyBook destroyed after connecting to PC?


#1

Hi

I have a WD Mybook Studio 500gb drive that was working fine with my Mac until a few weeks ago when I connected it to a Windows Vista PC. After that, the drive will not mount on either Mac or Pc. Is there a known solution to this problem?


#2

Apart from just connect it, what else did you do?


#3

Just connected it to a PC, nothing else… Windows could not find the hard drive of course, and when I connected it to my Mac again it whould not mount the hard drive.

I know there is nothing going on with the case itself, i tried removing the HDD from the case and put another one in, and that worked. Seems to be the HDD itself that has been corrupted.

My question is really, has anyone else had this problem and is there a resolution?


#4

Hi again

Hmm. Well, from the information you’ve provided it sounds like a warrenty job to me.

Sorry about this.


#5

Does the drive spin up?

If not, can you hear it trying to spin up? Any beeping or buzzing?

Can you detect the USB enclosure with the following Microsoft utility, with and without the drive installed?

http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe

Does the drive show up in Disk Management? Device Manager?