Apple Airport Extreme and My Cloud

I know several people have spoken about this issue, but I just wanted to relay my problems. I have done exhaustive searches of this forum and the internet to try to resolve connection issues. I did exactly as described on this forum. I set up port forwarding for ports 80 and 443 exactly as described. For a few minutes, the My Cloud software told me a direct connection was established and port forwarding was successful. The problem was the My Cloud could not be reached on my local network. After a few minutes, the My Cloud console said the device was not on the internet and could not be reached. The whole reason I purchased this device was to have my very own cloud as advertised. There are simply too many Apple users out there for WD not to take us seriously. Why do you consistenly ignore us and our issues? Come on guys, we expect better service than you have provided us in the past. I’m open to all suggestions. Right now, I’m a disappointed WD fan!


As a recommendation, please contact WD Support for direct assistance on this case.

WD Contact info:

Also see if the following link helps.

Got a nice email from WD Support saying my problem had been escalated to someone in Level 2 Support. I was to reply with a convenient time to take a phone call. I thought they were actually taking me seriously for a change. My first clue should have been when the guy called and said I’m so sorry you are having a problem with your WDTV Live. Do you see any mention of a WDTV Live in my description of the problem? I stayed on the phone for over 45 minutes though many of those were long periods of silence. After all that trouble, the problem is still not resolved and now my ISP must be to blame. Guess I’ll just have to purchase a Linksys or Netgear router if I want it to work properly. Just tired of being treated like a second-class citizen because I choose Apple products.

Not even remotely close!

Mycloud 2TB and Airport Extreme have worked perfectly together ever since I first installed MyCloud 3-4 weeks ago.

I am glad to hear it. How did you manage to make it work? Are you able to access your MyCloud from outside your network? Any insights you could provide would be greatly appreciated!! Thanks!!

I’m not sure if you’re a troll or not but I have the same problem. I cannot get my browsers (Safari, Chrome) to find http://wdmycloud.local


I got the blue light and it should work but it doesn’t. Could it be that it doesn’t communicate with OS 10.8? Should I update the firmware on the NAS?

I’ve also been reading these posts to work out whether or not to add a My Cloud 2tb to my Airport Extreme and then stream to WD TV Live. Lucky I did! Seems like Apple don’t support anything but Apple products ie Apple TV via Airport Extreme. Same goes for WD. No one wants to play ball with each other and the consumers suffer.

The best workaround I’ve had is plugging the external USB drive directly into the WD TV which is then visble through my home network. Then I can add movies and TV to it from either MBPs we have in the house via wifi. Saves unplugging the drive all the time which is all I wanted.

Not great if you want a central HD for everything. Sorry. But I think I’ll add another ethernet connected dive to the Airport Extreme for backups, etc.

Hope this helps. 

I have a Airport Express version 7.6.4 using WPA/WPA2 Personal and 802.11n (802.11b/g compatable). Just got off the phone with WD support who couldn’t help other than going through the reset of the WDmycloud device. That didn’t help.

I’m guessing there’s a problem with the connection between my computers browser and the Airport using the http://wdmycloud.local 

Could it be the password? To connect to my router I need to put in a password but does the WDmyclud device need to do that too? According to the support it’s supposed to work without. But when I scan after the reset it still can’t locate the device. Appearently I need a PC to check this but I only have Macs. bummer. What to do?