[APP] Transmission various versions for firmware V4+ (04/2018)


#905

Those auto remove script should work from 2.84 to 2.92. You just need to add them to the config file (stop the daemon first before editing the config). You may also need to do some editing in the script itself i.e. pointing to the correct path.

I’m using my own custom setup which also stops transmission when there’s nothing left to download. This is my setup (might not be suitable for everyone):

  1. Firstly disable transmission from reboot (in the crontab).

  2. Then schedule a once a day cron to run usually during off-peak.

  3. In the schedule, by sequence it updates my blocklist, start transmission, run flexget and finally call my custom script to stop transmission if there’s nothing left to download (this same custom script is also in my transmission config to remove completed list. It also needs to be in the cron because transmission will not trigger this script when there’s nothing to download).

By having this setup, I don’t have to let transmission run 24/7 thus saving some resources for my other stuffs backups/nginx/mysql5/php7-fpm etc.


#906

I see. thank you.


#907

How could I get the credentials, I can’t see live counter image above?


#908

If you can’t see the counter image or the site, it could be my NAS is temporarily down. If you still can’t access after several days most probably your subnet got auto blacklisted due to attacks or spam.


#909

Hello Nazar78 I am in need of your help … I have a WD My Cloud 3TB I would like to know if it is possible to install any torrent client


#910

Hi Nazar78, I can’t still connect your site, how soon could I get the site to download Transmission firmware V4+ ?


#911

If your firmware is version 4.x then yes you can install from my installer else search the forum.


#912

Your IP subnet might be blacklisted. PM me your IP.


#913

My IP might be 111.241.150.189

2017年3月20日 下午4:05,“Nazar78” wd@discoursemail.com寫道:


#914

Your subnet 111.240.0.0/12 is being blacklisted. Even if I remove, it will automatically add back due to many malicious activities from this twnic.net.tw.


#915

Hi Nazar,

First of all, a HUGE thanks for your work. I would not be able to enjoy my WD as much withtout your help.

However, I still have a question. Do you know how to access the Transmission Web Interface when I am not connected in local (not connected to the same modem as the NAS). When I am home I just go on http://wdmycloud.local:9091/transmission/web/ . I would like to access to the very same page but from abroad. Do you have any ideas how to do it ??

Thanks again !!

Cheers


#916

I’ve been using Transmission on my Drive for a few year now thanks to your great work, it’s been working great and I’ve been able accessing it remotely using freeDNS.

Just updated the firmware and went through the reinstall of transmission and I can’t seem to get access remotely. Everything in the settings file appears to be correct and accessing remotely using IP address to eliminate possible DNS issue’s doesn’t work, while local on my WiFi works fine. The exact error I’m getting is,

Not Found

The requested URL /transmission/web/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

Any idea’s?


#917

Hi. Someone can help me? I have an My Cloud Ext2 Ultra fw 2.30.165. How do I install the latest version of Transmission 2.92? I currently have version 2.84…

Thks!!!


#918

Hello! I’m a new WD MYcloud user and I just installed transmission using @Nazar78’s Excellent work!

I didn’t like the themes available for transmission so I decided to make one. Decided to share it incase anyone wants it :slight_smile:

Here it is:

https://secretmapper.github.io/combustion/


#919

i am new to networking but yes i have a my-cloud nas drive single bay…3tb…version 04.04.05-101. …core f/w…00 mentioned on drive which confirms its gen 1 drive.now i am looking for installing transmission to download torrents directly to my cloud instead of wasting time on laptop so how should i do it and i checked a lot of options but i new to this so step by step information will be highly appreciated i tried many times but i dont to how to assign path to specific folder now thing is i am new so i tried a lot approx 4 times then i reinstalled my firmware so that it can not take problem from any file now i closed ssh and i am not using putty but if anyone will suggest me the proper way just to download torrents directly to my cloud i will really really appreciated that i am looking for solution from last 5 days but no good going every-time i install it say no path or file found…or anywebsite where i can get proper installing commands


#920

Forward the port 9091 from your router to the MC then access by replacing the “wdmycloud.local” with your public IP provided by your ISP. You can connect using your personal DDNS if you have any.


#921

Did you forgot to input the port or there’s changes in your port forwarding? The page you’re seeing is from your Dashboard Apache2 server.


#922

Not sure what issue you’re having. Installing is simple, it can be done less than a minute. Just follow the steps in the first post. Then point your browser to the daemon http://wdmycloud:9091/ to add torrents. For easy access, the download share path has been set to \\wdmycloud\Public\Transmission\Downloads.


#923

I had stepped away from the issue but came back to it last night with fresh eye’s and yes, the issue was with my Port forwarding.

I’ve found that my transmission is a bit more unreliable since my recent update, I’ll have to keep my eye on it.

Thanks very much for your help with this project, your a superstar! :slight_smile:


#924

Hey Nazar, I’ve been using your packages for a long time now, so first of all, thank you for your work and time.

Sadly, my (your!) flexget install has stopped working since I upgraded to v04.05.00-315. This is what I get while running “flexget execute”

2017-04-24 22:47 DEBUG manager Figuring out config load paths
2017-04-24 22:47 DEBUG manager Adding virtualenv path
2017-04-24 22:47 DEBUG manager Found config: /root/.config/flexget/config.yml
2017-04-24 22:47 DEBUG manager Config file /root/.config/flexget/config.yml selected
2017-04-24 22:47 VERBOSE task_queue There are 1 tasks to execute. Shutdown will commence when they have completed.
2017-04-24 22:47 CRITICAL task series_newpct BUG: Unhandled error in plugin form: parse() got an unexpected keyword argument ‘transport_encoding’
Traceback (most recent call last):
File “/opt/flexget/local/lib/python2.7/site-packages/flexget/task.py”, line 435, in __run_plugin
return method(*args, **kwargs)
File “/opt/flexget/local/lib/python2.7/site-packages/flexget/event.py”, line 22, in call
return self.func(*args, **kwargs)
File “/opt/flexget/local/lib/python2.7/site-packages/flexget/plugins/plugin_formlogin.py”, line 57, in on_task_start
for form in br.forms():
File “/opt/flexget/local/lib/python2.7/site-packages/mechanize/_mechanize.py”, line 525, in forms
return self._factory.forms()
File “/opt/flexget/local/lib/python2.7/site-packages/mechanize/_html.py”, line 267, in forms
self._current_forms, self._current_global_form = self._get_forms()
File “/opt/flexget/local/lib/python2.7/site-packages/mechanize/_html.py”, line 282, in _get_forms
if self.root is None:
File “/opt/flexget/local/lib/python2.7/site-packages/mechanize/_html.py”, line 247, in root
response, verify=False))
File “/opt/flexget/local/lib/python2.7/site-packages/mechanize/_html.py”, line 149, in content_parser
namespaceHTMLElements=False)
TypeError: parse() got an unexpected keyword argument ‘transport_encoding’

I’ve been searching the web with no results, and my networking skills are too poor to keep trying to solve this without your help so… Can you please help me?

Thank you very much in advance.