[APP] Transmission various versions for firmware V4+ (04/2018)


#864

Thanks for your hard work but no need to rush I am back up and running now after a bit of time recompiling to the 64kb page size.
Downloaded directly from the Transmissions website.


#865

The captcha key generator is now fixed! Apologies for the delay since I have little time to work on it.


#866

Thank you very much for your good work, Nazar78.
We appreciate it a lot!


#867

Hey,
everything was smooth, but lately transmission keeps hanging mymycloud and it’s on v2.84. I heard there’s v2.92

If you guys (Nazar esp;) could help me clear the ■■■■ out of my transmission (refresh etc.) or even upgrade to another version without loosing anything, would be great!

Regards, M.


#868

Just install v2.92 over. If you need to start fresh, stop the daemon, remove the transmission config file, then restart.


#869

thank’s for this quick reply. Any instructions to install new version? :slight_smile:


#870

NP, just simply run the installer as stated in the first post after getting the anonymous credentials. Read my installers F.A.Q. if you have issues installing.


#871

Well, video helped on getting those loin credentials… Cheers


#872

I’m glad that simple video helps :slight_smile:


#873

@Nazar78

i was wondering if it is possible to get transmission 2.03 for my mycloud? please let me know,


#874

That’s from 6 years ago?!? I haven’t tried since the dep might be older but you can try to compile them. Not sure if it’s worthwhile for me to work on it.


#875

Hello Nazar, thanks again from France for your work and your disponibility !

After à Hard Reset in WD mycloud I cannot run the automatic installation from your website … À message appear : Network is unreachable … You know the reason ?

Thanks


#876

DNS issue? Run below then retry:

route|awk '{if($1~/^default$/)i=$2}END{printf "nameserver %s\n", i}'>/etc/resolv.conf

It will place your router IP in the resolve file.


#877

Thanks for the answer, After some try I have another error message :

WDMyCloud:~# curl teanazar.com/installer.fcgi?transmission_2.84-1|sh;
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (6) Could not resolve host: teanazar.com
WDMyCloud:~#

I don’t understand why it’s not work … :confused:


#878

Something is not right with your network. If you can’t reach me from your MyCloud means it could not even reach MyCloud.com. Can you ping google.com from the shell?

Try changing your DNS to Google’s, note below is temporary, set it on your router’s admin page to make it perm.

echo -e "nameserver 8.8.8.8\nnameserver 8.8.4.4">/etc/resolv.conf

To revert back, use the previous command. The original content should be “nameserver 192.your.router.ip”


#879

Hi,
since I upgraded to 2.92 my transmission crashes, can’t download nor seed. As soon as I add 2Gb+ file it starts downloading, then the usage grows:
%Cpu(s): 22.5 us, 14.0 sy, 0.0 ni, 10.4 id, 59.6 wa, 0.0 hi, 3.4 si, 0.0 st

what’s wrong, how can I configure or clean trash from transmission to work normally? I’m restarting process like 3 times a day :confused:
Thanks


#880

The usage growth is normal, MyCloud only has 650MHz/256MB. I have no issues so far. Could be issues with IO/Swap trashing. Lower your maximum global peers 200/50, set it to queue download/seed one after another. Every connection requires CPU cycles and memory. During low memory the kernel will frequently attempt to flush to Swap which also requires IO hence contribute CPU cycles. You could also try increasing the disk cache I have mine at 4MB but sparingly to avoid excessive growth in Swap which is bad. Ideal Swap usage for MyCloud is <200MB, reached 300MB and you’ll notice slowdowns. Higher apps might get OOM errors. I’m running transmission also PHP7/Nginx/MySQL for my site and my Swap is around 130MB idle. Try practicing scheduling of tasks if you have many apps running because the limited 256MB Ram is no longer a concern for MyCloud but Swap usage is.


#881

Hello and thanks for the thorough guide!

Ι have a quetion. Is there any way to remove transmission app after installing it?

Thank you in advance!


#882

Use dpkg --purge transmission. However this will not totally clean the traces of 3rd party apps like dependencies/configs etc. Best is to reflash the firmware again.


#883

Hi Nazar78,

First of all, thank you very much for this wonderful help you have provided through this post.

It has helped me a lot to run transmission on my WD My Cloud.

However, I recently updated the firmware software and, for some reasons, I can’t access my Interface web transmission as I used to ? I am trying to re-install the transmission on my wd my cloud but I can’t find out how to get the credentials ?

I have checked you video on your website, but still it does not work. I keep getting the page without the access to credentials…

Could you help me somehow ?

Thanks again !!

Cheers