[APP] Transmission various versions for firmware V4+ (04/2018)


#804

My firm is v04. 04.02-105 and I install from here, with the instructions of this page


#805

I’d suggest that, if you’re going to install packages on your MyCloud, that you learn a bit about Unix/Linux, so you can administer the thing when necessary.

To find out what processes are running on the MyCloud, login via SSH, and use one of the Unix process listing commands; ps or top



#806

Think you started another instance. Restart it again:

transmission-stop && transmission-daemon;

Check:

ps -ef|grep -v grep|grep transmission;


#807

This is the result

WDMyCloud:~# transmission-stop && transmission-daemon;
Stopping transmission-daemon…OK!
WDMyCloud:~# ps -ef|grep -v grep|grep transmission;
root 24452 1 0 08:54 ? 00:00:00 transmission-daemon
WDMyCloud:~#


#808

You have now only one instance running.


#809

Everything remains the same
I am not able to solve my problem.
I will do a new clean install


#810

Seems the port 9091 is still in use. Have you tried restarting MyCloud? I’m using the latest version 2.92 and so far never encountered such issue.


#811

Hi Nazar, I succeded in installing your package, but I had issues trying to stop/restart the transmission-daemon, probably because I had another (not working) installation of transmission on my nas.
I therefore removed everything related to transmission with dpkg -r, and I’m trying to reinstall your package from scratch, but now I’m getting this error:

Synchronizing your system time...
18 May 01:54:28 ntpdate[18028]: no server suitable for synchronization found
18 May 01:54:37 ntpdate[18029]: no server suitable for synchronization found

	Warning! Fail to synchronize your system time!

Your downloads may fail. Still proceed? (<[N]o/[Y]es> in 5secs) Y


Checking your internet response...
PING:81.174.24.80 -> teanazar.com = 0.886 secs

Checking resources...
Error-13: Unable to retrieve required files! Fail to validate request. Report to me your IP '81.174.24.80' if you still have issues. If you're behind web proxy, try my alternate port: curl teanazar.com:8245/installer.fcgi?transmission_2.92-1|sh;

Could you please help me? :sweat_smile:


#812

Hi Nazar im havent been able to install transmission im getting this error

Error-13: Unable to retrieve required files! Fail to
validate request. Report to me your IP ‘191.95.249.29’ if you still have issues. If you’re behind
web proxy, try my alternate port: curl teanazar.com:8245/installer.fcgi?transmission_2.92
-1|sh;


#813

I had this one before. It could be your time settings in My Cloud, check under settings, language&clock and see if its synchronized to your local time, check if NTP service if enabled, it should be.


#814

HI NAZAR

i have permission denied error when i am trying to run .exe files dl from torrents the umask is on 0

i found that i must change the owner from root to user from dash how can i do that???


#815

What’s the output before this? Was the time sync successful? What’s the ping reply delay? The installer needs precise timings down to the seconds. Refer to what @WILSONMAANO has suggested.

Edited, I noticed you’re a donor. Please check your PaylPal registered email I’ll help you to solve this.


#816

Are you able to rename or cut & paste the file from the download share to your desktop? The umask is not related anyway to executable permissions on Windows. On few occasions I got prompts from Windows about running executables from the shares it’s due to missing or invalid digital signatures but was to able to accept the prompt and proceed.


#817

yes i can delete rename but when i try to run exr files i have thid


#818

This is not related to permissions on the MyCloud, as I’ve pointed out earlier, it’s with Windows. Try WIN+R, regedit -> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections. Set EnableLinkedConnections dword value to 1.

Details here: https://technet.microsoft.com/en-us/library/Ee844140(v=WS.10).aspx


#819

I did it but still the same my friend if i copy the exe file to a different folder on my cloud i can run it and if i run chmod 777 - r on folder the problem are solved i have win10

i have this problem since the beginning of my cloud on fw 3.x and on pyload


#820

I have no issues running exes from this path. You can try below see if it helps:

chmod -R 2777 /shares/Public/Transmission>/dev/null 2>&1;
chown -R :share /shares/Public/Transmission>/dev/null 2>&1;

#821

Hello smiteone,

From our remote session, seems you’re rootfs is corrupted due to personal mods which leads to:

  • red led on boot
  • unable to mount data volume
  • WD Dashboard offline.

That should be the reason why your MyCloud is unable to update the time via NTP and about 900secs+ behind local time.

As you noted, I’ve done some quick fix on your MyCloud. Please backup your important data then update again from the Dashboard using the latest firmware to restore your rootfs.


#822

no my friend it doesnt work as u can see all the new files have 666 perm so i cant execute it

second i would like to ask something about my cloud i have on win 10 set shares view at tilrs mode and the wd is very slow and not responding if i cxhange to a diferent mode it works great but the tile mode works very well on win 7 i three diferent pc

thnx again for your help


#823

You mentioned you used umask 0 was it from the transmission config file? Seems it’s not honoring the umask settings. Try transmission-stop && umask 0 && transmission daemon; if it works, add umask 0 to the crontab crontab -e where you see the line @reboot for transmission (I’m typing off the top of my head).

As for the view mode it’s a different topic and I’m not sure about it as I always use detailed view. You should open a new topic for this.