[APP] Transmission various versions for firmware V4+ (03/2019)

#604

Can you see this image below? If yes I’m not sure what’s the problem. If no something is blocking your access.

#605

Is there any software / script to sort TV Shows / Movies?  Right now I’m downloading everything to one folder and would like to sort them to different folders so all same tv show episodes would be in same folder and do this without moving the files around so I could keep seeding, I’m thinking something like symlink’s could work. I looked around and Filebot seems to be able to do that exactly but I belive it requires java which doesn’t run on this device, I belive? Is anyone using any script / software to sort their downloads with transmission?

#606

I am currently on firmware v4.01 and transmission works perfect. Can anyone confirm that it works on v04.04.00-308?

Also I backup my config, before update. And I need to obtain keys again for online installer right?

#607

I’ve seen several peeps installing on v04.04.00-308 yet no complains so far. And yes you need to obtain the keys again, each key is for one attempt.

#608

Hello

I’ve Installed transmission on firmware v04.04.00-308 and worked fine till today.

First my torrent files were not being downloaded to the root\downloads folder and i don’t know why.

I’ve tried chenging the destination forlder to root\downloads and the transmission crasched.

Can you tell me how i define pernamently the folder where the files are going to be?

Can you tell me why it crasched and how do i recover? is it restarting the daemon only?

Thanks 

#609

First my torrent files were not being downloaded to the root\downloads

Don’t download to root.  root is part of the MyCloud’s operating system space, and not ‘user space’.

Download to a folder of your choice in the userspace:

/DataVolume/

http://community.wd.com/t5/My-Cloud/WD-My-cloud-4-TO-No-space-left-on-the-disk-Transmission/td-p/904200

1 Like
#610

dusantos wrote:

Hello

 

I’ve Installed transmission on firmware v04.04.00-308 and worked fine till today.

 

First my torrent files were not being downloaded to the root\downloads folder and i don’t know why.

I’ve tried chenging the destination forlder to root\downloads and the transmission crasched.

 

Can you tell me how i define pernamently the folder where the files are going to be?

 

Can you tell me why it crasched and how do i recover? is it restarting the daemon only?

 

Thanks 

Doesn’t seems that you installed Transmission from this thread? Or you’ve done your own changes blindly, else you shouldn’t have this issue.

#611

Hi 

I followed the guide step by step.

The thing i didn’t know how to do, and i still don’t know is how to chage the destination folder and how to delete the files that were downloaded to root/downloads.

If you can help with that i’ll be much appriciated.

Thanks again

#612

“I followed the guide step by step.” <- definately not from the 1st post? Because your installation seems different not from mine?

To fix your issue, do a reinstall:-

Check your rootfs for downloaded files:

ls -Rlh /root/

See which you don’t need and delete:

rm /root/path-found/filename.ext

If you don’t need any of them, just remove all including the parent directory:

rm -rf /root/path-found

I’m not sure how your Transmission was configured especially the path structure w/o looking into your system, easy way find the and delete the current config file “settings.json”. Look in the common known path /root/.config/transmission-daemon/. Or find it yourself, confirm then remove it with rm /path-found/settings.json

find / -type f -name settings.json

Remove the current Transmission from your system since you said it crashed when changing paths?

dpkg --purge --force-all transmission

Then reinstall back using my installer from the 1st post. If you use my installer, the download path will be /shares/Public/Transmission/Downloads/. I suggest you don’t change this path unless you know what you’re doing else you’ll get other permission issues. If you don’t want files in this path, move it elsewhere after downloading.

#613

Thanks Nazar78

This was helpfull.

I have one question.

I’ve reinstall everything like you said but when i add a torrent the default location to download still is /root/downloads, I’ve change it manually tevery time i add a torrent.

Can i change that?

Thanks again for the help

#614
  1. Which firmware you’re using? The latest .308?

  2. Show me your root structure, copy & paste the results here (you can omit those personal filenames):

    ls -Rla /root

Also below:

ls -la /
#615

@dusantos

I just tested the latest firmware .308. There’s no changes that could affect your transmission installation from this installer.

NOTE: My installer creates a symbolic link (a.k.a. shortcut) on the default transmission download path “/root/Downloads/” linked to new location “/shares/Public/Transmission/Downloads/” case sensitive. Meaning the files downloaded to “/root/Downloads/” will be actually on “/shares/Public/Transmission/Downloads/”:

nazar@TeaNazaR:~/.devel/chroot$ sudo ls -lah ./root/
total 36K
drwx------+ 3 root root 4.0K Oct 3 13:36 .
drwxrwx---+ 24 root root 4.0K Oct 3 13:36 ..
-rw-------+ 1 root root 201 Oct 25 2013 .bash_history
-rwxr-xr-x+ 1 root root 465 Sep 25 08:01 .bashrc
drwxr-x---+ 3 root root 4.0K Oct 3 13:36 .config
-rw-r--r--+ 1 root root 140 Nov 20 2007 .profile
lrwxrwxrwx 1 root root 37 Oct 3 13:36 Downloads -> /shares/Public/Transmission/Downloads

If you have changed the download path, you would then need to set the appropriate permissions else you can’t access the downloaded files via Windows share. Check your “/root/.config/transmission-daemon/settings.json”, it should read:

nazar@TeaNazaR:~/.devel/chroot$ sudo cat ./root/.config/transmission-daemon/settings.json|grep download-dir
    "download-dir": "/root/Downloads",
#616

Just a quick note to say thanks, @Nazar78, you’re awesome.

And for anyone that’s wondering, this still works perfectly with the latest v04.04.01-112 firmware.

1 Like
#617

Hi, I thought I’d upgrade yesterday, but did not see anyone confirming it… Now I’m too lazy to read all instructions once again :slight_smile: will wait maybe for some major upgrade

#618

Hello:

I am having a problem with Transmission 2.84 , whenever I restart my WD I need to manually start Transmission , this is my cron configuration :

@reboot transmission- daemon

But I still have the same problem and I can only see the Transmission ( WebGUI Joaco_AR ) interface but I can not see my downloads, after this, I start Transmission manually and I can see the torrents.

Can you help me please?

Thanks (and sorry for my poor english)

#619

Do you really have a space between ‘transmission-’ and ‘daemon’?

It should be ‘transmission-daemon’ with no space, I suspect, since that is the name of the daemon you are trying to start:

http://linux.die.net/man/1/transmission-daemon

1 Like
#620

@cpt_paranoia is right, check for spaces.

BTW it seems you’re referencing from my very very old obsolete guide, copied from elsewhere? :stuck_out_tongue: Because by default in WDMC the root running background cron doesn’t get the environment you get in tty sessions such as paths. Either export them or use @reboot /usr/local/bin/transmission-daemon.

#621

Thanks, problem solved¡¡¡¡

#622

Doh! I’m having that issue with files being inaccessible from Windows (read only).
I want my downloads to be in a different share, what are the required changes?

#623

Duh! Obviously if you change the download location, you’ll need to change the paths/files permission/ownership manually.