App Streaming Issues with Android Oreo

The My Cloud app crashes anytime I try to stream a video from it. This is only on my phone and I just updated my LG V30 to Android Oreo 2 days ago, so I’m wondering if that may be the culprit because it had played fine previously.

The app still streams video on my wife’s phone and my tablet. I cleared the cache on the app, reset my modem, reset my router, uninstall/reinstalled the app, rebooted the phone, tried differnt video player apps (like mx player), updated the My Cloud firmware, still crashes. I can still access photos, music, and docs but any kind of video file crashes the app immediately.

Any thoughts?

Thanks for any help!

When you installed the app on your phone did it show as compatible with Oreo?

It didn’t say if it was or not. I have looked around on the apps Google play page and don’t see anything that would indicate its not compatible.

How long have you owned your My Cloud? Do you know if it is 1st generation or 2nd generation? Have you tried the apps that are shown here? https://support.wdc.com/product.aspx?ID=904&lang=en#WD_downloads

I’m not positive on which generation it is but I have owned it for about 10 months now. I followed the link for android and it brings me to the Google play page for the app I currently have installed.

I have the exact same issue!
Everything worked fine until I upgraded my phone (Sony Xperia) to Android Oreo, now the MyCloud app crashes when trying to open any video. All other media files seem to work just fine.

I have reinstalled MyCloud and even tried uninstalling all my media players, but with no luck.

I have done more digging on this and others are also experiencing video streaming issues after updating to Android 8. Unfortunately after contacting My Cloud customer support it appears this is an app issue and there is NO fix in the engineering queue at this time. It looks like since Android 8 is so new, and there are not a lot of users yet (half of 1 percent of all android users) its not exactly high priority. Understandable, but a real bummer.

I found a work around for at home, if you download the app VLC it can play videos off of My Cloud. I have yet to find a work around for when I am away from my home network though, which is too bad as that is where you would want access to your media.

Upgraded to Oreo two days ago. One of my favorite apps, MyCloud, is now broken. I can view pictures but streaming video causes the app to crash. :frowning: And the sad thing was that after a recent update a few months ago (not sure if it was WD or Android) the app was working great for streaming video. There was a long time where it wouldn’t work well and freeze and not buffer properly, but for the past few months it was working great. Thanks Android.

z33099, I tried using VLC but it asks for a domain. ? I tried using my admin user and pass for WD but no go. What creds did you use?

Hello clwaldroff3579, I have only gotten VLC to work at home, because it can play off of the Local Network. When connected to my home WiFi l just hit Local Network on the VLC app and i have access to the My Cloud drive and any other sharable media on my home network. Is it asking for a domain on your home WiFi?

this happened with me also it was working smooth on my android phone when it was running on android version 6.0.1 however as I have updated to android version 7.1.1 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?

with regards
https://kodi.software/download/ https://messenger.red/ https://hotstar.onl/

I have the same issue I have Android 8 and application hangs all the time. It is not usable, anybody have some fix for it? Or any workaround? To open music via VLC you need to have stable My Cloud app, otherwise you cannot give order to open. Any ideas?