[APP] pyLoad v0.4.9 for firmware V4+ (11/2014)


#81

@aksneo

I can only help on the installation part but not usage as I’m not the app developer and I’m not using this app. I only help to build for our WDMyCloud from several people requesting it.

Please check with http://forum.pyload.org/


#82

@Nazar78

thanks for answers and helps.

pyload forum and website is very wretched and irrelevant.

i wroten a question about this app on this forum but they dont help me.

is there anyone on wd community website by using this application ?

maybe there is someone can help me with this app  

how can i update plugin ? 

https://github.com/pyload/pyload/commit/a591f5617de1280441012ddf846ccc1088963f47


#83

@ aksneo

everytime you restart pyload it will auto update the plugins

look at the LOG at the webinterface.

Schindi


#84

@ Schindi

can you use pyload ?

maybe i want install to  https://mega.co.nz/#F!rsUBDSqb!wepbPS5iETgg7R8Qgh0dbg 

or youtube ?

i searched a lot of website forum or another but i cannot use it.


#85

i installed it.

but i dont update plugin.

below the error.

http://i.hizliresim.com/9VJROk.png


#86

Hi, i upgraded wdmycloud to the latest firmware, now do i need to reinstall pyload from the beginning?


#87

Every mod is lost when you upgrade the firmware. It’s good to backup the configs (/root/.pyload/*.*) before you upgrade then restore them after.


#88

i have this error:


#89

Helo. I try  install to  Wd my cloud  v04.01.04-422   pyLoad from this subj, but got  erorr.

WebGui does not work. 

How solve this troble?

error log:

WDMyCloud:~# curl teanazar.com/installer.fcgi?pyload-cli-v0.4.9|sh;
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 9467 0 9467 0 0 8037 0 --:–:-- 0:00:01 --:–:-- 8043
##################################################

64K Page Size Memory Installer v1.0 by Nazar78

##################################################

Package: pyload-cli-v0.4.9
Description: pyLoad for WDMyCloud V4 Firmware

Note:
If you’re behind web proxy, try my alternate port ‘8245’:

curl teanazar.com:8245/installer.fcgi?pyload-cli-v0.4.9|sh;

To preserve my internet bandwidth, I’m limiting your download
speed to 1MB/s and maximum of ‘3’ download attempts per/hour.

*** You’re currently left with ‘1’ download attempt(s). ***
*** Unauthorized attempts is not tolerated and warrants permanent ban! ***

Disclaimer:
By you using this free service, you hereby agree taking full
responsibilities of any fault/damages resulted by/from your
actions and/or the developer’s contributions. No personal
information or individual usage tracking has been used or
transmitted. All trademarks/copyrights/licenses/credits
remain property of their respective holders.

Do you agree? (<[N]o/[Y]es>) y

Checking available rootfs space…

Partition : 1922.20MBytes
Available : 697.16MBytes
Required : 132.52MBytes

Estimated 697.16MBytes left after reinstalling. Proceed? (<[N]o/[Y]es>) y

Checking resources…
Downloading -> pyload-cli-v0.4.9 (138,956,860Bytes)…
100%[======================================>] 138,956,860 342K/s in 6m 38s

2015-05-24 10:32:56 (341 KB/s) - `pyload-cli-v0.4.9.gz’ saved [138956860/138956860]

Success! You’re currently left with ‘0’ download attempt(s).

##################################################################

WARNING! Attempts to abort this process may brick your device!

##################################################################

Installing required files by dependencies…
Installing (1)-> tesseract-ocr_3.02.01-6_armhf.deb 137KBytes…OK!
Installing (2)-> tesseract-ocr-osd_3.02-2_all.deb 4.1MBytes…OK!
Installing (3)-> tesseract-ocr-equ_3.02-2_all.deb 805KBytes…OK!
Installing (4)-> tesseract-ocr-eng_3.02-2_all.deb 21MBytes…OK!
Installing (5)-> libtesseract3_3.02.01-6_armhf.deb 1.2MBytes…OK!
Installing (6)-> libwebp2_0.1.3-3+nmu1_armhf.deb 91KBytes…OK!
Installing (7)-> libtiff4_3.9.6-11_armhf.deb 175KBytes…OK!
Installing (8)-> libjbig0_2.1-3.1_armhf.deb 28KBytes…OK!
Installing (9)-> liblept3_1.69-3.1_armhf.deb 634KBytes…OK!
Installing (10)-> libgif4_4.1.6-10_armhf.deb 39KBytes…OK!
Installing (11)-> spidermonkey-bin_24.8.1esr-1_armhf.deb 101MBytes…OK!
Installing (12)-> python-support_1.0.15_all.deb 34KBytes…OK!
Installing (13)-> python-pycurl_7.19.0-5_armhf.deb 80KBytes…OK!
Installing (14)-> libcurl3-gnutls_7.26.0-1+wheezy11_armhf.deb 285KBytes…OK!
Installing (15)-> python-openssl_0.13-2+deb7u1_armhf.deb 148KBytes…OK!
Installing (16)-> tk8.5_8.5.11-2_armhf.deb 1.1MBytes…OK!
Installing (17)-> x11-common_7.7+3~deb7u1_all.deb 278KBytes…OK!
Installing (18)-> libxss1_1.2.2-1_armhf.deb 16KBytes…OK!
Installing (19)-> libxrender1_0.9.7-1+deb7u1_armhf.deb 28KBytes…OK!
Installing (20)-> libxft2_2.3.1-1_armhf.deb 52KBytes…OK!
Installing (21)-> libxext6_1.3.3-1_armhf.deb 48KBytes…OK!
Installing (22)-> libx11-6_1.6.2-3_armhf.deb 658KBytes…OK!
Installing (23)-> tcl8.5_8.5.11-2_armhf.deb 1.5MBytes…OK!
Installing (24)-> python-imaging_1.1.7-4+deb7u1_armhf.deb 396KBytes…OK!
Installing (25)-> liblcms1_1.19.dfsg-1.2_armhf.deb 92KBytes…OK!
Installing (26)-> python-crypto_2.6-4+deb7u3_armhf.deb 573KBytes…OK!
Installing (27)-> libgmp10_5.0.5+dfsg-2_armhf.deb 193KBytes…OK!
Installing (28)-> pyload-cli-v0.4.9-all.deb 1.1MBytes…OK!

Configuring pyLoad…
You will now be directed to pyLoad’s ‘Setup Assistant’.
If unsure, it’s advisable to leave everything as default except for
the username, password and download folder. You can access these
settings later from the webGUI. You will also see one of the module
‘PyQt4’ is missing. It’s perfectly normal as we don’t need this.

Press enter to start the ‘Setup Assistant’…

[Begin pyLoad’s Setup Assistant]-----------------------------------------------

Traceback (most recent call last):
File “/usr/bin/pyLoadCore”, line 42, in
from module import InitHomeDir
File “/usr/share/pyload/module/InitHomeDir.py”, line 28, in
__builtin__.owd = path.abspath("") #original working directory
File “/usr/lib/python2.7/posixpath.py”, line 356, in abspath
cwd = os.getcwd()
OSError: [Errno 2] No such file or directory
Error-1: Unable to configure pyLoad!
WDMyCloud:~#


#90

@iganshan

Try:

pyLoadCore -s;

After that:

service pyload start;


#91

ok. its wok now. 


#92

http://c2n.me/3ibiPyF

when i select downloads tab ->

pyLoad - Web-интерфейс

An Error occured, please enable debug mode to get more details.

HTTP Response 500

Traceback (most recent call last):
File “/usr/share/pyload/module/lib/bottle.py”, line 733, in _handle
return route.call(**args)
File “/usr/share/pyload/module/lib/bottle.py”, line 1448, in wrapper
rv = callback(*a, **ka)
File “/usr/share/pyload/module/web/utils.py”, line 113, in _view
return func(*args, **kwargs)
File “/usr/share/pyload/module/web/pyload_app.py”, line 217, in downloads
elif isfile(join(root, item)):
File “/usr/lib/python2.7/genericpath.py”, line 29, in isfile
st = os.stat(path)
UnicodeEncodeError: ‘ascii’ codec can’t encode characters in position 37-43: ordinal not in range(128)

how solve this?


#93

it is pyload known problem nothing to worry about


#94

Hello all,

I installed without error but when you start me in the log writes:

WARNING Not able to connect the server for updates

I go directly to the Internet. I do not need a proxy server. for example, the command “apt-get update” works and updated information of the packages.

Please advise me what I set pyLoad to communicate with the Internet.

error is the same like wrote aksneo on page 9…

Thank You…


#95

This post only provides the installation part, you’ll need to check with pyload forum.


#96

Dear Nazar78,

Would it still work on firmware 4.04 OS3?  I would not dare to upgrade the firmware unless pyLoad and Transmission can run properly.


#97

I believe WD will still continue the 64K page size memory as it has been all this while for v4 firmwares. But we can only confirm when the new firmware has been released.


#98

Nazar78,

I tried to install pyload 0.4.9 on firmware 4.04.00.308.  I just entered return for all configuaration.  When I load the web interface,  it fails.

Would you advise?

Andy


#99

Without any error details I won’t know.


#100

Try a solution from message 35. It helps me.

/etc/init.d/pyload start

If  upper command works, run

update-rc.d pyload defaults

and restart device.