[APP] pyLoad v0.4.9 for firmware V4+ (11/2014)


#61

The downloadpath (where the chunks are located) is /root/.pyload/Downloads

Settings from pyload.conf:  folder download_folder : “Download Folder” = Downloads

Where can i change the location, when i can`t access the websettings?

df -h results:

Filesystem Size Used Avail Use% Mounted on
rootfs 1.9G 1.9G 0 100% /
/dev/root 1.9G 1.9G 0 100% /
tmpfs 40M 3.7M 37M 10% /run
tmpfs 40M 64K 40M 1% /run/lock
tmpfs 10M 0 10M 0% /dev
tmpfs 5.0M 0 5.0M 0% /run/shm
tmpfs 100M 3.6M 97M 4% /tmp
/dev/root 1.9G 1.9G 0 100% /var/log.hdd
ramlog-tmpfs 20M 2.4M 18M 12% /var/log
/dev/sda4 3.6T 369M 3.6T 1% /DataVolume
/dev/sda4 3.6T 369M 3.6T 1% /CacheVolume
/dev/sda4 3.6T 369M 3.6T 1% /nfs/SmartWare
/dev/sda4 3.6T 369M 3.6T 1% /nfs/TimeMachineBackup
/dev/sda4 3.6T 369M 3.6T 1% /nfs/Public

Finally: I can`t use the settings menu. After selecting an entry, nothing happens.

set.png 

Thank you!


#62

I can’t see your screenshot till mods approve them. Change the download folder in the “pyload.conf” to something else i.e.:

mkdir -pm2777 /shares/Public/Downloads;

chown :share /shares/Public/Downloads;

Clean up your 100% usage, “/” and “/var/log.hdd”:

  1. Move this folder out of your rootfs (you could see permission transfer issue, it’s ok):

    mv -f /root/.pyload/Downloads/* /shares/Public/Downloads/;

 2) Find files larger than 512k to be deleted manually (those *.log.[0-9] safe to remove):

find /var/log.hdd -type f -size +512k -exec ls -lh {} \;

 Finally restart your pyload.


#63

Hm, strange…

After the restart something seems to be messed up.

I can`t reach the webinterface.

When i start the pyload server i got the reply …

[....] Starting pyLoad server:Daemon PID 9851
. ok

 … so it seems to be online.

But when i try a stop or kill i got:

[....] Stoping pyLoad server:No pyLoad running.
. ok

-bash: kill: (9851) - No such process

 The logfile is also empty.


#64

Have you clean up your rootfs that’s currently 100% usage? Check: df -h /

To check if pyload is indeed running: ps -ef|grep -v grep|grep -Ei ‘pyload|python’

Check if the webUI is listening: netstat -natp|grep 8000


#65

Thank you very much Nazar, pyload on my wdmycloud is faster than the raspberry pi version, but i need unrar to extract my downloads, how can i enable it?


#66

@B1GWD

I’ll will integrate unrar in the next release.


#67

which one payload or flexget ?


#68

@aksneo

It depends on what you need. I suggest you research more about them.


#69

i want download only megaupload or youtube.

payload 0.5 is beta now.

can i install it with turkish language ?

192.168…:9091 is transmission and what is payload ip ?

i installed now but mycloud/8002 not open

thanks thanks


#70

@aksneo

I’m not sure if your language is supported, you can try check PyLoad’s forum: http://forum.pyload.org/

For the ports, when you first configure the webUI port should be default 8000 and remote is default 7227.


#71

i tried below the code port 8000 and 7227 but negative.

http://i.hizliresim.com/39n7Zr.png

service pyload restart||echo ERROR!

netstat -natp|grep 8000

#72

@aksneo

After you started the service, check if the PID is active:

ps -ef|grep -v grep|grep 29331

If you still have issues and want me to remote to your nas to check, change your password temporarily to your email address:

passwdoldpassemail

Then on your router temporarily forward port 22 TCP to 192.168.1.10. Let me know when it’s ok to connect.

Edited:

I think you may have changed the port during initial config. Check the config file /root/.pyload/pyload.conf. You should see the webUI port 8000 or some other port:

webinterface - "Webinterface":
	str template : "Template" = default
	bool activated : "Activated" = True
	str prefix : "Path Prefix" = 
	builtin;threaded;fastcgi;lightweight server : "Server" = builtin
	ip host : "IP" = 0.0.0.0
	bool https : "Use HTTPS" = False
	int port : "Port" = 8000

#73

i want you to remote to my nas to check.

but how ?

can i send to you my ip adress and ssh password ?


#74

I already know your IP address. You just need change your nas password temporarily to your email address that was made known to me. Also you need to port forward tcp port 22 from your router to your nas IP 192.168.1.10.

If you’re unsure of how to do this, we can try other means. Do you have TeamViewer installed?

http://www.teamviewer.com/

Send me your TeamViewer invitation link.


#75

ok.

my teamviever number 247729607.

i send my password to your private message


#76

I can’t connect wrong password.

Please join my meeting now instead: m77-450-521


#77

@aksneo

My assumption was right, wrong port 8001 instead of 8000. Anyway you still can use :8001 or next time you can just check:

ps -ef|grep -v grep|grep pythoncorrections, I'm sleepy, 4AM here :Pnetstat -natp|grep python

 It will show you the listening port.

Enjoy…


#78

@Nazar78

thanks your helps.

you are perfect :wink:

is there a way an access remote to wd dashboard ?


#79

@aksneo,

Glad it helps but nobody is perfect :stuck_out_tongue:

The question you asked is not related to this thread. But anyway here’s my previous post on how to remote access to the WD Dashboard. This is quite easy to accomplish. Refer to the screenshot in the spoiler link below:

http://community.wd.com/t5/WD-My-Cloud/Login-to-MyCloud-Dashboard-from-Outside-the-Network/m-p/765921/highlight/true#M17952


#80

@Nazar

i cannot use it :frowning:

i read all pyload website but icant :frowning: