[APP] GoodSync for WD My Cloud. Backup and file synchronization

Cyril, a global error Linux. The issue is due to the fact that you have installed is not suitable for this Linux package. Installer package does not understand which version of Linux ustanolena. Some packages are installed and working, and some change the settings so that Linux no longer see the folders. There eschë one option: to copy the files from the archive GoodSync for Linux in the directory.

Install Good Sync manually ! Download Linux for ARM v5 Marvell from GS site and copy in your folder. Read the installation manual .
Installer may fail to update-rc.d if you are running Busybox-based firmware. In this case use the following command to start GsServer manually:
/etc/init.d/goodsync-server start

someone help me?

root@EX4 root # /mnt/HD/HD_a2/_Goodsync/gsync sync /all /progress=yes
Profile folder: /home/root/.goodsync
Loaded 2 jobs from /home/root/.goodsync/jobs.tix.

=== Job === ftp2yadisk: 'ftp://192.168.2.2/gsync' <-> 'http://webdav.yandex.ru/'
00%: ** Connecting to folder ftp://192.168.2.2/gsync
080618 Use No Proxy
080618 FTP: Use MLST/MLSD command to list files
080618 Connected to: ftp://192.168.2.2/gsync: --------- Welcome to Pure-FTPd [privsep] [TLS] ----------You are user number 1 of 10 allowed.Local time is now 08:06. Server por ...: Syst='UNIX Type: L8' Feat='Extensions supported:: EPRT: IDLE: MDTM: SIZE: REST STREAM: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;: MLSD: ESTP: PASV: EPSV: SPSV: ESTA: AUTH TLS: PBSZ: PROT: UTF8:End.'
00%: ** Connecting to folder http://webdav.yandex.ru/
080618 Redirecting to https://webdav.yandex.ru/
080618 Basic authentication requested by server webdav.yandex.ru: MochiWeb/1.0
080618 Connected to: http://webdav.yandex.ru: DAV server: MochiWeb/1.0:
080618 -- Analysis Started by User
080618 ftp2yadisk: ANALYSIS started by User on 'EX4' (GoodSync 10.1.7.7)
080618 ftp://192.168.2.2/gsync [TmpDest] [NoGsData] =NoPropDels=> http://webdav.yandex.ru/ (http://webdav.yandex.ru) [TmpDest] [NoGsData], NoCopyLocked, NoWaitForLocks, LinksCopy, ReconnectSecs=120, ChangeLimit=50
080618 Exclude Hidden, Exclude System, Exclude name *._gstmp|/System Volume Information|Thumbs.db|.DS_Store
080618 Redirecting to https://webdav.yandex.ru/
080618 Locking folder ftp://192.168.2.2/gsync for write
080618 Do not lock folder, because it is read-only
080618 L: State file does not exist in mirror: /home/root/.goodsync/_mirrors_/ftp-192.168.2.2-gsync/_file_state_v4._gs
01%: Expecting 0 folders
46%: Comparing L
080618 L: Files: 49 (excluded 0). Folders: 1 (excluded 0). Times (s): Folder Scan: 0.020 (2500 f/s), Compare: 0.000 FTP: --------- Welcome to Pure-FTPd [privsep] [TLS] ----------You are user number 1 of 10 allowed.Local time is now 08:06. Server por ...
47%:
080618 Locking folder http://webdav.yandex.ru for write
080618 Redirecting to https://webdav.yandex.ru/_gsdata_/_insync_v4.gsl
080619 Delete abandoned lock file at http://webdav.yandex.ru
080619 Deleted lock file /home/root/.goodsync/_mirrors_/http-webdav.yandex.ru/lock.gsl
080619 R: State file does not exist in mirror: /home/root/.goodsync/_mirrors_/http-webdav.yandex.ru/_file_state_v4._gs
48%: Expecting 0 folders
94%: Comparing R
080619 R: Files: 9 (excluded 0). Folders: 0 (excluded 0). Times (s): Folder Scan: 0.050 (180 f/s), Compare: 0.000 DAV server: MochiWeb/1.0, Free: 210.0 GB, Total: 210.0 GB
95%:
96%: Applying Exclude and Include Filters
97%: Comparing Left to Right
98%: PostProcessing
Segmentation fault

and finish error “Segmentation fault”, wtf?
ps: if files created on both servers - gsync working normal (no upload, no download)
if i change files and sync then i have this error…

WD my cloud ex4

I am not sure, but it looks like the job settings problem. Check you tick “Create left/right Sync folders if they are not found”

@Alebel
I have a problem of install the resource directory.
show that space not enough?

thanks

Version : 10.1.7.7 is available.
Try. But when I had a problem to install GS , I reinstall Debian. It was easy for me than find a problem.

It is not full ! Must be /DataVolume/shares/

I too am having this problem. I have downloaded the program, and run the installer and it’s saying I do not have enough free Space.

Same error as the above person’s issue,

Any ideas??

It is not full part! Must be /DataVolume/shares/

I also tried to install Gsync with the same error-code "not enough space"altoutgh I installed it at /DataVolumens/shares?
Can anybody help us?

Did You make ClearDebian installation?
On ClearDebian HDD is /data/.
/DataVolumes/ is not on HDD.
But I have got problem to install GoodSync :frowning:
- Checking log directory…
- Writing GoodSync Connect credentials
./install-script.sh: 1: ./install-script.sh: /data/shares/Files/GS/gs-server: not found
ERROR: failed to configure server:
I have no idea what to do .
The file is in directory , but installer cant see it. dir show the file in the directory.

Does anyone know how to deal with the issue of power failures of the MyCloudEx2? It seems that every time the unit either shuts down and reboots, or there is a power bump, the GoodSync server needs to be reinstalled and restarted to function properly. Is there a particular way to have the server restart without having to reinstall and restart the server?

I should probably rephrase my question a bit. What would be the bootable folder where the server could be installed? For instance, to be able to install this package, I had to install to /mnt/HD/HD_a2/ to be able to have sufficient space. Is there another folder that the goodsync-server should be placed, so that it won’t disappear every time the unit reboots itself?

Thanks in advance

You can install without the .run binaries…
follow these instructions and you should be good

-On the WD, use Putty to access the drive, login as “root” with standard “Password” by default:

run this command :

uname -a

This will tell us what architecture the WD has so we can download the appropriate tar from https://www.goodsync.com/for-linux from the bottom of the page.

The WD PR2100 we setup was intel 64 bit, so we downloaded from https://www.goodsync.com/download/goodsync-release-x86_64.tar.gz

We then extract this somewhere ie"/home/root/goodsync/" on the WD, or copy to that folder using WinSCP. Then need to give the gsync and gs-server binaries execution rights with the following:
navigate to /home/root/goodsync/, if you placed the binaries there :

run these commands.

chmod +x gsync

chmod +x gs-server

Now run :

./gs-server /set-admin=“goodsyncuser:password:root”

Where the first two fields are your GoodSync Connect credentials, and the third field is root.

Now we run the ./gs-server command to have an idea of where the logs are being written to. The displayed directory is where we need to navigate to in order to set permissions and edit the users.tix and settings.tix.

Navigate into that directory (it will be in a folder called .goodsync) and give both settings.tix and users.tix execution rights with chmod +x. Now edit the settings.tix file with the following:

vi settings.tix

And make sure the Global Discovery field is set to “Yes”.

Remember to use the Insert key to begin editing, then press Esc, shift+: and type “wq!” enter key to save and exit.

Now navigate back to the folder containing the gs-server binary and run

./gs-server &

This should allow you to connect to the WD now from any other device with those GoodSync credentials.

2 Likes

try using " ./goodsync " as install folder
and it will install to /home/root/goodsync… best

1 Like

install to mnt/HD/HD_a2/goodsync

I have old file of GS , it was free before
GS files

its working with wd my cloudn gen 2 ?

Is it possible to upload files to OneDrive for business? I have gsync for NAS 10.7.2.3 version number. I configure on windows client jobs.tix, and copy to WD Mycloud. Then I run gsync and my job stopped with this line “210208 R: No file system for msgraph://graph.microsoft.com/”.

Tyrone, thank you so much for this tutorial! :smile:

I’ve got GoodSync Linux installed on my PR2100 and working!

I had trouble installing from the *.run file, and William at GoodSync told me I needed to learn Linux. I know enough Linux to do pretty well. Their instructions are woefully lacking.

What an attitude! I’m glad there are helpful folks like you around.

Thanks again! :smile:

If you need this much instruction for installing an app, then we must be living in 19th century.[quote=“AleBel, post:1, topic:173984, full:true”]
GoodSync is a backup and file synchronization program. It is used for synchronizing files between two directories, either on one computer, or between a computer and another storage device (e.g. another computer, a removable disc, a flash drive or a smartphone) or between a computer and a remote computer or server.
WebSite GoodSync for Western Digital MyCloud NAS

The GoodSync Client ( gsync ) can run on WD My Could, Siber Systems© doesn`t say this in overview. (firmware v04.04.03-113)

GoodSync Client supports Apple Filing Protocol (AFP), Windows Local, Windows Net Share, FTP, SFTP, WebDAV, Amazon S3, Windows Mobile devices, Windows Azure, Dropbox, OneDrive, Office365, SkyDrive, OneFile, OneDrive Pro (Sharepoint) and Google Docs.
before the installation you need to create an account on GS connect (free)
https://www.goodsync.com/gs-connect/
Installation
Installation manual GS RFM!!!

Jobs.tix default folder /root/.goodsync
The Job list can be exported from a Windows or Mac Client . I setup all syncs by GSTP File Servers (gstp:// IP:33333 ) within my LAN.

To run synchronization on schedule use crontab .
crontab -e
Example from my crontab flie
0 */5 * * * /DataVolume/shares/GoodSync/gsync sync /all

From PuTTY full path /DataVolume/shares/GoodSync/gsync --help

GoodSync Server installation
If You dont want to join GS Global Server , tick the box when setup your GSTP server
http://localhost:11000/settings

GoodSync Server settings on WD MyCloud
port 11000 from Web Browser

I could not download/upload from OneDrive , because it asks for additional authentication.

You cat download files from GDrive GS files (Old and Free)
[/quote]