Anyone using multiple Books on one computer?


#1

I have 3 My Book Essential Editions 1TB version and I’m trying to use them on one computer does anyone know if there is a limit to how many you can have hooked up to one computer?  I’m running win7 ultimate on a AMD Athlon 64 Processor 3800+  2.40GHz 2GB memory  250 internal HD then I have a 300GB USB external partitioned in half. Last year I added the first My Book 1TB and it works fine. On Black Friday I found the same My Book 1TB for $59 so I bought 2 of them. I hooked up the first one with no problems and when I try to hook up the third it won’t recognize it is even attached to the computer. If I unplug one of the others it works fine. So that’s why I’m wondering if there is a limit as to how many you can hook up. Though I can’t imagine why it would limit multiple My Books. Any input anyone has would be appreciated. Thanks

Kelly


#2

In case anyone has the same problem I had. I figured it out myself. In win7 I went into computer management then into Disk management. In there it lists all the disks you have connected to your computer. I had assigned the new Books as drive P an drive V. But according to the disk management one of them was offline and had the same identity so all I did was assign the drive letters again and put the second book online and it was all set.


#3

Thank you! It was driving me crazy! Have win7 Ultimate myself and I have used so much time pluggin in and out my disks and assigning them different letters. Who knew you could just right click and press online :stuck_out_tongue:

Thanx again


#4

FYI, I have five MyBooks running. :smiley:


#5

OK, and what is solution?! To run more than 3 drives?


#6

I too have multiple MyBooks and ran into this problem with Windows 7.  This seems to be a problem with Win7 not properly assigning additional external drives a drive letter, therefore causing a conflict.  What you’ll need to do to get around this and make your additional usb hard drives show up is:

1.  Open your start menu and right-click on Computer then select “Manage”.  The ‘Computer Management’ window will now pop up.

2.  Select “Disk Management” from the list on the far left.  Windows will switch to that screen and load all available drives in the second, middle section.  For example, you’ll see something like Disk 0, Disk 1, Disc 2, etc.  You’ll see the usb drive that’s not showing up in your Computer listing here, and it’ll show up as “Offline”.

3.  Right-click on the word “Offline” in the smaller box next to your drive in question, then select “Online”.  Windows should now assign a proper drive letter to it and activate the drive, making it available to access now.

This worked for me, though I notice once you set a drive to “Online”, you no longer have the menu option to set it back to “Offline” in the same manner, unless I’m totally missing it elsewhere.  Either way, this solved my problem of using multiple MyBook ExHDD’s with Windows 7 Home Premium 64-bit.


#7

Thank you SO MUCH!!!  This was driving me crazy!!!    :-S