Anyone upgraded their My Cloud Firmware to 4.01.02-41​7? Is this still buggy?


#1

Hi,

I was one of those users burned by terrible performance when I first upgraded to ver 4 firmware, and eventually went back to v03.04.01-230.  I am running on that now, and see there is a new version 4.01.02-41​7 just released.

I won’t consider this until I hear some feedback from users … anyone have any expereince with this release? Have the performance problems been solved, or is this still buggy?

Thanks,

Moe


#2

Did mine a couple of days ago and had no issues update went smoothly, nothing better or worse.


#3

I have recently upgraded my 2Tb MyCloud to firmware version 04.01.02-417 and have noted the following issues.

  1. The UI interface via the browser is very very slow to populate the available windows like capacity , shares and so on but      after a while it does eventually gets there, after about ten minutes.
  2. Trying to update a safepoint created in the earlier firmware version fails. Shows event code 1102
  3. Trying to create a new safepoint on the same  USB hard drive (WD MyPassport 8020) which had the first safepoint                noted in 2 above fails.
    When the external USB drive was origionally attached the quick view shows it present but it was not visible in the dashboard resulting in it failing to see any sharepoints created, only after rebooting the WD MyCloud did it show up. When I tried to create another safepoint with the previous one on the same USB HD it kept refering to the first one saying it was corrupt.

The only way around this was to format the WD MyPassport and create a new safepoint

With the exception of the above the system seems to work well, I have it attached to a WDTV media player and they both work very well together.


#4

I am having the same issue. Obviously for marketing purposes it is nice to have catchy names like “Safepoint”. However, since my USB drive attached to the WD MyCloud has nearly the same capacity, I would prever just a 1:1 copy. Not sure why it is so difficult for WD to write a simple copy feature into the firmware? There should be options such as copy as-is or compressed. Also having everyone create new safepoints each time the firmware updates is poor quality and time consuming.


#5

ianrws wrote:

I have recently upgraded my 2Tb MyCloud to firmware version 04.01.02-417 and have noted the following issues.

  1. The UI interface via the browser is very very slow to populate the available windows like capacity, shares and so on but after a while it does eventually gets there, after about ten minutes.

The UI interface is slow because of the horridly written wdmcserverd and wdphotodbmergerd services that are grinding away at your hard disk creating thousands of hidden directories, regardless of whether or not you disable Media Streaming or not. I disabled these services via SSH and now there is no remaining capacity shown on the Dashboard, which is completely unnacceptable.

In short, the firmware is still very buggy.


#6

All seems to be working well so far including updating of the previous version safepoint although, as others mention, the dashboard is taking much longer to populate.


#7

I still have same problems like before,

Drive never spins down

No email notifications but test emäil working fine

Incorrect time on the device (other devices on the same network keep correct time)

enabled and disabled media scaning, drive sleep on/off, and email notifications, rebooted many times, and it will not work

Hallo. WD, anyone cares to helpme???


#8

Hi guys, we have passed this along to support.


#9

I just recently bought a MyCloud and during the configuring process I updated to:

WDMyCloud v04.01.02-417 : Core F/W

I’m having Safepoint issues and and also see the dashboard window slow to refresh although not minutes just a few seconds (about 5).

How did you roll back to v03.04.01-230?

If I roll back to that can I expect the Safepoint to work?


#10

Hi

The link below is the method I use however a couple of time this has resulted in a blank dashboard which is usually fixed by the 40 second reset

http://community.wd.com/t5/WD-My-Cloud/Easy-method-to-downgrade-to-previous-version-of-the-firmware/…

Safepoints work for me however I have not tried to restore from a safepoint but as the files are direct copies they can be restored manually


#11

I have 2 My Clouds. One was purchased over a year ago and has had almost every firmware update that was made and is currently on 04.01.02-417.

The other one was a Christmas present and came with the firmware version just before 04.01.02-417 and then I updated it to 04.01.02-417 when I installed it on the network. There are noticable differences in the speed of both My Clouds.

Both now take about 10 seconds to show the initial page of the Dashboard and all its data. I guess I can live with that. It was almost displayed instantly on version 3 of my older My Cloud.

Rebooting, is a different story. My older My Cloud takes much longer to Shutdown and Reboot than the newer one. Both seem to take longer than was noticed on verion 3 of the firmware on the older My Cloud.

Safepoint is created from my older My Cloud to the new one and it has performed flawlessly. But I have never tried to restore a safepoint but that can be done manually if that ever failed.

I am sure that all this has something to do with the new 64K page size for the latest firmware.

I have most every function turned off on both My Clouds, which are now basically just large networked HDD’s.


#12

I have owned a 2TB My Cloud for about 6 months and found that all the WD firmware versions are buggy. I use my WD as a replacement for Dropbox and access the files from two PCs. I am an amateur photographer and upload photos almost daily, and this is where the problems start (IMHO). As soon as files are uploaded, the WD starts scanning but it seems unable to update the database it keeps, and eventually it crashes. So it starts a rebuild from scratch, and as I have a large number of photos it takes several hours. While it is doing a rebuild it is so busy that it drops off line, so any file copying or (more importantly) moving it was doing is stopped midstream. This leads to data loss.

I got fed up waitining for WD to sort the problems out and I have just removed all their software using this method here. Since doing this last Friday I have tried hard to make it fall over and I can’t, copying/moving files between the NAS and 2 PCs simultaneously. Previously I didn’t have to try, just using one was enough.

If you do install the clean Debian image (i.e. just a basic Linux PC system) you will invalidate the WD warranty and end up with just a disk on the network (i.e. a NAS server!). You will lose all the WD programs but there are plenty of free alternatives which, again IMHO, perform better, some having more functions/control to boot.

I wrote a script some while back and recently uploaded it to P33 of the thread above. The WD software added over 150,000 thumbnails to my files, videos and photos, both in private shares and the Public folder. For some, it created 4 different size thumbnails! The script will find these, count them and put the filenames and locations into a file. I don’t recommend deleting your thumbnails if you are running WD firmware (as they will be recreated), but you can at least see what the firmware is producing and possibly why the performance is so poor. There’s a screen print on P33 of that thread.

Hope this helps.