Anyone still having OFFLINE issues with WD my cloud home?

We are still facing the issue, The device if OFFLINE, slow breathing,
Did WD solved the issue or anyone can suggest any solutions, please

Hi @MTZamil1993,

Please refer to the below link to check information about My Cloud device is offline:

Please be informed that the issue with My Cloud Home offline is resolved with firmware 7.15.1-101

@Keerti_01 We know there was a firmware update but do you know when it was released in other territories than the US as for example in the UK we havent had any update

Will factory reset devices receive this firmware update too? After factory resetting my device I’m not able to set it up again

I think latest Firmware totally broke it. Many users have this problem and I think nobody actually recovered it. Some were able safe their data with external help (WD is not doing anything to help unfortunately)

Hello, is anybody knows the right “recipe” how to bring private space of WD My Cloud Home device back to online. I am discussing via email over one month with WD support. I have the latest firmware, I try to clear device owner, I set my router to factory settings. Nothing is blocked. I see open and establish ports for cloud device, but I am not able to connect to private folder via WD servers. Local folder is running and data are there, but I would like to connect to private part. Has anyone some closer information? WD support is terrible:-C

It was resolved in the first week of Oct and now it is happening again in mid Nov

I had my My Cloud Home Duo offline for months. I’ve tried reconnecting it and its just “breathing”, while it still shows up on my router. Tried DMZ; opening ports, nothing. It seems WD bricked it with one firmware or something like that?

Whatever I do, I cannot get to my data and its frustrating! Any help please?

Unfortunately today all My Cloud Home Devices are offline . Let s sit and wait until further notice.

1 Like

Go to this topic: MYCloud Home "Offline" - #36 by nishuperera

The My Cloud Home server is down @sampcuk had called them

1 Like

I had the same problem too. I uninstalled and reinstalled the latest version of the WD Discovery software. Now I get the error message 'My cloud is having trouble connecting to the server '.
I wrote several emails to their official support 'WD Discovery incident reporting. I have the feeling they do not support one seriously. They always refer to their standard Help links which are of no help.
I feel really helpless. I have a lot of data stored on my WD discovery and have found no possibilities to access them either through Wlan or directly through USB etc.
I find this irresponsible on WD Digital’s part for taking no action or providing a solution. I doubt I will ever buy any WD Digital products in the future.

I am having the same problem. I keep trying to reset it and it just keeps blinking. The Western Digital software does not see it. Ridiculous for something that cost over $300.