Any thoughts on strange failure of external 500GB


Model: WD5000AAKS

SN: [deleted for privacy]

Product of Malaysia

date 26 Feb 2008


R/N: 701537

LBA 976773168

500.0 GB

WWN: 50014EE0AB2E524A

PCB label:

2061-701537-E00 02P

XW 5N09 GNMY 6 0003340 8343

PCB stamp:

2060-701537-003 REV A

Hi, I have this hard drive that worked well for about 2 yrs. I have been running it via Firewire connection. Yesterday I installed another FireWire device {Presonus Firepod} and this hard drive will not not load. I believe the firmware possibly is corrupt because the firmware showed it was updating the Presonus but failed before completing. From that point the WD will now longer work. It does spin and keeps spinning as though it is trying initiate or boot up. It will continue this spinning until I drop the power.

It powers up and keeps spinning but never mounts, windows does not recognize or the bios.

I have tried on multiple computers and multiple OSs including a MAC. I have tried the drive via USB also and removed the drive from the external enclosure, pulled the external plug cards and see that it is a typical SATA drive. I also installed the drive connected directly to a motherboard via SATA and power cables. Still no luck?

Basically I am not sure if this is software or hardware related. Is this something you do?


Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support