Any Install of WD software on MAC crashed

i bought the WD MyCloud 4 TB and after copying most data I wanted to check out the WD Access and WD Sync tools. So i downloaded them and tried installation, but any attempt crashes with debug msg. I run on Sierra 10.12.6, MBP early 2015. The MBP runs stable and this is the first issue with software I experience. I am IT Consultant so not a newbie.
Seems to me that the software has an issue with Sierra 10.12.6. If I knew this I would have not bought this. Very disappointing.

What is the debug message, specifically? About missing fonts, perhaps?

This is the msg:
Process: WD Access Setup [882]
Path: /Volumes/VOLUME/*/WD Access Access Setup
Identifier: com.westerndigital.WDAccess
Version: (1)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: WD Access Setup [882]
User ID: 501

Date/Time: 2017-09-26 00:47:12.742 +0200
OS Version: Mac OS X 10.12.6 (16G29)
Report Version: 12
Anonymous UUID: D20A4411-778F-F1E8-AE09-6EC702C9BE32

Time Awake Since Boot: 4500 seconds

System Integrity Protection: enabled

Notes: Translocated Process

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘NSConcreteMutableAttributedString addAttribute:value:range:: nil value’
abort() called
terminating with uncaught exception of type NSException

Both WD Access and WD Sync for Mac run into an exception and termination of the program.