Any fix for Netflix hanging while loading? (error aip-705,tvp-801)


Netflix refuses to work. I can login fine, but whatever i attempt to play, starts to load, the red bar gets stuck 1/4 of the way through then it errors with “We’re having trouble playing this title at the moment”.

Simply cannot get anything to work. I’ve had a quick look through the forums, tried restarting, tried a proper power off and restart, tried a reset. Tried it with and without a drive plugged in, nothing works…

My network is fine and Netflix works perfectly on a laptop, an iPhone and a tablet.

Has anyone fixed this before i return it to WD as defective?


try this:

Awesome.  That worked great. My daughter and my sanity thank you!

ok, so while this solution works every time it happens…The problem is every single time i load Netflix, regardless of whether the box has been off in the meantime, i have to deactivate then re-enter my username password etc.

Is there anyway to stop it happening EVERY time you load Netflix?


I suggest upvoting this thread, you’re not the only one.  This is being experienced by others: