Any connectivity issues with WD My Net N900 Central and Apple devices?

I am going to pickup the 2TB model this afternoon at a local BestBuy store and I am curious to know if anyone has encountered any connection problems with Apple devices, such as Mac Book Airs, iPads 2nd gen, iphone 4S, etc. I combed through the net reading reviews about this router and I am generally impressed by product and the testing. The main reason why I am considering this device over the Time Capsule are the following;

The QoS (Quality of Service) feature

The repeated written posts on the ‘ease of use’ in setup.

The built in NAS drive.

The remote access feature

The personal cloud feature

The support for Apple Time Machine backup.

I’ll post  a separate message on my user experience when I get the router.

We are on the same page…

Today I bought the My Net N900C and am trying to set it up with a brand new Macbook Air (Lion) , Windows 7 Dell Laptop, Windows XP Net book, and an original (2.5yrs old) Motoral Droid.  So far, it is configured and sharing the internal drive with my Macbook Air.  I also was able to get it to share the internal drive with my Droid both via wireless network and via the WD2GO app over verizon 3G.

Then I though the next thing I wanted to setup was the printer sharing.  I really ddn’t think it would be very hard at all, but here I am stumped…

I installed the WD Print Share software (by the way it is all delivered on the internal drive in case you do not have a CD drive anymore) on the Mac and when I open the Print Share Control Center it does show the Epson Sylus CX4200 connected to the N900.

I think the problem lies in the setting up of the printer in System Preferences / Printers.  There are several options for IPP, LPD, and Socket.  I’ve messed with them all, but no joy yet.  When I send something to print, it goes to the queue and after about 20 seconds it just says “error” and quits.

When the Mac and the printer are cabled together it prints fine, so the drivers are in place for the epson; it has something to do with setting up of a network printer that I am messing up (would be nice if there was some guidance in the Print Share software setup as to a recommended settings for use with the N900… no??)

Help!  Printer sharing shouldn’t be this difficult.  I’m so close to getting this cloud thing off the ground…

I bought the N900 Central router last night and it took less than 12 minutes (while inhaling a 6 inch Blimpie sandwich) to configure and connect my MBA to the 5Ghz band but then it all went down hill from there.

Let me back track… I decided to use my Windows Vista Home edition SP2 to run the Router setup and install the software (I know… stop laughing). The setup went well with the only changes that I made during the setup was to the SSID info and password. As mentioned the MBA connected without issue. I then went to into my bedroom (<35 feet away from the router) logged into and started streaming a movie (Thor). I left the MBA in the room and went back to router. I chose to update the firmware and that went well. Now here is where the problem started. I was prompted to install software I chose not to install the Print component because I did not want to connect the printer the router, yet. At the same time I started changing certain settings on my router from the Admin web UI, such as not broadcasting the SSID, turning On MAC filtering, and for the 5Ghz band I turned off WPA/WPA2 mixed security. I clicked Save. The Router started reconfiguing but then I could not connect to the router again from Firefox. I could not ping the router either.

I restarted Vista and loading took longer than usual (it took an extra 5 minutes for the processes to load) and I still could not connect to the router.  I unplugged the router, restarted Vista (still very slow to load) plugged the router and still no connection. I then decided to reset the router and run the setup again. That worked!

I suspect the Vista slowness is the result of the WD suite of software that I installed and the failure to connect to the Router was because of the three changes that I made all at the same time, which should not have behaved that way.

Back in the BR I continued my testing by streaming the movie, Transformer, Dark of the Moon on my MBA and within 5 minutes I noticed a spinning wheel pausing the movie. I think it was buffering or something interrupted the video stream. I noticed the spinning wheel behavior two more times during the movie. I may go back my D-Link router (2Ghz) tonight or tomorrow and test the video streaming with the same movie.

Things were soo slow on my Vista machine I decided to do something I have not done in more than two years, I issued a System Restore from before the WD software installation. The result was stil the same very slow. Much slower prior to the WD router introduction.

I still have tol connect my Apple iPad, iPhone 4S, Apple TV, HP printer, and Android phone to the router.

I’ll keep posting my N900 Central router experience.