Anti-virus Essentials app?

Anyone had any success installing the Anti-virus essentials app?  Mine will not intall, an times out.  I have tried rebooting the drive, and still no luck.

If you have had any success, please let me know what you did.

I have had several issues trying to install apps on this device. I would be extremely pissed if I was counting on these apps to install but seeing that I am using it primarily as storage it doesn’t kill me.

Same experience here.  Add the app, it just sits there “initializing”.  It does absolutely nothing, no matter how long I let it run.

1 Like

Same here.  I am using a My Cloud EX2 with the latest firmware version.  By searching all the forums,  It looks like other models are having the same issue, 

Same thing here with the EX2.  Huge FAIL for WD.

Same here too. I can install and remove other apps but it hangs on the AVE. Reboot too.

I have found url of antivirus app package in file /var/www/xml/app_info.xml ->  http://download.wdc.com/apps/WDMyCloudEX2/AntivirusEssentials/WDMyCloudEX2_clamAV_1.12.bin. I was able to download it and then “Add an App” -> install manually -> select downloaded bin file and… it’s working :slight_smile:

3 Likes

Hello,

We have passed this along to support.

Nice one, although the above link has gained an extra . at the end so won’t work without modification. 

The correct link is:

http://download.wdc.com/apps/WDMyCloudEX2/AntivirusEssentials/WDMyCloudEX2_clamAV_1.12.bin

1 Like

For those of you experiencing the download process hanging anywhere between 0% and 98%, we are currently investigationg the issue.  

However, after getting out of the hanging, you can download and install the software package manually.

How to manually download and install the Antivirus Essential:

  1. Open a Web Browser
  2. Copy and paste the URL path depending on your WD MyCloud model.> My Cloud EX2

http://download.wdc.com/apps/WDMyCloudEX2/AntivirusEssentials/WDMyCloudEX2_clamAV_1.12.bin

My Cloud EX4
http://download.wdc.com/apps/WDMyCloudEX4/AntivirusEssentials/WDMyCloudEX4_clamAV_1.12.bin

My Cloud Mirror
http://download.wdc.com/apps/WDMyCloudMirror/AntivirusEssentials/WDMyCloudMirror_clamAV_1.12.bin

  1. Save the file to your local PC
  2. Login to the WD My Cloud WebUI and navigate to the Apps screen
  3. Click the + to “Install App”
  4. Click “here” to Install the app Manually
  5. Select the downloaded app
  6. Click “OK” to install the app manually
1 Like

I don’t understand why AV Essentials is not available for the “My Cloud”. I feel like I alpha tested this product for you. Why is it not or some form of AV not available for the older products?

Did you installed on the Mycloud single bay modificating the hide access?

What would be the instructions for passing an antivirus/malware on my My Cloud Pro Series PR4100 WD?
Thanks in advance