Anti-Virus essentials App making drive too slow

Is anyone else finding that when the Anti-Virus Essentials app is running a scan that data on the drive(s) is very slow, to the point of being unusable?

I am using on a home network with a couple of Mac computers, and when scanning, many applications will simply time out due to the invasive scan.

Not impressed with performance when this is running.

The initial scan will take the longest; just like a regular computer. After the initial scan is completed the process should no longer affect the unit’s performance that much.

This is not the first time this has happened, which is why I have raised it here. First time around, the scan seemed to take well over a week or so, Dashboard becomes unavailable, and to view a directory takes several minutes to respond. Using Adobe Creative Cloud applications often causes crashes as it is timing out on load and save operations.

If it was the initial scan, I would be more understanding of the issue, but it isn’t.

This is getting silly now. 3 days later and STILL scanning!!

The system has become pretty much unusable now and it is not the first scan!!

getting very fed up now! It won’t let me stop the scan because it wont let me in to dashboard because it keeps timing out!!

I don’t know why, but it is now nearly FRIDAY, the scan started on MONDAY. This can’t be right!

I’m having something similar at the moment. I have a full scan set up to run once a month, and at the moment it seems to be happening as my dashboard is extremely slow and the HDD access lights are twinkling like a Christmas tree.

My drive is about 75% full (about 3TB out of 4TB used) but I also have 6TB of other USB drives connected which I think may also be part of the issue. But I would agree that maybe there does need some sort of limiting of CPU usage or prioritisation of dashboard access over other stuff on the NAS.

IF someone at WD is looking at this to escalate, It is still scanning 10 days later (despite it emailing me 8 times the other day telling me the scan had stopped) - for information it is a 4tb MyCloud set up in RAID 1 configuration, with about 0.65tb in use.

One other option (if you have WD Quickview installed) is to use that to command the NAS to shut down. I may do that on my MCM soon if it carries on. That should allow you to restart and get access back, whence you can then review whether to keep the AV active or not.

I did wonder about that, but wasn’t sure a) if it is likely to respond, and b) what effect that might have mid-scan on data.

It also doesn’t answer the fundamental question about the fact that the virus scan takes far too long, and also takes up far too much processing power from the unit.

I left my tablet’s Chrome pointing at the dashboard, and after a while it did appear (left it over dinner, so about half an hour or so) and was then able to use that to tell my MyCloud Mirror to reboot.

Confirmed the slowness was due to the AV, it had got to 4% (according to the dashboard) of a full scan - this was in about 36-48 hours or so. Reboot stopped it of course, and everything’s now back to normal responsiveness and the LEDs have stopped madly flickering.

So I’d recommend you to either do the same or use Quickview to command a shutdown and then restart your MCM normally. Either that or wait patiently, but you could be waiting for a very long time I’d say. And certainly don’t just pull the plug on it, as there would be risk of drive corruption then as they are being heavily accessed at the moment.

But would also certainly agree that the AV add-on needs some adjustment in terms of priority and CPU usage. Would probably be something to propose in the ideas section.

Still ongoing. Virus scan timed out, then started again the next day. Not been able to access dashboard to turn it off.

Am close to having to simply pull the plug and hope for the best (I can’t get an up-to-date backup from the drive as it is too busy scanning, and going through the ‘shut down’ process has the same problem, and it does not respond to this.


Have you tried using Quickview on your PC to remote command the MCM to shutdown?

That works, although takes a little while to respond. Then when you boot it up again, you should be able to get back in to the dashboard and kill the AV set-up.

Yup! Tried that. and about 13 or so hours later it is still going! :confused:

Hmm. The only other thing I can think of is to perhaps SSH into the MCM and kill the AV service from there. But of course that would only work if you already have SSH enabled (as of course you can’t get into your dashboard now to enable it if not), and my Linux-fu isn’t strong enough to advise on exactly what the suitable commands would be, although Google or someone a bit more used to Linux may be able to help there.

Aside from that I’m out of ideas aside from the drastic one you already mentioned of plug-pulling. Sorry about that, and best of luck!

For better or worse, I have pulled the plug! No other option. I have pretty much everything backed up on an external drive, but am VERY disappointed in Western Digital as their support or concern for this seems non-existent.

Will try and re-boot later and see what happens! Fingers crossed.

Ok - reset after pulling the plug, with the button on the back (as advised by WD eventually) and fingers crossed everything SEEMS OK. Switched off the app now!

They are looking at the system logs to see where the problem is.

At the moment, the drive is back to normal. Will keep advised of progress.

1 Like

Ok, I have to ask. How did you install the Anti-Virus? I followed this post, but unable to install the app.

I have a MCM Gen 2 with 2.11.140 firmware

When I had it installed, just via the download and and manually install route (the “To install an app manually, click here” link in your image).

That said, given when it runs the AV app absolutely kills the access and availability of the device as it’s such a resource and processor hog (especially on my Gen 1 MCM) it fairly quickly got removed again.

OK, then it is possible the Anti-Virus Essentials app is not for the Gen 2 devices. I’m not surprised regarding the performance.