[Answered] Question about "System Test" Utility

Initial Steps: I’m just doing some routine maintenance checking with my EX2. I’ve disconnected all devices from the EX2 (there is only 1 device that connects to it, so this is easy to verify), I’ve ensured that I have the most current firmware (2.11.157 as of this post), and I’ve rebooted just to make sure the system is fresh.

The Problem: Under the Settings Menu, when I go to Utilities and then click System Test, I get a popup window that says System Test, and inside the window it shows an animated blue ball with the text “Please wait…” right next to it.

My Question: What does this actually do? It runs for hours with absolutely no feedback. So I am assuming it is doing some background system checking and when it finishes, it will present me with some feedback about what was checked. The problem is, it never finishes. I tried letting it run overnight, but when I checked it the next day (at least 10 hours later), the browser window had apparently timed out so I just saw the login screen.

Further Thoughts: I don’t have any reason to believe the NAS is malfunctioning, but I’m just doing some routine maintenance checking and would like to get some feedback that confirms the system has been properly checked. But since the system check never finishes, I’m worried that it’s hanging on something and can’t get past that point. But since it doesn’t provide any feedback whatsoever, I have no idea what’s going on.

Summary: What is the system check doing? How long is it supposed to take? Is there a way to use the SSH login to run the system check from the command line so that I can get more feedback than a useless popup window that doesn’t say anything at all?

The dialog box should provide you with options to run different tests; it does not run a test right away. It appears the unit is not granting access to said functions.

Try a system-only factory reset. If this does not address your Dashboard’s behavior I’d recommend contacting WD Support about this if a full factory reset is not possible.

This test should not take too long, about a minute or so at most. It is basically a series of internal checks for the system clock, its RAM, its temperature, a working fan, and the presence or absence of the two hard drives; all of which will be marked by a tick if passed. If you’ve also deleted the three important folders like Public, SmartWare and TimeMachineBackup, it’ll recreate them for you too. That’s about it.

The only other two comprehensive tests that takes much longer will be the Disk Test (aka SMART) and the Scan Disk. Best to apply the good advice Trancer has given and do a System-Only reset to see if this clears it up.

Thanks for the replies. I found that something was causing the system to hang. (I never figured out what it was*.) But I realized it was hung because I couldn’t get it to reboot when clicking on the reboot option in the web interface. I tried to enable SSH so that I could ssh into it and get a look at the process list, but it would not allow me to enable ssh. After a while, I gave up and pulled the plug. I hate doing that because I fear it is going to corrupt the data, but I felt I had no other option.

After rebooting (and waiting for everything to have a chance to settle), I was able to enable ssh, reboot through the web interface, and so on. At that point, I reran the System Test and it only took 10 or 20 seconds.

So my initial question has been solved.

*As an aside, I suspect the hanging problem might have had something to do with the IPV6 Network Mode being set to Auto? I noticed in the Network Settings that the Status was saying something to the effect of being offline or unavailable. But the network was clearly working as I was able to use the web interface. At any rate, I set IPV6 Network Mode to off. When I rebooted, the Status was saying “Internet access” and everything seemed to be working correctly. It may have been a coincidence, but I’ll just leave IPV6 off since I think my LAN is only using IPV4 anyway.