Another update that is causing a great deal of difficulty

The other day I plugged in my WD External Drive and was told to get an update (this is the second one with a very short time). I did so.  Now the blasted thing blunks out my Backup tab and I suppose it is merrily backing up on its own.  I really am most unhappy with this piece of electronic machinery. I’ve had it for a couple of years, and had no problems till the last two updates when everything got twisted about.  I’d not have touched that latest update except that it stopped me from using the drive.  It was jolly expensive, and though I may not be a maven (which is really necessary to be to use this, in my opinion), I am not totally stupid. 

I had a lot of trouble with the previous update and had to uninstall it (that was a job and a half) and reinstall it.   It was fine.  Now it’s not.  And again, it doesn’t allow my computer to go to sleep which annoys me even further.

Now I didn’t allot any kudos when I solved my own problem, and was kindly received by someone else with the same problem which, apparently my instructions helped.   I suppose I’m going to have to uninstall, and do everything all over again.   Plus pray that there won’t be any more updates, either, for a LONG time.

I finally found the help pages, but the support and  contact buttons don’t function.  

I have had identical problems - your saga is mine exactly.  I have a WD Passport Essentiials SE ( . . . ABK) on a Wndows 7 OS.

At the last update (before the new version v1.6.0) I tried all of the remedies posted for “Backup and Restore Tabs not functioning”. No success. I managed to recover on my own by reinstalling software from the WD site which takes me back to v1.4.  Then some time later along came v1.6 which created the same problem.  This is what I did:

  1. Downloaded "Update the Drive Firmware Updater v3.1.0.11 which simply confirmed that firware v2.019 is up to date.  Interesting but not helpful.

  2. Reformatted the HD using WD Quick Formatter for Windows 7 per Answer ID 3868.  Tricky but well illustrated.

  3. Downloaded and reinstalled SES Driver and WD Smartware Disk Image for Windows per Answer ID 5419.  Also tricky but well illustrated.  Must print out the accompanying instructions which are very good.  This installs v1.4 again but the entire backup works quite well, finally, so everything is working again

4.  Downloaded the WD Smartware Software Updater.  Of course it wants to update to v1.6 again.

 At this point I have lost my nerve.

My wild guess is that the jump from v1.4 to 1.6 cannot be made without junking the program.

Somewhere on the WD support site there is a list of reasons for each update.  I cannot find it nor a download for v1.5.

Can anyone help me out too?

I have the same problem Annie. DL’ed 1.6, now my Backup tab and Retrieve Tabs are subdued, so I cannot use them. Help!