Another MyCloud disconnect problem

larryg0 wrote:

Are you using a static IP? if not that would be the 1st thing to try.

 

what are the 3 LEDs doing when it disconnects?

 

many of the disconnects I have seen posted are actually just some services. with no response even to ping it make it difficult to diagnose

 

if it happens again try reseting the router to see if it helps

Rebooting the router is not the solution or even a way to determine the cause of the issue. THe fact that other devices on the router fuction without any problem and only the WD drives becomes unreachable says it all.

There is some ghostly stuff going on here with the drives.

the last time i encountered this poblem.

The leds in the back were normal, green and green blinking, no ping to drive IP (static from the router), no dashboard at all.

Many thanks to all who have chimed in.

As of this morning, remained online, with full access to the files and pings fine.  Just does not respond to either browser or app dashboard.  I am tempted to plug pull and reboot, but don’t want to mess up what is now working, even at the level at which it is working.

I don’t run SSH.  I have read about it here on the board, but don’t know much about it.  Is there a quick education to the program, what version to run (Googling reveals several - free and paid); why I want to run it and what does it get me.  And would it help?

I look forward to your responses.

depends on your comfort level. it can be helpful but also very unforgiving. if you are confortable with even minor operation in it i would have said run reboot if it was enabled instead of pulling the plug which should be a last resort. generally someone here could give commands to try but as with anything online proceede with caution when following advice here

If you decide to enable it putty is a free SSH client that man people including myself use

for the dashboard not responding issue how long has this been? and big uploads? restores? etc recently? this generally works ok once things catch up so I would try to wait at least a day after any of these operations before pulling the plug. The other day I actually had apache stop, if this is the case without SSH pulling the plug is the only option

mines down again as we speak!!

no response to ping or anything…

Solid blue LED on the front. Green leds in the back.

Just want to add that looks to something like a kernel panic on the drive. While I was in the above scenario,
I first tried unplugging and re plugging the network cable into the drive but that didn’t do anything to make it reachable over the network
I then rebooted my router twice to see if the drive would recover, but as it seems, it never connect to the network again. This tells me that the OS on the drive as crashed, halted or something

Only when I power cycle the drive, it came back online.

Just to keep this alive. Updated firmware and still a problem

I had another thread here where I posted a script that would run via corncob…the script is meant to check the drive for network connectivity and if the check fails it should reboot itself… Look for that script and try to use it see if it helps you…
I haven’t run into this problem so far again so can’t say if the script works as intended or not…

Edit here’s the script

#!/bin/bash

test_host=netstat -nr | grep "UG" | awk '{ print $2}' | xargs ping -q -w 1 -c 1 | grep "received" | awk '{ print $4 }'
if ["$test_host" == “0”] || [-z “$test_host”] ;
then

echo $(date) “service networking restart” >> /shares/data/no_ip_reboot_output.txt

/etc/init.d/networking restart

sleep 60

test_host=netstat -nr | grep "UG" | awk '{ print $2}' | xargs ping -q -w 1 -c 1 | grep "received" | awk '{ print $4 }'

if ["$test_host" == “0”] || [-z “$test_host”] ;

then

echo $(date) “Rebooting” >> /shares/data/no_ip_reboot_output.txt

shutdown -r now

fi

fi

Running on a Win 7 64b system

Router is ASUS RT-AC68U with the drive plugged into a port on the drive

QUESTION:

  1. What is “Drive plugged into a port on the drive” ?

     Do you mean USB drive attached to the USB port of the My Cloud device?

  1. What file system is the USB drive formatted as?

TRY THIS:

  1. Remove the USB drive

  2. Disable Remote / Cloud Access

  3. Disable iTunes Server

  4. Disable DNLA Service

  5. Reboot the My Cloud

  6. Attach the USB drive to MyCloud

  7. Login to the UI

  8. Create a NEW Safepoint backup and start it

Report the results when completed.

Another frustrated user chiming in. If so many people are having the exact same issue, why can’t it be fixed? I’m sure it can be replicated. Obviously it’s not an issue with any single router, firewall, switch or computer. My device is the 8TB EX2 on firmware 1.05.36, but also had the issue on 1.05.34 which was the impetus for me updating this weekend.

Static IP on same subnet as all other devices. All media sharing turned off except for file sharing. Device sleep turned off. No apps installed. I’ve tried countless Cat5e cables, different ports, changing the static IP, etc. Front LEDs are blue. network port is all green with flashing activity.

So lets give one of my old post a try.  

http://community.wd.com/t5/WD-My-Cloud/Call-me-maybe-WD-Connectivity-Issues/m-p/881610#M35919

Let me know either here or on that post whether it works.

If not, my other guess would be to do a full reset. I’ve read in this forum that sometimes after a firmware update the Cloud requires a full reset to work. 

1 Like

Thank you for that detailed post.  I will try it tomorrow, and see what happens.  Will get back to you.

So I established a DHCP IP address, and all was fine … for about two hours.  I cannot reach the control panel or the drive at this point, but I can ping the MyCloud without problem.  I’m open for ideas.  Factory reset for the MyCloud?  Sledge Hammer?

drleavey wrote:

So I established a DHCP IP address, and all was fine … for about two hours.  I cannot reach the control panel or the drive at this point, but I can ping the MyCloud without problem.  I’m open for ideas.  Factory reset for the MyCloud?  Sledge Hammer?

sledge hammer and post up pics :stuck_out_tongue:

well you could try pulling the plug on the router or whomever is giving out the ips to do a reset.

Also try a new router by buying one, trying it out for a day to see if you can isolate it to the router itself. If the router is from the isp, once you determine that it is their fault you can then hound them for a new one.

Now the other thing that I didn’t mention in my post is the media scan activities. It could be one of the cause for a non-responsive Cloud. You might want to give it a shot

SSH into the cloud

then type

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

let us know what happens afterwards and if you do use a sledge hammer, please post up pics!!

I am in the process of doing a full reset, will see if that helps.

I am no novice, having built my first computer on a board in 1976, but I am not familiar with SSH.  Can you give me a capsule of the program, or a link to a site that tells me just what that is, does, and why I want to play with it?

here is a link…

http://community.wd.com/t5/WD-My-Cloud/HOWTO-Securing-SSH-with-private-encryption-key-and-passphrasec/m-p/870185

once you are logged in the Cloud you can deactivate those two scan programs.

The reasons is that those two scan programs can take up to 99.9% of your Cloud CPU time and thus cause a complete slowdown of your Cloud and could be the reason that your cloud seems to drop off the network.

1 Like

So I just completed a 24 hour factory reset of the 6 Tb drive.  It is connected, with nothing on it.  I am going to let it sit there for a day or two and see if it stays connected.  Thanks for the help so far, and I’ll pop back when I know something!

Okay people … I write this with some trepidation.

I went onto my router and assigned a fixed address from the DCHP pool

Then I did a factory reset of the MyCloud.  For reference, the 6 TB drive took a bit over 24 hours (I was sleeping when it finished)

Then I let it stay connected for a day or two doing nothing but showing me it’s presence.

Then I initiated a 2 GB backup of one of my drives, which took 16 hours

Then I waited for another 12 hours to write this Email

And it’s still connected.

My guess is that the extra shares I added and data somehow bollixed up things, and I will treat it kind at this point, but it does appear to be working.   I may add to this thread down the line with progress, but MANY THANKS to Ralphael and all the others along the line who have extended a helping hand.

phew!!! as I was reading each line… I was looking for the “But”…

I’m glad to hear drleavey. Mine has been connected for over a year and half now with no incidents. 

However if you ever find that your device gets slugish, you might check into SSH’ing into the device and stop the two media scans.

Theorectically some people have survived the media scans and when it does complete your device functions normally.

Thanks for posting back… makes our volunteer duties so much more thankful.

1 Like

Like a Timex watch … two more weeks and still ticking.   I am cautiously optimistic.  Being gentle, but optimistic!  

Going to ask for that raise! Back me up on this :stuck_out_tongue: