Android WD My Cloud App not working on 3G/4G

Hi,

The app works just fine when on Wi-Fi (both on the same network as the NAS or on other Wi-Fi). When I turn off the Wi-Fi on my phone, I get an error from the app. I have an WD MyCloud 2TB, newest firmware.

"User does not have permission (403)"

I have tried removing the device from the app and re-adding it.

I have uninstalled the app and reinstalled it.

I have tried setting up new users on the NAS.

I have tried turning cloud services off and back on.

I have rebooted my router.

I have set up portforwarding (NAT) for both HTTP and HTTPS in my Router.

The user i am trying with is (now) the only user on the NAS - the web interface works fine (incl. wd2go.com)

Phone: OnePlus One (64gb) on LTE (800/2600) (TDC Denmark)

Router: Zyxel VDSL VMG8924-B10A

Can someone help?

Vestergardi

Hi and welcome to the WD community.

Try to go to the dashboard if the unit and disable and then reboot the unit, after the unit reboots re enable the cloud access and then see if this works for you. you can also try to check if ports 80 and 443 are forwarded on your router or modem in case they are closed. 

To test try to access the drive remotely from a different computer see if you get the same issue.

After turning off cloud and rebooting (which did nothing), I tried changing my NAT setting (was 8081->80 and 8082->473) to straight through on both 80 and 473. That also did nothing. I also tried going from NAT to uPNP. Nothing. I then tried removing the device from the app (while NOT on WiFi) and readding it, entered a new code and got the error:

Unable to access device (503)

Turning back on WiFi and everything works again.

Update: I also tried accessing the device from several other Windows machines using both browser (Java) and the My Cloud application. Both worked fine. I also tried connecting to the device using my Firefox android browser via wd2go.com and it seemed to work - Java is not enabled in the browser, so it stopped after logging in.

Hi,
I have the same problem. Is there any real solution for that?

Thanks

I have the same problems. Thank for your shares. It helps me fix the error very effectively.