Android App MyCloud - Access error


Before read this topic, you must know that my English is bad :slight_smile: sorry.

My name is Matthew, and i have a problem with my MyCloud. Today i firstly use this solution. I used to configure MyCloud wizard. Unfortunately when i want to get access to MyCloud through android app, i saw error. I downloaded latest app from google play store and install it. Later, I run the application and accept licensce. In next, i want to login to MyCloud, i typed right login and password (I create 2 account. All account dosn’t work). Suddenly i see this message:


You need to reestablish your access to the drive. Tap Add Device to do so. (401)

I don’t know what solution this problem. Can i count on help?

Best regards,

My smartphone is Xiaomi Redmi Note 3 Pro with MIUI 8.2 (Android 6).

Is this through your own local network or through the internet?

I try to login through my local network (if i try to login through the internet, i don’t see my device). After first run i upgraded firmware. My current version firmware is 2.21.126.

Does you device have Cloud Access in the Dashboard and is it Connected? See image below. Click on, tap or activate image to enlarge it.

In Cloud Access, i see two section. The first is talking about “does not have a account. Enter an email address to sign up for a login.”, and i can click “Sign up”. The second section is talking about “There is no cloud device access configured for mateusz. Click Get Code to generate an activation code for your cloud devices. Codes are valid for 48 hours from the time of request and can only be used once.”, and i can click only Get Code.

If i click on the “Get Code” i see this error:

If i try to sing up my account i see this:

This is my first cloud. Please forgive me if i doing something wrong.


My problem is solved.

It was enough wait to auto-update date. After first run, date is set at 1 Januar 2013. Today my MyCloud auto-update date at 27-03-2017.

It looks like great!