An alternative to WD Photos?

Hi folks, does anyone know another app for either iOS or Android that can look at photos on the MBL?

From searching it seems a lot of people are having the same issue with WD, I’m surprised it’s not everybody.

I mean, what use is WD Photos? The app works well enough but it can only access the public share?

Can this be any use to anyone that wants to share files with other people?

I want to share family photos with friends and family…

I want give my clients access to a shared folder with work I’ve done for them…

But do I want all these people to have access to all my photos with read/write privilages? I just don’t get WD’s thinking on this.

Perhaps I’m misunderstanding, please let me know if I’m wrong about this as I’m new to MBL and NAS.

It seems to me that if you want to share a folder with someone you have to give them full access to the public share.

Therefore, I would think most people would not want to use the public share if they want to share other folders with family, friends, clients.

So surely WD either need to let us decide user access to the public share or change WD Photos so it accesses a private share.

I’ve found hacks and stuff but I’m a bit nervous of using them and not sure they really do what I want.

The only thing I can think to do is to not use WD Photos and have everything on the MBL out of the public share.

What a shame :frowning:

Like I say though, have I got this wrong? I really hope so.

What do other people do?



Currently, WD does not have any other app that will allow you access the photos on the MBL.

Hi, have a look at
There is a hack on there, but it does seem to work fine and would provide you what you want.


Thanks Miles,

Sorry I’m a bit new to all this. I’ve read your post a few times and didn’t understand the 2nd bit, where you say if you also want to keep the files in a private share…

The first bit makes it read only right? I found another hack which makes the public share privite, which is better for me as I didn’ty want people I share with to have access to my entire photo collection, especially clients :slight_smile:

That mostly worked except not for mobile devices, so my son can still delete photos. But it’s hard to do by accident so I guess it’s cool.

So currently I have everything in private folders except photos which are in public but have a hack in place which seems to stop access for all web access users except admin.

And after all that WD Photos doesn’t seem to work anymore. So I might just give up on it.

Thanks for your post anyway.

Hopefully, one day, WD will give us a photo app that works how we need it to :slight_smile:

The way i have it setup means wdphoto works fine, however if you use a winxp machine to browse to the public share the photos cannot be deleted as they are read only. The photos are all kept in the private share,but there is a symlink to the public share.

The other hack which you mention below makes the public share private, however this will break wdphoto.

I have not tested the dlna server with my hack. I suspect it will be fine, there is a possibility it may show double the photos if it follows the symlink, most software is smart enough not to follow symlinks though for that type of thing.

Happy to help you with getting my hack working.

1 Like

Oh I see, that’s sounds perfect.

I had a feeling that hack was what had messed up WD Photo while I was out, still ok when I’m on my home network.

I would very much appreciate your help :slight_smile:

I don’t know Linux but I am careful and I did find my way round nano and stuff, just about.

Can I return it to how it was? is it just changing those 2 lines back and running the command again?

You might have to spell out the instructions a bit :slight_smile:

like :


ln -s /shares/Private/path\ to\ your\ pictures   /shares/Public/Shared\ Pictures

does the line start with -s ?

are the / and \ all as you’ve done?

maybe for me it would be:

-s /shares/Private/Photos /shares/Public/Shared Pictures

is that it? I would simply have a privite share called Photos


yeah instuctions a bit vague, meant for people who know linux :smiley:

put the other settings back, unsure what restarting your referring to, if its samba then fine.


edit /etc/samba/overall_share

and change the [Public] share section to

writable = no
wide links = yes

ln is a command, it means to make a link, the -s means to make a symbolic link, I’m not going to explain what this is, just trust me or google it.

your example should be

ln -s /shares/Private/Photos /shares/Public/Shared\ Pictures

the \ is so it realises its a space, and not another parameter to the command.

thats it.

if it makes your NAS smoke, blow up, melt down, errupt, explode, etc… dont call me

you will need to restart samba again, unsure how to do this, from mememory its

/etc/init.d/samba restart

1 Like

Thanks Miles,

Restarting? Not sure what you’re referring to :slight_smile:

Do you mean where I asked about entering the command again?

I meant after I change the 2 lines the original instructions said to enter

settrustees -f /tmp/trustees.mod

I guess I should run that again?

Apart from that, it all makes sense.

I will try it later. 

Thanks again.


Yep fine

Just a note, the l in ln is not an uppercse i, its an l, if you know what i mean, ln stands for link, let me know how you go.

Phew, yes, assumed it was a L for link.

So here’s what happened:

I changed those 2 lines back to how they were and assumed I should run the command again

settrustees -f /tmp/trustees.mod

I restarted Samba and rebooted the MBL for good measure.

Then I tested the public folder by logging in as a test user I’d created with a different email.

Before reverting those 2 lines I got an error when i tried to connect to the Public with that user. Now it let me in in a normal way.

So I assumed it’d worked.

I moved all my photos to a new ‘Photos’ private share with admin only for now and deleted the contents of Shared Pictures, but not the folder.

I changed the lines to

writable = no

wide links = yes

writable was ‘yes’ before and there was a different line beneath, so I inserted the extra line that said wide links = yes

I assumed spaces at the start of lines weren’t seen as the wide line started a couple of characters before the writable line.

I entered

ln -s /shares/Private/Photos /shares/Public/Shared\ Pictures

exactly as is.

I restarted Samba again and rebooted MBL.

Deleted all the remote access users, made a new one and sent a new activation code for admin user.

On WD Photos tried to access and got ‘no photos’ message. So maybe still looking at the Public share?

rebuilt the database or whatever that option is in dashboard/settings advanced.

Went to work. Now when I try WD Photos on a different Network, I get the

The operation couldn’t be completed. (NSURRLErrorDomain error - 1200)

Any ideas what might be wrong?

post the output from

ls -l /shares/Public

this will show if the symlink looks ok

also try

ls /shares/Public/Shared\ Pictures/*

should see the contents of the foler in /shared/Private/Photos

note, Shared\ Pictures is case sensitive

also, post last few lines of a log file, i can’t remember the name, its in /var/log/wd2go.txt or something like that from memory.

I wouldn’t go to much further with this if you can’t get to work, might be best to revert back, but post the above info and we’ll see what it looks like.


Here we go. Seems to be a problem here. 

URL= [][/URL]

I Don’t suppose it’s this? /var/log/wdnas.log?

URL= [][/URL]

I think I’ve listed what’s in /var/log:

URL= [][/URL]

Any ideas?

Try that again:

No sorry, had wrong log file, just logged in mine and checked. The log file you want is


The log file will update when you do a wd2go server rebuild, under settings, remote access, advanced.

Post the last 10 lines of this after you do the rebuild.

Also post the ls commands i mentioned above

Hi there,

I’ll try the log file when I get home.

Regarding the other commands they are in the image link called PuTTY2

I have entered

ls -l /shares/Public and got a response


ls /shares/Public and got a response


ls /shares/Public/Shared\Pictures and got a ‘no such file or dir’ error.

I tried a few variations.

Thanks mate :slight_smile:

Ah ha, do you have a space after the , so Shared\ Pictures

I did try a few space variations. That may not have been one.

I will try when I get home.

Thanks for all this help :slight_smile:

Ok here we go:

That ls /shares/Public/Shared\ Pictures/* line still results in an error as you can see.

I also noticed I cannot write to the Public share when opened in windows.

Could it be that there’s still something left over from the original hack?

I changed those 2 lines back and they seem to have stuck but I was never sure if I should have repeated the command line or not, or entered a different one perhaps?

Here are the grabs: