Alternative Firmware (Debian Jessie, Synology DSM6)


#520

I would be happy with only OVM and Docker! :grinning:


#521

Well, me too. But TBH OMV is a bit of an overkill for this - too much software packaged together. I’ll keep asking around but I doubt that I’ll find a solution this without knowing the kernel error. Can you by any chance hook it up using an FTDI cable, and check the output? That would at least give us a starting point.


#522

hello
i’m try to update my wd home 3TB. But it’s possible? When i start partitioguru i not see my hd into.
Thanks


#523

Hi,

I installed DSM on my Mirror Gen2 and it booted and worked fine. Then I downloaded the latest 6.2 DSM from synology and did an update. This seemed also be fine.
Now I am on login screen and either I forgot my admin password and can’t login or the system changed after update the admin account and I can’t login.

Tried to reset the WD Mirror with a paper clip on the Reset switch but it doesn’t work.
Is this the bricking people are mentioning or am I doing something wrong?
How can I reset the DSM if the paperclip method (from the WD site) doesn’t work?
I tried both variants with powered on and 40-seconds without power plug initially pluged in.


#524

Hello everyone.
I’m still on the original WD firmware and struggling on the decision of which alternative firmware to use.
I would really love the idea to use a dsm like firmware but, to me, appear to persist too many bug and problems. Also the updates would not be automatic but dependent on fox_exe because there isn’t a full automatic script to perform all the required task to migrate the dsm firmware to our devices.
So the proposed debian+omv appear to be the best alternative.
So my question is:
the os will be installed on the nand, or in the hard drives?
the debian + omv will make we loose some functionalities like fan control?
debian can be updated or requires a new release from fox_exe every time?
the unit will support wake on lan?
The cryptograpic engine of the armada 385 will be available, to accelerate the encryption of the disks?
what about https://github.com/c-MM/mcm-daemon and https://forum.doozan.com/read.php?2,28939


#525

No, I do not think so! But you should not update DSM from Synology! Try to enter recovery mode, see above for details.


#526

To answer this question correctly you have to understand how an OS is constructed. The OS Linux has a kernel that communicates with the hadware and several programs on a file system that communicate with the kernel.

The kernel is on the NAND memory but all the programs are on a file system “ext4” on a partition on the hard drive in the NAS.

Yes, automatik “fan control” because you can set the fan speed with

/usr/sbin/mcu_ctl

“Wake on LAN” and “samba speed”. Maybe more, but that’s what I noticed.

Debian can be updated with the normal procedure. Only the kernel itself can not be updated without the releases of Fox_exe or you have to compile the kernel yourself.

See above.

Not sure what you mean.


#527

Thank you for replying.
I finally installed debian and omv on the wd ad got the answers I needed by my own, just before your reply.
I wonder if the stretch rootf can fit the nand to avoid the disk continue to spin. It looks small enough to fit but I don’t know how to try it.
About the auto fan speed and the wake on line, I found that on the doozan forum are available some patches and a daemon to manage them.
About the acceleration of the encryption, I’ve read the datasheet and found that the marvel armada has an encryption acceleration. The fox_exe kernel does not load it correctly (error -22) so with his kernel is not available.
So I’ve compiled the 4.14.59 following this guide https://themm.net/public/ex2u/start https://themm.net/public/ex2u/kernel and I’ll test it soon :slight_smile:
Hope to have luks encryption fully accelerated, fan daemon, power off and wol working (in contrast with fox_exe kernel)

Thank you!


#528

Yes, DSM depends on someone, either Fox_Exe or someone else making a new image, new kernel, etc. with every update. Unfortunately Syno is tight on their software and they make sure it only runs on official Syno hw (look up XPEnology if you want to see the struggle), so it isn’t as easy as pulling an official update package and installing that - some quite heavy modifications are usually required.

Both. The Debian image is set up in a way that kernel + base image (initramfs) is located on the NAND - it contains just a tiny bit of code enough to serve as a “recovery” mode using telnet, and an installer.

The parts of Debian that make it Debian (packages, configs, etc.) are installed on the HDD, that’s why there’s that pesky install process with multiple partitions. Unfortunately Debian base wouldn’t fit on our NAND (although if we did some cleanup, removed some stuff a NAS does not use, etc., we could possibly make it small enough that a base OS image is bootable with scripts that format the HDD, etc.).

Technically you’ll lose the automatic fan control, but Fox_Exe made a nice little open source controller for the MCU that controls the fans, LEDs, etc. which can be used as a proxy for setting fan control. In my experience leaving it at 100% is fine, since the disk will be spinning anyway all the time (due to swap + OS root being on them).

Debian can be updated of course, Fox_Exe’s firmware uses regular armhf Debian with a custom kernel. Just make sure you don’t install any of the linux-image-* packages, and you’re good to go. The kernel version is pretty new too, so for at least 2-3 years it should be fine for the latest Debian versions - but you can build your own kernel too, since everything is open source.

WOL doesn’t really work on our devices - technically it’s not WOL, it’s a rather finicky implementation. There’s an MCU in these NAS’, which is a low power CPU - think of it like an Arduino wired in to control some stuff. So this MCU can wake the device, if it receives certain packets on the Ethernet interface, but these are unfortunately nonstandard packets, so regular WOL won’t work, you need to use the WD app for it. Hopefully the MCU can be reprogrammed (its firmware should be open source, but it isn’t) so that it reacts to regular WOL messages too - but it won’t happen in the near future.

I have no idea about the encryption, but my guess would be no.


#529

I have an EX2 Ultra and tried to update straight to Firmware-debian-linux-4.14.4.bin from OFW. From what I understood of the directions it should have been a straightforward affair. However I’m now sitting here with a bricked NAS that won’t even boot to recovery from USB stick. ANY help in getting this thing working again would be appreciated. I do see something on my network with a mac address of “incomplete” according to arp, but it never lets me telnet into it and there is no recovery web interface.


#531

OK, I’ve made some progress with what I have. (I don’t have an FTDI cable right now) I am able to get my system to boot a recovery image from USB that I can tell. However, I don’t have any page to be able to recover the firmware from. I CAN see the NAS on my network. I think I have a TFTP server running on it but It’s hard to tell fully. Every device I try to connect to acts like it’s working. Now I hope I can get things working better some time tomorrow.


#532

I found that I actually DO have a UART cable, it was an old cable for programming 2GIG security panels. Just had to verify the pinout on it. Now I’ve got a port hooked up on my NAS that I soldered in place today so I can connect. But the post telling me how to actually connect and fix the thing has apparently been deleted. Is there an actual step by step that says what commands I need to enter so I can restore my system? I assume going back to stock would be the easiest first step.


#533

It is not deleted! Look

Fox_exe

Jun '16

dd if=/dev/zero of=/dev/mtdblock1
reboot -f

After this WDMC runs in “Rescue” mode. Go to webgui and upload original firmware file (.bin)

When kernel or ramdisk in internal nand drive is damaged (In mtdblock 1 and 2) - bootloader trying to boot recovery kernel (mtdblock4).
Another way: (Need USB flash drive)
Format it in Fat32
make dir “boot” and copy uImage-marvell-original and uRamdisk-marvell-recovery to this folder. Rename files as “uImage” and “uRamdisk”.
Connect this flash to WDMC Mirror, power on. Wait ~1 min, then you can connect to web interface (“Recovery mode”) and upload official firmware.

  • I have written about it at the Russian forum (4pda.ru 8), but have forgotten to duplicate in the archive…

But if you ask how to flash the /dev/mtdblock1 with directly with the original firmware you have to think a littel. For example:
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVSWYxWDBtS2wwejA


#534

I can connect via SSH to the EX2 Ultra but I’m still stuck. If I let it boot on it’s own I get stuck with it repeating “sh: noip2: not found” and never getting a network connection so I can’t go to a recovery console. If I interrupt I can get it to pull an IP Address with DHCP but no console. I assume I can do something with commands through SSH, but I have no clue what to actually enter here. At this point I would be beyond happy to just get back to stock firmware.


#536

Does anyone have any suggestions? I’m still stuck and am completely unable to use my NAS. I know I shouldn’t have even bothered trying without being 100% sure what I was doing was correct, but I just want to get it up and running at all at this point.


#538

@ghrayfahx
Maybe I can only help you to bring back to the recovery mode and flash the original firmware again on it. If you have SSH connection just this two commands.

dd if=/dev/zero of=/dev/mtdblock1
reboot -f

After the reboot the WD should just reboot into the recovery mode, if not try to switch it on while holding the reset botton until it reboots to flashing red lights.


#539

I can connect to the system via putty but it tells me DD is an unknown command.


#540

@Fox_exe

Hi Fox,

I have a at mycloud gen2 with your debian+omv and now also a mirror gen2 with debian stretch+omv. and at this point, you are doing a great work!

the single bay is working fine, no issues here. but there is a strange behaviour from the mirror.

…every time I reboot the device, the network interfaces gets a new Mac address…

I already tried to change/edit the udev rules, but this does not take effect. maybe you have any idea regarding that!?

best regards

jan


#541

Create file in:

/etc/network/if-up.d/set-mac

#!/bin/sh
ifconfig eth0 hw ether `dd if=/dev/mtd0 bs=1 skip=1046528 count=17 2>/dev/null`

Make it executable (maybe not necessary):

chmod a+x /etc/network/if-up.d/set-mac

So, this script set MAC to original when eth0 is up (At connect or reconnect LAN).

Change MAC Address:

echo -n '00:90:A9:12:34:56' | dd of=/dev/mtd0 bs=1 seek=1046528 conv=notrunc


#542

thank you for the quick response. I will test it tomorrow.

…are there more things “need to know” regarding the mirror gen2? or maybe tweaks, like fan control etc.?