Alternative Firmware (Debian Jessie, Synology DSM6)


#438

Hi Fox,

I have WD EX2 Ultra have installed Synology DSM6 with no issue with installation. However having same issue as @Rand and had to re-install DSM per your steps to him. I see that there is a discussion of a workaround. Do have that workaround or fix?


#439

Only workaround. I cant fix it because cant find what program changed (break) these libs.


#440

Hallo zusammen ich hoffe es ist jemand hier der Deutsch kann und mir helfen kann das DSM auf meine wdmycloud gen1 zu bekommen da ich mit der Beschreibung nicht ganz so zurecht komme.
Eventuell kann das auch jemand über teamviewer machen wenn ich ihm den Zugang gebe oder es mir so gut erklären das sogar ein blöder wie ich es hin bekomme.

Hi, I hope there is someone here who can speak German and help me to get the DSM on my wdmycloud gen1 because I’m not quite as coped with the description.
Maybe somebody can do that via teamviewer if I give him access or explain it to me so well that even a stupid guy like me gets it.

Lg
Pat


#441

Hi,

I have a mycloud ex4 on my desktop and want to have a clean debian system.

I found this site, and the link to the files, but I didn’t found a good howto, so I have some questions:

  1. What about this app?
    http://fox-exe.ru/WDMyCloud/WDMyCloud-Ex4/Apps/WDMyCloudEX4_Debian-armel_8.0-2.bin

I think it is a chroot environment. It’s maybe the best way for me, but it doesn’t work. I installed the app and nothing happens. How can I use the chroot system??

  1. Maybe I want to install a real debian, not the chroot. Is there any documentation how to do this?

  2. By the way, where is the origin firmware stored? Is there a flash storage on the ex4??

regards
tux007


#442

@tux007,

  1. Yes, its chroot’ed debian. Login:
    chroot /mnt/HD/HD_a2/Nas_Apps/chroot/chroot /bin/bash
  2. https://fox-exe.ru/WDMyCloud/WDMyCloud-Ex4/Debian/
  3. Nand chip on board. (256 or 512MB). 3rd partition (compressed squashfs, mounted as “loop” device with changes stored in RAM.)

Seems like Ex4 similar to Ext2 Ultra / Mirror Gen2. Read documentation for these devices.
Also check your CPU and RAM info. If Ex4 have same cpu and ram size - possible to use Debian (And documentations) from Mirror Gen2.


#443

Hi there, could you PM me? (haven’t seen that button anywhere here :O) I have a few questions about how to upgrade an Ex2 NAS? In addition, some others about performance and apps which can be installed.

Thank you!


#444

I tried to install the OMV to my Cloud Mirror Gen. 2.
But nothing worked as described. Now my Mirror is dead and I trie to install the Recovery Image.

###################################
#
# One of success-story with this howto: 
# https://community.wd.com/t/my-cloud-gen2-using-an-8tb-hdd-and-formatting-failure-error-code-600/221499/1
#
###################################

=====================================
# Alternative way:

# Use Debian/ubuntu or any other linux distro (USB/CD Live image)
# All "/dev/sda" change to your disk! (List disks in system: "parted -l")
# If this is new disk or damaged (formatted) old, recreate partitions first:
parted /dev/sda
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB
q
mkswap /dev/sda1
mkfs.ext4 /dev/sda3

# Download and unpack files from WDMyCloud/WDMyCloud-Gen2/Developing: uImage-wdrecovery and uRamdisk-wdrecovery
# Write it disk:
mkdir /mnt/boot
mount /dev/sda3 /mnt/boot
mkdir /mnt/boot/boot
cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

# Done. Connect disk back to WDMC and turn on.
# After few minutes WDMC boots to "WD Recovery". Go to webgui and upload official firmware.
# Done!

There where no errors so all steps done, but I can’t access the WebGUI.
Just 404 Not found, and yes I got the new IP from my fritz.box.

Any suggestions?


#445

Hi there,

I followed the Instructions to install DSM on my mirror gen 2. Then i wanted to go back to original Firmware and i followed the instruction to Go back. But now im stuck at the wd recovery page. Firebug told me about some js errors (some post request to system_mgr.cgi with „cmd“ Parameters ended in a 404-Error) . USB recovery also unsuccessful (wont boot from usb). Btw. non of the led are on (only at boot they are blinking)

Can anybody help???


#446

@Fox_exe,

I’m still the newbie that I was. But at least I can say that I own a WDMyCloud-EX2-Ultra.:wink:

Isn’t it possible to watch this lib files?

@All
But now to my actual question. Can you tell me or anyone here how to get docker on the mentioned device in the debian chroot? In the non chroot environment docker seems to be running, but I do not have access via ssh.

@Patjutzu
Schreib mir eine PN, wenn du immer noch Hilfe suchst.

@piksi
What do you mean with “upgrade an Ex2 NAS”?

@RockKeeper
Have you tried the alternative way described in _Unbricking_en.txt


#447

@all
Forget it, i just started docker with /usr/sbin/docker_daemon.sh start.


#448

@Q-Fireball Yes, it doesn’t seems to boot from USB (stick shows no activity, now yellow blinking lights, no telnet possible). Any other Idea? Do i have to do something else to get the box booting from USB-Stick? (Yes, its fat32 formatted :wink: )


#449

@Q-Fireball I’m still at the safemode screen where an upload isn’t possible…


#450

No, the alternative way is to unplug the hard drives from the NAS and follow the instructions under:

Alternative way:

Use Debian / ubuntu or another Linux distribution (USB / CD Live Image)
All “/ dev / sda” will change to your hard drive! (List disks in the system: “parted -l”)
If this is a new hard disk or is damaged (formatted) old, first rebuild the partitions:


#451

So I tried it since nearly one week to get my WDCloud Mirror 6TB working again.
I tried all stuff i could found. I extracted my HDD’s and bootet ubuntu live and formatted and restored my disks.

The LED is always blue (also if its just one disk inside both LED’s are blue), but I don’t get an WebGui its always 404 not found.

Is it important to have both disks running or should it also work with one disk?
Not sure what I can try further…

It’s not so important that I restore the original firmware, also DSM or OMV is okay, but I’m not able to get one of these running.

Please help me.


#452

@B0mB3r
First you have to find the right device. Is it a mirror gen1 or a mirror gen2? And then just follow the instructions for the alternative way. As described, upload the official firmware via the recovery webgui. If you have the 404 error, you probably do not have the correct IP of the recovery webgui.


#453

@all
Ok, the ex2’s original docker is too old and does not work as it should. How can I run Docker in the chroot environment? With me crashes immediately, as soon as I want to pull a container.


#454

Thanks for your answer. That’s exactly what I did. But for the mirror Gen 2 there is no recovery image it’s just for mycloud Gen 2.

Also tried to use the original Images from the mirror Gen 2 folder, but nothing happens.

The ip is hopefully the ip from the device I see in my Fritz.box or is this ip different?!

After 10-20 seconds after I powered on the NAS, I see an new entry in my Fritz.box dashboard like “PC192-168-178-XX” which wasn’t there before so I guess this is the ip from my nas.


#455

So you partitioned your HDD new with a live Linux and run

mkdir / mnt / boot
mount / dev / sda3 / mnt / boot
mkdir / mnt / boot / boot
cp uImage-wdrecovery / mnt / boot / boot / uImage
cp uRamdisk-wdrecovery / mnt / boot / boot / uRamdisk

With the uImage and uRamdisk from here?
And you didn’t get a recovery console on the new assigned ip address?
Can you ping the device? Can you telnet the device?

If everything is failing than you have to recover with a USB Serial cable and uart, but this is really work and usually means that you did something seriously wrong or even something is broken.


#456

That’s correct. I always get 404 not found on the new IP.

ubuntu@ubuntu:~$ ping 192.168.178.55
PING 192.168.178.55 (192.168.178.55) 56(84) bytes of data.
64 bytes from 192.168.178.55: icmp_seq=1 ttl=64 time=0.165 ms
64 bytes from 192.168.178.55: icmp_seq=2 ttl=64 time=0.220 ms
64 bytes from 192.168.178.55: icmp_seq=3 ttl=64 time=0.222 ms
64 bytes from 192.168.178.55: icmp_seq=4 ttl=64 time=0.190 ms
64 bytes from 192.168.178.55: icmp_seq=5 ttl=64 time=0.206 ms
^C
--- 192.168.178.55 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4086ms
rtt min/avg/max/mdev = 0.165/0.200/0.222/0.026 ms

ubuntu@ubuntu:~$ telnet 192.168.178.55
Trying 192.168.178.55...
Connected to 192.168.178.55.
Escape character is '^]'.

I think this is working but get no UI =(

For me it’s not necessary to go back to Original UI. Like I mentioned before DSM or OMV would be a good alternative. Is there an Tutorial to install one of these without install the Firmware from the WD UI?

tried to install OVM + Debian, but it does not work. Any chance to install DSM from scratch?


#457

Sorry for waiting, did you followed the instruction:
“On first login you can get “Error 404: Not found”. Just clear browser cache and check URL (There is no “/UI” string anymore)”