Alternative Firmware (Debian Jessie, Synology DSM6)


#338

Sorry, only one different - Memory size (512mb vs 1GB). All other - same.
But DTB with 512mb won’t boot at 1gb ram and vise versa.
Im recreate kernel’s later…


#339

So why does the Gen2 Image you created work with my Ultra 2? (with the known stability issues, but else working fine) ?

cat /proc/meminfo
MemTotal: 1030132 kB
MemFree: 268228 kB
Buffers: 29508 kB

used DSM-wdmc-mirror-gen2-8451.pat…

Edit:
Created a script - will let it run for a while to see whether it helps (and works;) )


#340

Im totally confused…
Some people says “Its not work”, some “Works great”… Where is true? o_O


#341

For my part I can say I have an Ultra 2 and installation worked without issues.
The only problem I have, is that I loose GUI access (multiple times) and my volume (once) without doing anything with it - maybe/hopefully due to the 4 files getting corrupted. The effect is that I have to restore.
Additionally the known issue of reboots not working properly.
And just found out I can’t enable iscsi-target, so that might not be fixed completely.


#342

Hi rand

which steps exactly did you make to change the system

  1. I have do flash wd-to-dsm.bin and then follow the steps in the info_en ?

and how will this file be installed is this automatically installed somehow ??
DSM-wdmc-mirror-gen2-8451.pat

Any answer would be nice. Im really confused because there is no complete tutorial.

But i have read also all your post here. So the dsm runs very unstable yet ? Sounds not got to always reinstall the system


#343

@Fox_exe Sorry to ask again but is the DL2100 supported here? Thanks!


#344

Well its not excessively documented but its all there;)
“# Install:
Go to webgui and install “wd-to-dsm.bin” as firmware
After reboot you can access to DSM WebInstaller (http://diskstation or http://wdmcmg2)
Please, dont chose any of “Feedback” options.”

So:
Go to webgui in the WD firmware and install a new update, from file and use wd-to-dsm.bin.
Then run Synology Installation Agent to discover your new “Diskstation”, access the webinterface.
Install DSM-wdmc-mirror-gen2-8451.pat as the new firmware
Make sure not to choose feedback or remote login options and don’t update firmware automatically obviously.

And atm yes its somewhat unstable for unknown reasons, I hope the 4 files getting corrupted are the main issue.
For now its running again, will see how it goes :pray:

Edit: Lol, broke it before I finished typing the above:

Starting check at 20170504081338
/usr/lib/libfileindex.so exists: 277f97c503c00480d34237fe830e5a2e =>MD5 Nok, moving file to /usr/lib/libfileindex.so.20170504081338
/usr/lib/libsynopkg.so exists: d972d5e5e7c3f5366bddbbbaaebce074 => MD5 Nok, moving file to /usr/lib/libsynopkg.so.20170504081338
/usr/lib/libsynoshare.so exists: 781a87d76941b175d853ea79dadc2299 => MD5 Nok, moving file to /usr/lib/libsynoshare.so.20170504081338
/usr/lib/libsynostoragemgmt.so exists: c130e03afe9e31e5d5bd8cda702bdeae => MD5 Nok, moving file to /usr/lib/libsynostoragemgmt.so.20170504081338

bash-4.3# md5sum libfileindex.so.20170504081338 libfileindex.so
277f97c503c00480d34237fe830e5a2e libfileindex.so.20170504081338
0d277fbe68caee19da319619266e4898 libfileindex.so

Basically I caused it by trying to enable NFS sharing (since iSCSI didnt work).
The script didn’t work properly with the symlinks so it didn’t auto-fix yet.
Manually replaced the files (telnet continues to work while GUI & ssh don’t), rebooted and it seems to work again, which would be great:) Will test some more.


#345

Hi rand

thanx for the explanation !!

But now im thinking to give my ex2 ultra back to amazon. I have 20 days left. I did take a look at synology and dsm 6.1 and it is 100 times better than this shi… and cheasy programmed nas station by western digital with 3 years old apps and a buggy and sometimes lame system

I mean with respect of the work from Fox_exe but i have some doubts at the moment that the system is really stable. I do not want to reinstall every week the system :slight_smile:

–> Western digital guys : It´s a shame that you are selling a nas system with outdated and buggy firmware and old apps and you do nothing against this.


#346

Totally up to you:)


#347

I have bought this here now …the ultra goes back

Synology DiskStation DS216+II 12TB Bundle [Inkl. 2x 6TB WD Red 3,5" NAS HDD]

  • 8 gb ram extra

thats 100 times better. ok 240 $ more expensive but with a good and reliable system


#348

Have fun with it:)


#349

@Fox_exe
The DSM firmware for WD MyCloud Mirror Gen 2 is based on ds216j firmware?


#350

Check /tmp folder size. I see once is /tmp used at 100% before all crashed.
Need check this situation…


#351

Added it to the script, that’s running in 5 min interval.

Edit:
Ok, for the last days i didn’t do anything with the box except creating the script via cli - no issues.
Just went on to install audio station to start using it - boom:

Was fine a few seconds ago - “Starting check at 20170506110501 … /tmp=1% done”
So it must have been the gui interaction causing this - why - no idea

Additionally the modification seems to be ongoing… found multiple changed file each, i.e. had to run the scripts multiple times until the original file remained…

bash-4.3# md5sum libfileindex.so libfileindex.so.*
0d277fbe68caee19da319619266e4898 libfileindex.so
277f97c503c00480d34237fe830e5a2e libfileindex.so.20170504081338
44654068f05bddad1e7703ec23ace16d libfileindex.so.20170506015501
a6f6509cef68350b36f76ac6058ce756 libfileindex.so.20170506110832
5cf7b8473e16df44548fb7b86e2e5205 libfileindex.so.20170506111001
f2a4136489eba973f539bcc82ee0b002 libfileindex.so.20170506111211
0d277fbe68caee19da319619266e4898 libfileindex.so.6
0d277fbe68caee19da319619266e4898 libfileindex.so.6.0
0d277fbe68caee19da319619266e4898 libfileindex.so.bak

bash-4.3# md5sum libsynopkg.so*
912617dcdb7339cc021a94d720ec7c9f libsynopkg.so
912617dcdb7339cc021a94d720ec7c9f libsynopkg.so.1
912617dcdb7339cc021a94d720ec7c9f libsynopkg.so.20170504081338
79d98e6cec605cbbbf6f8c174f93aabd libsynopkg.so.20170506015501
0928f978c3d24cdffb2e6fc328a1904f libsynopkg.so.20170506110832
4d8364f49289fa8fa094a65db8edbec2 libsynopkg.so.20170506111211
912617dcdb7339cc021a94d720ec7c9f libsynopkg.so.bak

bash-4.3# md5sum libsynoshare.so*
e93361bfaafba00f076ac557070c068d libsynoshare.so.20170504081338
124841f28a13a180a31452ef9ba0a3c7 libsynoshare.so.20170506015501
ba0ef2575900bf0c284fe0d88ac1e2a3 libsynoshare.so.20170506110832
4e73dff9f02abb255677627bfc7aa224 libsynoshare.so.20170506111001
e93c88a8cc2810aed0ae92df1855839d libsynoshare.so.20170506111211
1a1119f24ef90ef34764962f8603adf6 libsynoshare.so.20170506111501
e93361bfaafba00f076ac557070c068d libsynoshare.so.6
e93361bfaafba00f076ac557070c068d libsynoshare.so.bak

bash-4.3# md5sum libsynostoragemgmt.so*
18006ff90915bccf55f39605a34bf2f0 libsynostoragemgmt.so
c130e03afe9e31e5d5bd8cda702bdeae libsynostoragemgmt.so.20170504081338
3692cfe054e65537bb7a363373975e06 libsynostoragemgmt.so.20170506015501
1814ab7eb3e98d10632513be5f3b9005 libsynostoragemgmt.so.20170506110832
90d8ec87b80546f8d415a96b82ac343b libsynostoragemgmt.so.20170506111001
09b231cb96284512d2178206707b6c3b libsynostoragemgmt.so.20170506111211
6b14ec471b915755035aef916b94fda0 libsynostoragemgmt.so.20170506111501
2d86bef3efc4bbb4155d68ff5341369f libsynostoragemgmt.so.bak

bash-4.3# /root/test_md5.sh
Starting check at 20170506111559 /usr/lib/libfileindex.so exists, should have: 0d277fbe68caee19da319619266e4898 but has 8f0ce68314119caea67f9d5e3c52cc5c => MD5 Nok, moving file to /usr/lib/libfileindex.so.20170506111559
/usr/lib/libsynopkg.so exists, should have: 912617dcdb7339cc021a94d720ec7c9f but has d5f0cc7dc90b67ba59c69691114db87d => MD5 Nok, moving file to /usr/lib/libsynopkg.so.20170506111559
/usr/lib/libsynoshare.so exists, should have: e93361bfaafba00f076ac557070c068d but has 3d133ceb1218b860ea3de75a1b2fcda2 => MD5 Nok, moving file to /usr/lib/libsynoshare.so.20170506111559
/usr/lib/libsynostoragemgmt.so exists, should have: 2d86bef3efc4bbb4155d68ff5341369f but has bf16628042a5b73c7ad5e5b488e9f26e => MD5 Nok, moving file to /usr/lib/libsynostoragemgmt.so.20170506111559
_ /tmp=100% done_

bash-4.3# /root/test_md5.sh

Starting check at 20170506111637 … /tmp=100% done

/tmp is indeed full and is still being written to (new timestamps):

bash-4.3# ls -ltr /tmp
total 515060
-rw------- 1 root root 22779932 May 6 11:13 5xBIHA
-rw------- 1 root root 36741004 May 6 11:13 Imb6P3
-rw------- 1 root root 27850316 May 6 11:13 50h5qC
-rw------- 1 root root 41849256 May 6 11:13 2Poi2b
-rw------- 1 root root 37755972 May 6 11:13 x41RPR
-rw------- 1 root root 40424932 May 6 11:13 oyLNZB
-rw------- 1 root root 41667372 May 6 11:13 vE8P0m
-rw------- 1 root root 29246740 May 6 11:13 oPNi2c
-rw------- 1 root root 24927012 May 6 11:13 bd9QX4
-rw------- 1 root root 35970596 May 6 11:13 UGSTh0
-rw------- 1 root root 37304896 May 6 11:13 DcBvs1
-rw------- 1 root root 24284012 May 6 11:13 IjzUJ3
-rw------- 1 root root 22399792 May 6 11:13 PB0xa8
-rw------- 1 root root 35054692 May 6 11:13 soHd2e
-rw------- 1 root root 34306116 May 6 11:13 ewIrcg
-rw------- 1 root root 34832384 May 6 11:13 YMa55m

bash-4.3# ls -ltr
total 515060
-rw------- 1 root root 37296504 May 6 11:18 c7fGoh
-rw------- 1 root root 26402640 May 6 11:18 36M7Gi
-rw------- 1 root root 26929796 May 6 11:18 A2AGln
-rw------- 1 root root 32805560 May 6 11:18 buOaZt
-rw------- 1 root root 28346264 May 6 11:18 0Oq5VB
-rw------- 1 root root 26976280 May 6 11:18 HFTdhP
-rw------- 1 root root 25156544 May 6 11:18 at8bR4
-rw------- 1 root root 30786532 May 6 11:18 F526sm
-rw------- 1 root root 32450852 May 6 11:18 6be0JF
-rw------- 1 root root 41630152 May 6 11:18 bd8UK1
-rw------- 1 root root 27399992 May 6 11:18 YQmiHr
-rw------- 1 root root 26149948 May 6 11:18 RXweMU
-rw------- 1 root root 31943944 May 6 11:18 gNZOYp
-rw------- 1 root root 27653108 May 6 11:18 pmG4n1
-rw------- 1 root root 37434572 May 6 11:18 U43sWE
-rw------- 1 root root 31485580 May 6 11:18 ZXbPqj
-rw------- 1 root root 26713224 May 6 11:18 6zk233
-rw------- 1 root root 9826304 May 6 11:18 HhoJWQ

bash-4.3# rm -rf c7fGoh 36M7Gi A2AGln buOaZt 0Oq5VB HFTdhP at8bR4
bash-4.3# df -k
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/md0 2385528 802444 1464300 36% /
none 512472 4 512468 1% /dev
/tmp 515064 315916 199148 62% /tmp
/run 515064 2200 512864 1% /run
/dev/shm 515064 4 515060 1% /dev/shm
none 4 0 4 0% /sys/fs/cgroup
/dev/vg1000/lv 7747531340 2514405432 5233007124 33% /volume1

But I am not sure what those are … they seem to be empty?
bash-4.3# head -10 F526sm
bash-4.3# cat F526sm
bash-4.3# ls -ltr F526sm
-rw------- 1 root root 30786532 May 6 11:18 F526sm

quite weird

Edit: The good thing is - with replacing the 4 libs and cleaning up /tmp the box comes up working after a reboot.

Noteworthy, after the reboot /tmp looks like this:

bash-4.3# cd /tmp/
bash-4.3# ls -ltr
total 236
-rw-r–r-- 1 root root 4964 Aug 2 2016 synodrivedb.db
-rw-r–r-- 1 root root 157496 Aug 2 2016 drivedb.db
-rwxr-xr-x 1 root root 12601 May 6 11:27 synoschedtask
-rwxr-xr-x 1 root root 8973 May 6 11:27 synoschedtool
-rw-r–r-- 1 root root 2366 May 6 11:27 scheduled_tasks
drwxrwxrwt 2 root root 40 May 6 11:27 DSMTaskMgr
prwxr-xr-x 1 root root 0 May 6 11:27 syslog_recv.fifo
-rw-r–r-- 1 root root 0 May 6 11:28 firewall_iptables_exec.lock
-rw-r–r-- 1 root root 0 May 6 11:28 eunitseq
-rw-r–r-- 1 root root 0 May 6 11:28 syno_scemd.lock
-rw-r–r-- 1 root root 0 May 6 11:28 synoups.lock
-rw-r–r-- 1 root root 0 May 6 11:28 iptables_serv_mod_map.lock
-rw-r–r-- 1 root root 0 May 6 11:28 snap-origin-module-init
-rw-r–r-- 1 root root 0 May 6 11:28 vspace_layer.lock
-rw-r–r-- 1 root root 12 May 6 11:28 sshd.reference
-rw-r–r-- 1 root root 0 May 6 11:28 synoproxy.conf
-rw-r–r-- 1 root root 8 May 6 11:28 downloadHelp.error
drwxr-xr-x 2 root root 80 May 6 11:28 ssdp
srwxr-xr-x 1 root root 0 May 6 11:28 synosnmpcd.sock
drwxr-x— 2 root root 160 May 6 11:28 synocrond
srwxr-xr-x 1 root root 0 May 6 11:28 scemd_event_handler.sock_server
-rw-r–r-- 1 root root 26 May 6 11:28 buzzerCurrentBitMap
srwxr-xr-x 1 root root 0 May 6 11:28 scemd_connector.sock_server
-rw-r–r-- 1 root root 0 May 6 11:28 tcm_service_state.lock
-rw-r–r-- 1 root root 0 May 6 11:28 ep_journal_access.lock
prw–w---- 1 root root 0 May 6 11:28 synocomm_pipe_svr_msg_req
prw–w---- 1 root root 0 May 6 11:28 synocomm_pipe_rep_4649
drwxr-xr-x 2 root root 80 May 6 11:28 syno_led_brightness
drwxr-xr-x 2 root root 120 May 6 11:28 S2S
drwxr-xr-x 2 root root 40 May 6 11:28 lock
-rw-r–r-- 1 root root 783 May 6 11:28 usbdebug
-rw-r–r-- 1 root root 8 May 6 11:31 downloadSynohdpack.error
-rw-r–r-- 1 root root 7 May 6 11:31 boot_seq.tmp
drwxr-xr-x 3 root root 120 May 6 11:31 space
-rw-r–r-- 1 root root 6 May 6 11:31 standbytime
-rw-r–r-- 1 root root 0 May 6 11:31 iptables_scripts.lock
-rw-r–r-- 1 root root 608 May 6 11:33 enumlist_det
-rw-r–r-- 1 root root 0 May 6 11:33 user_agent.lock
lrwxrwxrwx 1 root root 26 May 6 11:33 pkglist.tmp -> /volume1/@tmp/pkglist. tmp/
-rw-r–r-- 1 root root 44 May 6 11:34 ddns.info
-rw-rw-rw- 1 root root 44 May 6 11:34 login_fail.list
prw-r----- 1 root root 0 May 6 11:34 syslog_local.fifo
bash-4.3#

Additionally, installing Audio station worked flawlessly this time…


#352

Again playing with nfs in gui, this time ‘only’ /tmp got full


#353

Im think - its cache files. But who create this?
Hmm… Maybe increase /tmp size?

Situation seems like that:
We do something in GUI.
One of services (GUI? Daemon?) make cache (temp) files in /tmp
/tmp goes full because old temp files not removed
Another daemon trying to write something to /tmp, but get “Buffer overflow” exception and write to HDD except RAM… (Or to the area of the memory belonging to other program)

Need “lsof” tool for check who uses these files or something, for check - who create these files.


#354

I see lsof is part of the ipkg supported tools, so will try to deploy it via these.
Anything in particular I should be looking for (lsof options you want to see) ?


#355

Hi,

I also noticed that after a few weeks, that the WebGui reported that the tmp was full and therefore I couldn’t log on. I rebooted the machine to find that the WebGui now actively refuses the connection., All my SMB shares are working as expected. I logged into SSH to find the following:

admin@toasteroven:/$ df -k
Filesystem         1K-blocks       Used  Available Use% Mounted on
/dev/md0             2385528    2368604          0 100% /
none                  253460          4     253456   1% /dev
/tmp                  256044        460     255584   1% /tmp
/run                  256044       4584     251460   2% /run
/dev/shm              256044          4     256040   1% /dev/shm
none                       4          0          4   0% /sys/fs/cgroup
/dev/vg2/volume_2 1917967448  116310484 1801538180   7% /volume2
/dev/vg1/volume_1 1917967448 1210286720  707561944  64% /volume1

It doesn’t actually look like my tmp folder is a problem in this case, though, my flash device, /dev/md0, is reported as full. Do you suppose that’s a problem? Note that this is the release of Fox_Exe’s that doesn’t have native flash support. So many that explain that. I also haven’t had any problems with corruption yet. At least not noticeably. I’m using the version before Fox_Exe’s Feb 26th update.

Edit: More digging…

I looked into what was filling up my root, and it looked like the var folder and more specifically /var/log/messages (808M) and /var/log/kern.log (also 808M). The tail of each of those contained SMI Busy Timeout messages. I removed them both, and rebooted, and I have the gui back!


#356

Turned out out my libsynopkg.so.1 was indeed corrupted, but none of the other 3 libraries were. I replaced it and rebooted, and miraculously my Resource Monitor from the WebGui started working again! I also had troubles with The Storage Manager app, and it’s also working as expected now. In addition, all of my samba shares are untouched and happy.

Problem: Resource Monitor and Storage Manager not working?
Potential Solution: Check your libsynopkg.so.1 file. Replace it if corrupted.

Problem: WebGui not working?
Potential Solution: Check your usage with df -k and consider removing /var/log/messages and /var/log/kern.log if they have ballooned out of control.


#357

Edit:
Got lsof going:
-Installed ipkg using this guide (https://thingshardtofind.blogspot.de/2015/06/optware-ipkg-and-bootstrap-for-synology.html (changing Alpine to Arm in the sh )